summaryrefslogtreecommitdiff
path: root/recipes-bsp/multitech/mtac_4.0.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/multitech/mtac_4.0.7.bb')
-rw-r--r--recipes-bsp/multitech/mtac_4.0.7.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes-bsp/multitech/mtac_4.0.7.bb b/recipes-bsp/multitech/mtac_4.0.7.bb
index b032a9a..ca872e2 100644
--- a/recipes-bsp/multitech/mtac_4.0.7.bb
+++ b/recipes-bsp/multitech/mtac_4.0.7.bb
@@ -27,8 +27,11 @@ S = "${WORKDIR}/git"
inherit module
+MTS_EXTRA_SYMBOLS="${STAGING_INCDIR}/mts-io/Module.symvers"
+
COMMON_OEMAKE = " -C ${STAGING_KERNEL_DIR} \
KBUILD_VERBOSE=1 \
+ KBUILD_EXTRA_SYMBOLS="${MTS_EXTRA_SYMBOLS}" \
M=${S} \
modules \
"
@@ -56,6 +59,8 @@ fakeroot do_install () {
# use cp instead of install so the driver doesn't get stripped
cp ${S}/mtac.ko ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra
+ install -Dm0644 ${S}/Module.symvers ${D}${includedir}/${BPN}/Module.symvers
+
install -d ${D}${includedir}/mts-kernel-headers/linux
install -m 0644 ${S}/mtac.h ${D}${includedir}/mts-kernel-headers/linux
cp ${S}/machine/* ${D}${includedir}/mts-kernel-headers/linux