summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/rs9113/rs9113-from-src_1.5.6.bb (renamed from recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb)13
-rw-r--r--recipes-kernel/rs9113/rs9113_1.5.6.bb (renamed from recipes-kernel/rs9113/rs9113_1.5.0.bb)0
2 files changed, 10 insertions, 3 deletions
diff --git a/recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb b/recipes-kernel/rs9113/rs9113-from-src_1.5.6.bb
index 234d6c9..c490ae1 100644
--- a/recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb
+++ b/recipes-kernel/rs9113/rs9113-from-src_1.5.6.bb
@@ -44,10 +44,17 @@ do_compile () {
do_patch () {
cd ${WORKDIR}/git
- echo "patches" ${M}/patches/*
for f in ${M}/patches/* ; do
- echo "Patching with ${f}"
- patch -p1 < ${f}
+ # Cannot use [[ $f =~ \.patch$ ]] here because the $ after patch breaks the recipe.
+ if echo ${f} | grep '\.patch$' >/dev/null 2>&1 ; then
+ echo found patch ${f}
+ patch -Np1 < ${f}
+ else
+ fname=$(basename ${f})
+ oldf=$(find . -name ${fname})
+ echo "copying $f to ${oldf}"
+ cp ${f} ${oldf}
+ fi
done
}
diff --git a/recipes-kernel/rs9113/rs9113_1.5.0.bb b/recipes-kernel/rs9113/rs9113_1.5.6.bb
index fbfb706..fbfb706 100644
--- a/recipes-kernel/rs9113/rs9113_1.5.0.bb
+++ b/recipes-kernel/rs9113/rs9113_1.5.6.bb