summaryrefslogtreecommitdiff
path: root/recipes-kernel
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2019-02-14 11:45:16 -0600
committerJohn Klug <john.klug@multitech.com>2019-07-03 11:22:01 -0500
commit9d0fc75188d6d90e3bd62bffa669aad4c6ae81fc (patch)
tree1f5627088b9ac73480b4c322911747e74ffb0efe /recipes-kernel
parent12679852b750945fd907224ff9f4e41b56e0bcc8 (diff)
downloadmeta-multitech-9d0fc75188d6d90e3bd62bffa669aad4c6ae81fc.tar.gz
meta-multitech-9d0fc75188d6d90e3bd62bffa669aad4c6ae81fc.tar.bz2
meta-multitech-9d0fc75188d6d90e3bd62bffa669aad4c6ae81fc.zip
Remove wpa_supplicant init script from rs9113-noarch, and simplify recipe.
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/rs9113/rs9113-from-src_1.6.1.bb2
-rw-r--r--recipes-kernel/rs9113/rs9113.inc28
-rw-r--r--recipes-kernel/rs9113/rs9113_1.6.1.bb3
3 files changed, 13 insertions, 20 deletions
diff --git a/recipes-kernel/rs9113/rs9113-from-src_1.6.1.bb b/recipes-kernel/rs9113/rs9113-from-src_1.6.1.bb
index 0de8d3b..328ef6e 100644
--- a/recipes-kernel/rs9113/rs9113-from-src_1.6.1.bb
+++ b/recipes-kernel/rs9113/rs9113-from-src_1.6.1.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "USB Driver for Redpine RS9113"
LICENSE = "Proprietary"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
PROVIDES = "rs9113-from-src"
-PR = "r4.${MLINUX_KERNEL_VERSION}${MLINUX_KERNEL_EXTRA_VERSION}"
+PR = "r5.${MLINUX_KERNEL_VERSION}${MLINUX_KERNEL_EXTRA_VERSION}"
INHIBIT_PACKAGE_STRIP = "1"
BB_STRICT_CHECKSUM = "0"
inherit module
diff --git a/recipes-kernel/rs9113/rs9113.inc b/recipes-kernel/rs9113/rs9113.inc
index 0ef9277..750060e 100644
--- a/recipes-kernel/rs9113/rs9113.inc
+++ b/recipes-kernel/rs9113/rs9113.inc
@@ -75,34 +75,21 @@ python do_fetch_prepend () {
os.system(ex + ";" + gt + "|" + tar)
}
+# Required drivers for Bluetooth and WiFi
FILES_kernel-module-${PN} = " \
/opt/rs9113/*.ko \
"
+# Required utility
FILES_${PN}-util = "/opt/rs9113/transmit \
/opt/rs9113/onebox_util \
"
FILES_${PN}-dbg = "/opt/rs9113/.debug/bt_bbp_utils \
- /opt/rs9113/.debug/bbp_util \
- /opt/rs9113/.debug/zb_bbp_util \
- /opt/rs9113/.debug/transmit \
- /opt/rs9113/.debug/zb_util \
- /opt/rs9113/.debug/bt_transmit \
- /opt/rs9113/.debug/onebox_util \
- /opt/rs9113/.debug/receive \
- /opt/rs9113/.debug/zb_transmit \
- /opt/rs9113/.debug/bt_util \
- /opt/rs9113/.debug/START_RS9116_NBZ_D0N \
- /opt/rs9113/.debug/sniffer_app \
- /opt/rs9113/.debug/transmit_packet \
- /opt/rs9113/.debug/bt_receive \
+ /opt/rs9113/.debug \
"
-# pmemdata is for upgrading rs9113 non-volatile firmware
-# *.rpm are firmware files for various modes of
-# rs9113 or rs9116 operation. MODE_PER is for
-# certification testing.
+# ELF files here are not normally installed on images.
FILES_${PN}-utils-extra = " \
/opt/rs9113/zb* \
/opt/rs9113/bt_transmit \
@@ -121,6 +108,12 @@ FILES_${PN}-utils-extra = " \
/opt/rs9113/START_RS9116_NBZ_D0N \
"
+# pmemdata is for upgrading rs9113 non-volatile firmware
+# *.rps are firmware files for various modes of
+# rs9113 or rs9116 operation.
+# MODE_PER is for certification testing.
+# ZIGBEE is not supported.
+# Files here are not normally installed on images.
FILES_${PN}-misc = " \
/opt/rs9113/firmware/RS9113_WLAN_BT_DUAL_MODE_PER.rps \
/opt/rs9113/firmware/RS9113_ZIGBEE_ROUTER.rps \
@@ -136,6 +129,7 @@ FILES_${PN}-misc = " \
/opt/rs9113/p2pcommands.pl \
/opt/rs9113/*reg \
/opt/rs9113/afe_spi \
+ /opt/rs9113/init.d \
"
CONFFILES_${PN}-noarch = "${sysconfdir}/default/"
diff --git a/recipes-kernel/rs9113/rs9113_1.6.1.bb b/recipes-kernel/rs9113/rs9113_1.6.1.bb
index 2bf98c5..24781d5 100644
--- a/recipes-kernel/rs9113/rs9113_1.6.1.bb
+++ b/recipes-kernel/rs9113/rs9113_1.6.1.bb
@@ -14,8 +14,7 @@ RDEPENDS_${PN} += "bash"
# To update this, manually copy ipk from Jenkin's job to
# git://git@${MTS_INTERNAL_GIT}/mlinux/ipk.git;protocol=ssh;branch=${PV}
#
-# r1 is the new firmware, 1.6.24.0, so upgrades will work.
-PR = "r4.${MLINUX_KERNEL_VERSION}${MLINUX_KERNEL_EXTRA_VERSION}"
+PR = "r5.${MLINUX_KERNEL_VERSION}${MLINUX_KERNEL_EXTRA_VERSION}"
SRC_URI = " \
file://rs9113/rs9113.init \
file://rs9113/rs9113.default \