summaryrefslogtreecommitdiff
path: root/recipes-devtools
diff options
context:
space:
mode:
authorAndrii Pientsov <andrii.pientsov@globallogic.com>2020-05-13 14:42:23 +0300
committerAndrii Pientsov <andrii.pientsov@globallogic.com>2020-05-13 14:42:23 +0300
commit6e609b4721c4816050f0d201cad5f063adcff867 (patch)
tree5787dd6104539175cb9670587a7bb8c64b4d6c60 /recipes-devtools
parent87ba31c96fdfa7ba092d21395aa6489cd85c005c (diff)
downloadmeta-multitech-6e609b4721c4816050f0d201cad5f063adcff867.tar.gz
meta-multitech-6e609b4721c4816050f0d201cad5f063adcff867.tar.bz2
meta-multitech-6e609b4721c4816050f0d201cad5f063adcff867.zip
Initial meta-multitech-common based on meta-multitech (branch master)
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/dtc/dtc_1.4.7.bb28
-rw-r--r--recipes-devtools/mtd/mtd-utils-static_git.bb25
-rw-r--r--recipes-devtools/mtd/mtd-utils/0001-Revert-Return-correct-error-number-in-ubi_get_vol_in.patch92
-rw-r--r--recipes-devtools/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2-git-2.patch105
-rw-r--r--recipes-devtools/mtd/mtd-utils_git.bb73
-rw-r--r--recipes-devtools/mtd/mtd-utils_git.bbappend5
6 files changed, 0 insertions, 328 deletions
diff --git a/recipes-devtools/dtc/dtc_1.4.7.bb b/recipes-devtools/dtc/dtc_1.4.7.bb
deleted file mode 100644
index 80b505f..0000000
--- a/recipes-devtools/dtc/dtc_1.4.7.bb
+++ /dev/null
@@ -1,28 +0,0 @@
-SUMMARY = "Device Tree Compiler and its library"
-HOMEPAGE = "https://git.kernel.org/pub/scm/utils/dtc/dtc.git/about/"
-LICENSE = "BSD & GPLv2+"
-LIC_FILES_CHKSUM = "file://README.license;md5=89fd4e63f2aea733216e660f81b3c118"
-
-SRC_URI = "git://git.kernel.org/pub/scm/utils/dtc/dtc.git"
-SRCREV = "78e113e81c9d33d0f33704b187a46399d5a75419"
-INC_PR = "r1"
-PR = "${INC_PR}.0"
-DEPENDS = "flex bison swig"
-RDEPENDS_dtc = "libfdt"
-S = "${WORKDIR}/git"
-PACKAGES =+ "libfdt"
-FILES_libfdt = "${libdir}/libfdt.so.[0-9] ${libdir}/libfdt-*.so"
-RPROVIDES_libfdt = "libfdt"
-
-FILES_${PN}-dev += "${libdir}/libfdt.so.[0-9].*"
-
-do_compile() {
- oe_runmake
-}
-
-do_install() {
- echo "DESTDIR is ${D}"
- oe_runmake install-lib DESTDIR=${D} HOME="/" LIBDIR="${libdir}"
- install -d ${D}/${includedir}/libfdt
- install ${S}/libfdt/*.h ${D}/${includedir}/libfdt
-}
diff --git a/recipes-devtools/mtd/mtd-utils-static_git.bb b/recipes-devtools/mtd/mtd-utils-static_git.bb
deleted file mode 100644
index d3ba77e..0000000
--- a/recipes-devtools/mtd/mtd-utils-static_git.bb
+++ /dev/null
@@ -1,25 +0,0 @@
-# Recipe to produce a static nandwrite for flashing
-# the root file system after it has been mounted
-# read-only, and erased on the flash.
-# nanderase has already loaded its libraries before
-# the root file system has been erased, so it
-# does not need to be static.
-require recipes-devtools/mtd/mtd-utils_git.bb
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/mtd-utils:"
-
-PR = "r0"
-
-PACKAGES = "${PN} ${PN}-dbg"
-
-# build static version of nandwrite for flash upgrading
-CFLAGS += "-static"
-
-do_install () {
- install -d ${D}${bindir}
- install -m 0755 ${B}/nandwrite.static ${D}${bindir}/
-}
-
-do_compile_append() {
- ${CC} ${CFLAGS} ${LDFLAGS} -o nandwrite.static nand-utils/nandwrite.o libmtd.a
-} \ No newline at end of file
diff --git a/recipes-devtools/mtd/mtd-utils/0001-Revert-Return-correct-error-number-in-ubi_get_vol_in.patch b/recipes-devtools/mtd/mtd-utils/0001-Revert-Return-correct-error-number-in-ubi_get_vol_in.patch
deleted file mode 100644
index 4ece56b..0000000
--- a/recipes-devtools/mtd/mtd-utils/0001-Revert-Return-correct-error-number-in-ubi_get_vol_in.patch
+++ /dev/null
@@ -1,92 +0,0 @@
-From 0f833ac73ad631248826386e2918d8571ecf0347 Mon Sep 17 00:00:00 2001
-From: David Oberhollenzer <david.oberhollenzer@sigma-star.at>
-Date: Sat, 9 Jun 2018 16:45:22 +0200
-Subject: [PATCH] Revert "Return correct error number in ubi_get_vol_info1"
-
-This reverts commit dede98ffb706676309488d7cc660f569548d5930.
-
-The original commit tried to fix a descrepancy between the implementation
-and the documentation by making the implementation comply.
-
-When making the change, it was overlooked, that ubinfo and ubirename were
-written against the implementation instead of the behaviour specified by
-the documentation. So were further internal functions like
-ubi_get_vol_info1_nm which further breaks ubirmvol.
-
-A report with an outline of a resulting problem can be read on
-the mailing list:
-
-http://lists.infradead.org/pipermail/linux-mtd/2018-June/081562.html
-
-From the report:
-
-steps to reproduce: have mtd-utils 2.0.1 or 2.0.2
-
-0. make a bunch of ubi volumes in sequential order
-
-ubimkvol /dev/ubi0 -s 64KiB -N test1
-ubimkvol /dev/ubi0 -s 64KiB -N test2
-ubimkvol /dev/ubi0 -s 64KiB -N test3
-ubimkvol /dev/ubi0 -s 64KiB -N test4
-..
-
-1. delete the test1 volume, making a hole in the volume table
-
-ubirmvol /dev/ubi0 -N test1
-
-2. try an affected tool (i.e. "ubirmvol /dev/ubi0 -N test4" )
-
- |root at mr24:/# ubirmvol /dev/ubi0 -N test4
- |ubirmvol: error!: cannot find UBI volume "test4"
- | error 19 (No such device)
-
-or "ubinfo -a"
-
- | root at mr24:/# ubinfo -a
- | UBI version: 1
- | Count of UBI devices: 1
- | UBI control device major/minor: 10:59
- | Present UBI devices: ubi0
- |
- | ubi0
- | Volumes count: 11
- | Logical eraseblock size: 15872 bytes, 15.5 KiB
- | Total amount of logical eraseblocks: 1952 (30982144 bytes, 29.5 MiB)
- | Amount of available logical eraseblocks: 75 (1190400 bytes, 1.1 MiB)
- | Maximum count of volumes 92
- | Count of bad physical eraseblocks: 0
- | Count of reserved physical eraseblocks: 40
- | Current maximum erase counter value: 984
- | Minimum input/output unit size: 512 bytes
- | Character device major/minor: 251:0
- | ubinfo: error!: libubi failed to probe volume 5 on ubi0
- | error 19 (No such device)
- | Present volumes: 0, 1, 2, 3, 4root at mr24:/#
-
-Reported-by: Christian Lamparter <chunkeey@gmail.com>
-Signed-off-by: David Oberhollenzer <david.oberhollenzer@sigma-star.at>
-Upstream-Status: Accepted [http://git.infradead.org/mtd-utils.git/commit/0f833ac73ad631248826386e2918d8571ecf0347]
----
- lib/libubi.c | 5 +----
- 1 file changed, 1 insertion(+), 4 deletions(-)
-
-diff --git a/lib/libubi.c b/lib/libubi.c
-index b50e68a..978b433 100644
---- a/lib/libubi.c
-+++ b/lib/libubi.c
-@@ -1240,11 +1240,8 @@ int ubi_get_vol_info1(libubi_t desc, int dev_num, int vol_id,
- info->dev_num = dev_num;
- info->vol_id = vol_id;
-
-- if (vol_get_major(lib, dev_num, vol_id, &info->major, &info->minor)) {
-- if (errno == ENOENT)
-- errno = ENODEV;
-+ if (vol_get_major(lib, dev_num, vol_id, &info->major, &info->minor))
- return -1;
-- }
-
- ret = vol_read_data(lib->vol_type, dev_num, vol_id, buf, 50);
- if (ret < 0)
---
-2.14.4
-
diff --git a/recipes-devtools/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2-git-2.patch b/recipes-devtools/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2-git-2.patch
deleted file mode 100644
index 5d874d9..0000000
--- a/recipes-devtools/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2-git-2.patch
+++ /dev/null
@@ -1,105 +0,0 @@
-Upstream-Status: Pending
-
-Index: git/jffsX-utils/mkfs.jffs2.c
-===================================================================
---- git.orig/jffsX-utils/mkfs.jffs2.c
-+++ git/jffsX-utils/mkfs.jffs2.c
-@@ -100,6 +100,11 @@ struct filesystem_entry {
- struct rb_node hardlink_rb;
- };
-
-+struct ignorepath_entry {
-+ struct ignorepath_entry* next; /* Points to the next ignorepath element */
-+ char name[PATH_MAX]; /* Name of the entry */
-+};
-+static struct ignorepath_entry* ignorepath = 0;
- struct rb_root hardlinks;
- static int out_fd = -1;
- static int in_fd = -1;
-@@ -309,7 +314,7 @@ static struct filesystem_entry *recursiv
- char *hpath, *tpath;
- struct dirent *dp, **namelist;
- struct filesystem_entry *entry;
--
-+ struct ignorepath_entry* element = ignorepath;
-
- if (lstat(hostpath, &sb)) {
- sys_errmsg_die("%s", hostpath);
-@@ -318,6 +323,15 @@ static struct filesystem_entry *recursiv
- entry = add_host_filesystem_entry(targetpath, hostpath,
- sb.st_uid, sb.st_gid, sb.st_mode, 0, parent);
-
-+ while ( element ) {
-+ if ( strcmp( element->name, targetpath ) == 0 ) {
-+ printf( "Note: ignoring directories below '%s'\n", targetpath );
-+ return entry;
-+ break;
-+ }
-+ element = element->next;
-+ }
-+
- n = scandir(hostpath, &namelist, 0, alphasort);
- if (n < 0) {
- sys_errmsg_die("opening directory %s", hostpath);
-@@ -1359,6 +1373,7 @@ static struct option long_options[] = {
- {"root", 1, NULL, 'r'},
- {"pagesize", 1, NULL, 's'},
- {"eraseblock", 1, NULL, 'e'},
-+ {"ignore", 1, NULL, 'I'},
- {"output", 1, NULL, 'o'},
- {"help", 0, NULL, 'h'},
- {"verbose", 0, NULL, 'v'},
-@@ -1409,6 +1424,7 @@ static const char helptext[] =
- " -L, --list-compressors Show the list of the available compressors\n"
- " -t, --test-compression Call decompress and compare with the original (for test)\n"
- " -n, --no-cleanmarkers Don't add a cleanmarker to every eraseblock\n"
-+" -I, --ignore=PATH Ignore sub directory and file tree below PATH when recursing over the file system\n"
- " -o, --output=FILE Output to FILE (default: stdout)\n"
- " -l, --little-endian Create a little-endian filesystem\n"
- " -b, --big-endian Create a big-endian filesystem\n"
-@@ -1566,6 +1582,7 @@ int main(int argc, char **argv)
- char *compr_name = NULL;
- int compr_prior = -1;
- int warn_page_size = 0;
-+ struct ignorepath_entry* element = ignorepath;
-
- page_size = sysconf(_SC_PAGESIZE);
- if (page_size < 0) /* System doesn't know so ... */
-@@ -1576,7 +1593,7 @@ int main(int argc, char **argv)
- jffs2_compressors_init();
-
- while ((opt = getopt_long(argc, argv,
-- "D:d:r:s:o:qUPfh?vVe:lbp::nc:m:x:X:Lty:i:", long_options, &c)) >= 0)
-+ "D:d:r:s:I:o:qUPfh?vVe:lbp::nc:m:x:X:Lty:i:", long_options, &c)) >= 0)
- {
- switch (opt) {
- case 'D':
-@@ -1600,6 +1617,28 @@ int main(int argc, char **argv)
- warn_page_size = 0; /* set by user, so don't need to warn */
- break;
-
-+ case 'I':
-+ printf( "Note: Adding '%s' to ignore Path\n", optarg );
-+ element = ignorepath;
-+ if ( !ignorepath ) {
-+ ignorepath = xmalloc( sizeof( struct ignorepath_entry ) );
-+ ignorepath->next = 0;
-+ strcpy( &ignorepath->name[0], optarg );
-+ } else {
-+ while ( element->next ) element = element->next;
-+ element->next = xmalloc( sizeof( struct ignorepath_entry ) );
-+ element->next->next = 0;
-+ strcpy( &element->next->name[0], optarg );
-+ }
-+ printf( "--------- Dumping ignore path list ----------------\n" );
-+ element = ignorepath;
-+ while ( element ) {
-+ printf( " * '%s'\n", &element->name[0] );
-+ element = element->next;
-+ }
-+ printf( "---------------------------------------------------\n" );
-+ break;
-+
- case 'o':
- if (out_fd != -1) {
- errmsg_die("output filename specified more than once");
diff --git a/recipes-devtools/mtd/mtd-utils_git.bb b/recipes-devtools/mtd/mtd-utils_git.bb
deleted file mode 100644
index d3ff48b..0000000
--- a/recipes-devtools/mtd/mtd-utils_git.bb
+++ /dev/null
@@ -1,73 +0,0 @@
-SUMMARY = "Tools for managing memory technology devices"
-HOMEPAGE = "http://www.linux-mtd.infradead.org/"
-SECTION = "base"
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
- file://include/common.h;beginline=1;endline=17;md5=ba05b07912a44ea2bf81ce409380049c"
-
-inherit autotools pkgconfig update-alternatives
-
-DEPENDS = "zlib lzo e2fsprogs util-linux"
-RDEPENDS_mtd-utils-tests += "bash"
-
-PV = "2.0.2+${SRCPV}"
-
-SRCREV = "bc63d36e39f389c8c17f6a8e9db47f2acc884659"
-SRC_URI = "git://git.infradead.org/mtd-utils.git \
- file://add-exclusion-to-mkfs-jffs2-git-2.patch \
- file://0001-Revert-Return-correct-error-number-in-ubi_get_vol_in.patch \
-"
-
-S = "${WORKDIR}/git/"
-
-EXTRA_OECONF += "--enable-install-tests"
-
-# xattr support creates an additional compile-time dependency on acl because
-# the sys/acl.h header is needed. libacl is not needed and thus enabling xattr
-# regardless whether acl is enabled or disabled in the distro should be okay.
-PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'xattr', '', d)}"
-PACKAGECONFIG[xattr] = ",,acl,"
-
-
-CPPFLAGS_append_riscv64 = " -pthread -D_REENTRANT"
-
-EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} ${@bb.utils.contains('PACKAGECONFIG', 'xattr', '', '-DWITHOUT_XATTR', d)} -I${S}/include' 'BUILDDIR=${S}'"
-
-# Use higher priority than corresponding BusyBox-provided applets
-ALTERNATIVE_PRIORITY = "100"
-
-ALTERNATIVE_${PN} = "flashcp flash_eraseall flash_lock flash_unlock nanddump nandwrite"
-ALTERNATIVE_${PN}-ubifs = "ubiattach ubidetach ubimkvol ubirename ubirmvol ubirsvol ubiupdatevol"
-
-ALTERNATIVE_LINK_NAME[flash_eraseall] = "${sbindir}/flash_eraseall"
-ALTERNATIVE_LINK_NAME[nandwrite] = "${sbindir}/nandwrite"
-ALTERNATIVE_LINK_NAME[nanddump] = "${sbindir}/nanddump"
-ALTERNATIVE_LINK_NAME[ubiattach] = "${sbindir}/ubiattach"
-ALTERNATIVE_LINK_NAME[ubiattach] = "${sbindir}/ubiattach"
-ALTERNATIVE_LINK_NAME[ubidetach] = "${sbindir}/ubidetach"
-ALTERNATIVE_LINK_NAME[ubimkvol] = "${sbindir}/ubimkvol"
-ALTERNATIVE_LINK_NAME[ubirename] = "${sbindir}/ubirename"
-ALTERNATIVE_LINK_NAME[ubirmvol] = "${sbindir}/ubirmvol"
-ALTERNATIVE_LINK_NAME[ubirsvol] = "${sbindir}/ubirsvol"
-ALTERNATIVE_LINK_NAME[ubiupdatevol] = "${sbindir}/ubiupdatevol"
-ALTERNATIVE_LINK_NAME[flash_eraseall] = "${sbindir}/flash_eraseall"
-ALTERNATIVE_LINK_NAME[flash_lock] = "${sbindir}/flash_lock"
-ALTERNATIVE_LINK_NAME[flash_unlock] = "${sbindir}/flash_unlock"
-ALTERNATIVE_LINK_NAME[flashcp] = "${sbindir}/flashcp"
-
-do_install () {
- oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} INCLUDEDIR=${includedir}
-}
-
-PACKAGES =+ "mtd-utils-jffs2 mtd-utils-ubifs mtd-utils-misc mtd-utils-tests"
-
-FILES_mtd-utils-jffs2 = "${sbindir}/mkfs.jffs2 ${sbindir}/jffs2dump ${sbindir}/jffs2reader ${sbindir}/sumtool"
-FILES_mtd-utils-ubifs = "${sbindir}/mkfs.ubifs ${sbindir}/ubi*"
-FILES_mtd-utils-misc = "${sbindir}/nftl* ${sbindir}/ftl* ${sbindir}/rfd* ${sbindir}/doc* ${sbindir}/serve_image ${sbindir}/recv_image"
-FILES_mtd-utils-tests = "${libexecdir}/mtd-utils/*"
-
-BBCLASSEXTEND = "native nativesdk"
-
-# git/.compr.c.dep:46: warning: NUL character seen; rest of line ignored
-# git/.compr.c.dep:47: *** missing separator. Stop.
-PARALLEL_MAKE = ""
diff --git a/recipes-devtools/mtd/mtd-utils_git.bbappend b/recipes-devtools/mtd/mtd-utils_git.bbappend
deleted file mode 100644
index 1fceb70..0000000
--- a/recipes-devtools/mtd/mtd-utils_git.bbappend
+++ /dev/null
@@ -1,5 +0,0 @@
-# install jffs-user.h which was removed from linux-headers
-do_install_append() {
- install -d ${D}${includedir}/mtd
- install -m 644 ${S}/include/mtd/jffs2-user.h ${D}${includedir}/mtd/
-}