summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2021-11-08 03:41:21 -0600
committerAndrii Pientsov <andrii.pientsov@globallogic.com>2021-11-18 14:49:55 +0200
commitcbcd9e1dcc299fcbb2ccbf09bc8aa1aa1750618c (patch)
tree1380c93bc12f5d53995aca5242d91c19f6283afa /recipes-bsp
parent0b7036679cf0c057f0ae492e84438270797faf4f (diff)
downloadmeta-multitech-cbcd9e1dcc299fcbb2ccbf09bc8aa1aa1750618c.tar.gz
meta-multitech-cbcd9e1dcc299fcbb2ccbf09bc8aa1aa1750618c.tar.bz2
meta-multitech-cbcd9e1dcc299fcbb2ccbf09bc8aa1aa1750618c.zip
mt-dt-overlay must come before mts-io for gpio-leds driver
Diffstat (limited to 'recipes-bsp')
-rwxr-xr-xrecipes-bsp/multitech/mt-dt-overlay/init6
-rw-r--r--recipes-bsp/multitech/mt-dt-overlay_1.0.5.bb17
2 files changed, 16 insertions, 7 deletions
diff --git a/recipes-bsp/multitech/mt-dt-overlay/init b/recipes-bsp/multitech/mt-dt-overlay/init
index 5bd8523..bb6790b 100755
--- a/recipes-bsp/multitech/mt-dt-overlay/init
+++ b/recipes-bsp/multitech/mt-dt-overlay/init
@@ -5,6 +5,8 @@
# device tree.
sysdir=/sys/devices/platform/mts-io
+i2c=/sys/bus/i2c/devices/
+eepromPath="/sys/devices/platform/i2c-gpio-0/i2c-0/0-0056/eeprom"
DEVTREE="/sys/kernel/config/device-tree/overlays/"
SYSFS="/usr/sbin/mts-io-sysfs"
@@ -47,7 +49,9 @@ install_dtbo_dir() {
# [flag]
# [file1] [file2] [file3]
setdevtree() {
- hw=$(${SYSFS} show hw-version)
+ hwlin=$(mts-id-eeprom --in-file "$eepromPath" 2>/dev/null | grep '^hw-version:')
+ [[ $hwlin =~ hw-version:[[:space:]]*\"([^\"]+) ]]
+ hw=${BASH_REMATCH[1]}
mach=${hw/%-*}
rev=${hw/#*-/}
echo mach is $mach
diff --git a/recipes-bsp/multitech/mt-dt-overlay_1.0.5.bb b/recipes-bsp/multitech/mt-dt-overlay_1.0.5.bb
index 5727e14..a023a4e 100644
--- a/recipes-bsp/multitech/mt-dt-overlay_1.0.5.bb
+++ b/recipes-bsp/multitech/mt-dt-overlay_1.0.5.bb
@@ -5,12 +5,16 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
inherit update-rc.d
INITSCRIPT_NAME = "${PN}"
-INITSCRIPT_PARAMS = "start 40 S ."
-DEPENDS = "dtc-native"
+# mt-dt-overlay must start before mts-io
+# because the gpio-leds driver will not load
+# after mts-io.
+INITSCRIPT_PARAMS = "start 39 S ."
+DEPENDS = "dtc-native linux-at91"
RDEPENDS_${PN} = "bash"
-COMPATIBLE_MACHINE = "(mtcap|mtcdt|mtrv1)"
+# For now, just mtcap
+COMPATIBLE_MACHINE = "(mtcap|mtrv1|mtcdt)"
# By using an overlay, we should be able to support multiple pinouts
# using the same image. The overlays go into /lib/dtoverlays.
@@ -21,14 +25,15 @@ COMPATIBLE_MACHINE = "(mtcap|mtcdt|mtrv1)"
dt_dir = "/lib/dtoverlays"
-PR = "r1"
+PR = "r2"
+# git://git.multitech.net/mt-dt-overlay.git;protocol=git
SRC_URI = " \
- git://git.multitech.net/mt-dt-overlay.git;protocol=git \
+ git://git@gitlab.multitech.net/mirrors/mt-dt-overlay.git;protocol=ssh;branch=MTCDT-0.2 \
file://init \
"
-SRCREV = "${PV}"
+SRCREV = "${AUTOREV}"
DEPENDS = "virtual/kernel u-boot-mkimage-native"