summaryrefslogtreecommitdiff
path: root/recipes-bsp/multitech/mts-io-sysfs_0.2.5.bb
diff options
context:
space:
mode:
authorMykola Salomatin <mykola.salomatin@globallogic.com>2022-05-17 19:08:14 +0300
committerMykola Salomatin <mykola.salomatin@globallogic.com>2022-05-17 19:08:14 +0300
commitfc393dbed7b562c3dd761d94575138b278ff99c6 (patch)
tree465e56bad85f7e4d798fd2030b1ba54ca8c25fd1 /recipes-bsp/multitech/mts-io-sysfs_0.2.5.bb
parent427b0b0072e62a0c0e7db09452d5da4fab69cb42 (diff)
downloadmeta-multitech-fc393dbed7b562c3dd761d94575138b278ff99c6.tar.gz
meta-multitech-fc393dbed7b562c3dd761d94575138b278ff99c6.tar.bz2
meta-multitech-fc393dbed7b562c3dd761d94575138b278ff99c6.zip
[MTX-4480] mPower R.6.0.X: MTCAP3 - Filesystem Encryption capability GP-1586
Diffstat (limited to 'recipes-bsp/multitech/mts-io-sysfs_0.2.5.bb')
-rw-r--r--recipes-bsp/multitech/mts-io-sysfs_0.2.5.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes-bsp/multitech/mts-io-sysfs_0.2.5.bb b/recipes-bsp/multitech/mts-io-sysfs_0.2.5.bb
new file mode 100644
index 0000000..3b8bf7f
--- /dev/null
+++ b/recipes-bsp/multitech/mts-io-sysfs_0.2.5.bb
@@ -0,0 +1,46 @@
+DESCRIPTION = "mts-io sysfs wrapper"
+HOMEPAGE = "http://www.multitech.net/"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+inherit update-rc.d
+
+DEPENDS = "libmts openssl"
+RDEPENDS_${PN} = "bash"
+PR = "r0"
+
+SRCREV = "${PV}"
+
+SRC_URI = "git://git@gitlab.multitech.net/mirrors/mts-io-sysfs;protocol=ssh;branch=master \
+ file://mts-io-sysfs.init"
+
+S = "${WORKDIR}/git"
+
+do_configure_append() {
+}
+
+do_compile() {
+ oe_runmake
+}
+
+
+fakeroot do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 ${S}/build/mts-io-sysfs ${D}${sbindir}/mts-io-sysfs
+ install -d 0755 ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/mts-io-sysfs.init ${D}${sysconfdir}/init.d/eeprom-config
+}
+
+
+INITSCRIPT_NAME = "eeprom-config"
+# Must start after MTS-IO to read the accessory cards.
+INITSCRIPT_PARAMS = "start 40 S ."
+
+FILES_${PN} += "${libdir}/mts-io-sysfs*"
+FILES_${PN} += "${sbindir}/mts-io-sysfs"
+
+# disable this on purpose for dev purposes
+do_rm_work() {
+ echo "skipping"
+}