summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2022-02-02 19:24:16 -0600
committerJohn Klug <john.klug@multitech.com>2022-02-04 09:47:09 -0600
commitdb3719f227d0a43d9ad6d573a5b0b3840d0162e2 (patch)
tree06abf17c3c20970a649b0b7f0bd77833470708b4
parentbcaceb878ced8f8827e15d91d47d15de4604856e (diff)
downloadmeta-multitech-5.3.x.tar.gz
meta-multitech-5.3.x.tar.bz2
meta-multitech-5.3.x.zip
Fix GPS on MTCDTIP25.3.x
-rwxr-xr-xrecipes-bsp/multitech/mt-dt-overlay/init26
-rw-r--r--recipes-bsp/multitech/mt-dt-overlay_1.1.2.bb2
2 files changed, 15 insertions, 13 deletions
diff --git a/recipes-bsp/multitech/mt-dt-overlay/init b/recipes-bsp/multitech/mt-dt-overlay/init
index a59d215..8900651 100755
--- a/recipes-bsp/multitech/mt-dt-overlay/init
+++ b/recipes-bsp/multitech/mt-dt-overlay/init
@@ -33,14 +33,17 @@ install_dtbo_dir() {
# [flag]
# [file1] [file2] [file3]
setdevtree() {
- hwlin=$(mts-id-eeprom --in-file "$eepromPath" 2>/dev/null | grep '^hw-version:')
- [[ $hwlin =~ hw-version:[[:space:]]*\"([^\"]+) ]]
+ eeprom=$(mts-id-eeprom --in-file "$eepromPath" 2>/dev/null)
+ [[ $eeprom =~ [[:space:]]hw-version:[[:space:]]*\"([^\"]+) ]]
hw=${BASH_REMATCH[1]}
mach=${hw/%-*}
rev=${hw/#*-/}
echo mach is $mach
echo rev is $rev
- capd="${sysdir}/capability"
+
+ regx='capa-(.*):[[:space:]]*true'
+ capflags=$(echo "$eeprom" | egrep "$regx" | sed -e 's/capa-//g' -e 's/: true//')
+ capflags=" ${capflags} "
# add device tree overlays, if they exist.
[[ -d /lib/dtoverlays ]] || return 1
@@ -67,15 +70,14 @@ setdevtree() {
if [[ -d capability ]] ; then
cd capability
for d in * ; do
- if [[ -f ${capd}/$d ]] ; then
- if (($(cat ${capd}/$d) == 1)) ; then
- echo "This device has capabilithy $d"
- (
- cd $d
- install_dtbo_dir
- )
- fi # Install dtbo files for a capability
- fi # Does a given capability flag exist in the mts-io platform
+ echo "We have found overlay capability directory $d"
+ if [[ ${capflags} =~ [[:space:]]${d}[[:space:]] ]] ; then
+ echo "This device has capabilithy $d so install the overlay"
+ (
+ cd $d
+ install_dtbo_dir
+ )
+ fi # Does a given capability flag exist in the EEPROM
done # Loop over all capabilities for this machine and version overlays
fi # Is there a capability directory to be installed?
)
diff --git a/recipes-bsp/multitech/mt-dt-overlay_1.1.2.bb b/recipes-bsp/multitech/mt-dt-overlay_1.1.2.bb
index 799e319..339c2bb 100644
--- a/recipes-bsp/multitech/mt-dt-overlay_1.1.2.bb
+++ b/recipes-bsp/multitech/mt-dt-overlay_1.1.2.bb
@@ -23,7 +23,7 @@ COMPATIBLE_MACHINE = "(mtcap|mtrv1|mtcdt)"
dt_dir = "/lib/dtoverlays"
-PR = "r3"
+PR = "r4"
SRC_URI = " \
git://git.multitech.net/mt-dt-overlay.git;protocol=git \