summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2019-02-05 16:26:17 -0600
committerJohn Klug <john.klug@multitech.com>2019-02-05 16:27:53 -0600
commitcf1bf26d7c89caca047bb9f26703ec69d045754e (patch)
tree97c45e45a59b67bf07154345d09ea654d6e81d63
parenteeb363bcc5318dc214cef5754ca7dce7f196fc00 (diff)
downloadmeta-multitech-4.1.5.tar.gz
meta-multitech-4.1.5.tar.bz2
meta-multitech-4.1.5.zip
Remove perl dependency4.1.64.1.54.1.4
-rw-r--r--recipes-kernel/rs9113/rs9113-from-src_1.6.0.bb6
-rw-r--r--recipes-kernel/rs9113/rs9113.inc1
-rw-r--r--recipes-kernel/rs9113/rs9113_1.6.0.bb4
3 files changed, 7 insertions, 4 deletions
diff --git a/recipes-kernel/rs9113/rs9113-from-src_1.6.0.bb b/recipes-kernel/rs9113/rs9113-from-src_1.6.0.bb
index cd7c72c..46a348e 100644
--- a/recipes-kernel/rs9113/rs9113-from-src_1.6.0.bb
+++ b/recipes-kernel/rs9113/rs9113-from-src_1.6.0.bb
@@ -3,7 +3,7 @@ LICENSE = "Proprietary"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
PROVIDES = "rs9113-from-src"
# r1 is the new firmware, 1.6.24.0, so upgrades will work.
-PR = "r1.${MLINUX_KERNEL_VERSION}${MLINUX_KERNEL_EXTRA_VERSION}"
+PR = "r2.${MLINUX_KERNEL_VERSION}${MLINUX_KERNEL_EXTRA_VERSION}"
INHIBIT_PACKAGE_STRIP = "1"
BB_STRICT_CHECKSUM = "0"
inherit module
@@ -76,5 +76,9 @@ do_install() {
install -m 0755 -d ${D}${sbindir}
install -m 0755 ${M}/rs9113_load_modules.sh ${D}${sbindir}/
install -m 0755 ${M}/rs9113_remove_modules.sh ${D}${sbindir}/
+ # New patch makes p2commands.sh a bash script.
+ cd ${D}/opt/rs9113/
+ mv p2pcommands.pl p2pcommands.sh
+ ln -sf p2pcommands.sh p2pcommands.pl
}
diff --git a/recipes-kernel/rs9113/rs9113.inc b/recipes-kernel/rs9113/rs9113.inc
index d981ca2..b632fc2 100644
--- a/recipes-kernel/rs9113/rs9113.inc
+++ b/recipes-kernel/rs9113/rs9113.inc
@@ -5,7 +5,6 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
# up elsewhere.
PACKAGES = "kernel-module-${PN} ${PN}-util ${PN}-dbg ${PN}-noarch"
RDEPENDS_${PN}-noarch = "bash"
-RRECOMMENDS_${PN}-noarch = "perl"
DR = "${DL_DIR}/rs9113-ipk"
FILESEXTRAPATHS_append := "${DR}:"
diff --git a/recipes-kernel/rs9113/rs9113_1.6.0.bb b/recipes-kernel/rs9113/rs9113_1.6.0.bb
index 5e820e5..58d22b4 100644
--- a/recipes-kernel/rs9113/rs9113_1.6.0.bb
+++ b/recipes-kernel/rs9113/rs9113_1.6.0.bb
@@ -4,7 +4,7 @@ LICENSE = "Proprietary"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
PROVIDES = "rs9113"
FILES_${PN} = "/opt/rs9113 ${sbindir} ${sysconfdir}"
-RDEPENDS_${PN} += "perl bash"
+RDEPENDS_${PN} += "bash"
# This bitbake recipe requires SSH_AUTH_SOCK to be set if ssh key pass
# phrases are used. SSH_AUTH_SOCK is set by a keyserver,
@@ -15,7 +15,7 @@ RDEPENDS_${PN} += "perl bash"
# git://git@${MTS_INTERNAL_GIT}/mlinux/ipk.git;protocol=ssh;branch=${PV}
#
# r1 is the new firmware, 1.6.24.0, so upgrades will work.
-PR = "r1.${MLINUX_KERNEL_VERSION}${MLINUX_KERNEL_EXTRA_VERSION}"
+PR = "r2.${MLINUX_KERNEL_VERSION}${MLINUX_KERNEL_EXTRA_VERSION}"
SRC_URI = " \
file://rs9113/rs9113.init \
file://rs9113/rs9113.default \