summaryrefslogtreecommitdiff
path: root/recipes-kernel/rsi-91x/rsi-91x-utils_2.5.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/rsi-91x/rsi-91x-utils_2.5.1.bb')
-rw-r--r--recipes-kernel/rsi-91x/rsi-91x-utils_2.5.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-kernel/rsi-91x/rsi-91x-utils_2.5.1.bb b/recipes-kernel/rsi-91x/rsi-91x-utils_2.5.1.bb
new file mode 100644
index 0000000..f43d2d7
--- /dev/null
+++ b/recipes-kernel/rsi-91x/rsi-91x-utils_2.5.1.bb
@@ -0,0 +1,31 @@
+LIC_FILES_CHKSUM = "file://${WORKDIR}/git/rsi/apps/onebox_util.c;beginline=5;endline=17;md5=de9e3b7d092ee142ef090acc79db39c1"
+LICENSE = "CLOSED"
+PR = "r1"
+
+RDEPENDS_${PN} += "bash"
+
+SRCREV = "v${PV}"
+SRC_URI = "git://github.com/SiliconLabs/RS911X-nLink-OSD.git;protocol=https \
+ file://onebox_util.sh \
+ "
+S = "${WORKDIR}/git/rsi/apps"
+
+FILES_${PN} = "${base_libdir} ${prefix} /opt"
+TARGET_CC_ARCH += "${LDFLAGS}"
+do_install() {
+ instdir="${D}/opt/rs9113"
+ install -m 0755 -d ${D}${prefix}/share/${PN}
+ sed -n '5,17p' ${S}/onebox_util.c >${D}${prefix}/share/${PN}/LICENSE
+ install -m 0755 -d ${instdir}
+ cd "${S}"
+ for f in $(find . -type f) ; do
+ if file "$f" | grep ELF ; then
+ if [ "$f" = "./onebox_util" ] ; then
+ install -m 0755 $f ${instdir}/onebox_util_rsi
+ else
+ install -m 0755 $f ${instdir}
+ fi
+ fi
+ done
+ install -m 0755 ${WORKDIR}/onebox_util.sh ${instdir}/onebox_util
+}