summaryrefslogtreecommitdiff
path: root/recipes-kernel/rsi-91x/rsi-91x-sta-ap_2.5.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/rsi-91x/rsi-91x-sta-ap_2.5.1.bb')
-rw-r--r--recipes-kernel/rsi-91x/rsi-91x-sta-ap_2.5.1.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-kernel/rsi-91x/rsi-91x-sta-ap_2.5.1.bb b/recipes-kernel/rsi-91x/rsi-91x-sta-ap_2.5.1.bb
new file mode 100644
index 0000000..56c2de6
--- /dev/null
+++ b/recipes-kernel/rsi-91x/rsi-91x-sta-ap_2.5.1.bb
@@ -0,0 +1,39 @@
+LICENSE = "GPLv2+|BSD"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+PR = "r1"
+PKGR = "${PR}${KERNEL_MODULE_PACKAGE_SUFFIX}${EXTENDPRAUTO}"
+RPROVIDES_kernel-module-${PN} = "${PN}"
+inherit module
+
+SRCREV = "v${PV}"
+SRC_URI = "git://github.com/SiliconLabs/RS911X-nLink-OSD.git;protocol=https \
+ file://rsi-91x-sta-ap.patch;striplevel=2 \
+ file://0001_concurrent_compilation_fix.patch \
+ file://0002-fix-rsi_handle_card_ready-card-ready.patch \
+ "
+S = "${WORKDIR}/git/rsi"
+
+EXTRA_OEMAKE = " KERNELDIR=${STAGING_KERNEL_DIR} \
+ CROSS_COMPILE=${TARGET_PREFIX} \
+ ARCH=arm \
+ WLAN_COMPILE_FLAGS='' \
+ V=1 \
+ "
+
+PARALLEL_MAKE = ""
+PACKAGES = "kernel-module-${PN} \
+ kernel-module-rsi-usb-sta-ap \
+ ${PN}-dev \
+ ${PN}-dbg \
+"
+INSTDIR = "/opt/rs9113/modules"
+FILES_kernel-module-${PN} = "${INSTDIR}/rsi_91x_sta_ap.ko"
+FILES_kernel-module-rsi-usb-sta-ap = "${INSTDIR}/rsi_usb_sta_ap.ko"
+
+do_install() {
+ instdir="${D}/opt/rs9113/modules"
+ install -m 0755 -d "${instdir}"
+ # use cp instead of install so the driver doesn't get stripped
+ cp ${S}/rsi_91x_sta_ap.ko "${instdir}"
+ cp ${S}/rsi_usb_sta_ap.ko "${instdir}"
+}