summaryrefslogtreecommitdiff
path: root/recipes-kernel/rsi-91x/files/rsi-bt91x-config.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/rsi-91x/files/rsi-bt91x-config.patch')
-rw-r--r--recipes-kernel/rsi-91x/files/rsi-bt91x-config.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes-kernel/rsi-91x/files/rsi-bt91x-config.patch b/recipes-kernel/rsi-91x/files/rsi-bt91x-config.patch
new file mode 100644
index 0000000..3bda909
--- /dev/null
+++ b/recipes-kernel/rsi-91x/files/rsi-bt91x-config.patch
@@ -0,0 +1,41 @@
+diff --git a/rsi/Makefile b/rsi/Makefile
+index 64f7742..bc088b8 100644
+--- a/rsi/Makefile
++++ b/rsi/Makefile
+@@ -42,7 +42,7 @@ KERNELDIR=/lib/modules/$(KERNELRELEASE)/build
+ #CONFIG_SDIO_INTR_POLL=y
+
+ # Uncomment below line for BT alone (Classic/LE/Dual) mode
+-#CONFIG_RSI_BT_ALONE=y
++CONFIG_RSI_BT_ALONE=y
+
+ # Uncomment below line for Wi-Fi BT coex mode
+ #CONFIG_RSI_COEX_MODE=y
+@@ -190,16 +190,21 @@ ifeq ($(OFFLOAD_SCAN_TO_DEVICE), y)
+ EXTRA_CFLAGS += -DOFFLOAD_SCAN_TO_DEVICE
+ endif
+
+-obj-m := rsi_sdio.o rsi_usb.o rsi_91x.o
+-rsi_sdio-objs := $(COMMON_SDIO_OBJS)
+-rsi_usb-objs := $(COMMON_USB_OBJS)
+-rsi_91x-objs := $(RSI_91X_OBJS)
++obj-m := rsi_btsdio.o rsi_btusb.o rsi_bt91x.o
++rsi_btsdio-objs := $(COMMON_SDIO_OBJS)
++rsi_btusb-objs := $(COMMON_USB_OBJS)
++rsi_bt91x-objs := $(RSI_91X_OBJS)
+
+ all:
++ @echo env is:
++ env
+ @echo -e "\033[32mCompiling RSI drivers...\033[0m"
+ make -C$(KERNELDIR)/ M=$(PWD) modules
+- @echo -e "application compilation"
+- make CC="$(CC)" ROOT_DIR=$(ROOT_DIR) -C $(PWD)/apps
++ # @echo -e "application compilation"
++ # make CC="$(CC)" ROOT_DIR=$(ROOT_DIR) -C $(PWD)/apps
++
++modules_install:
++ $(MAKE) -C $(KERNELDIR) M=$(PWD) modules_install
+
+ clean:
+ make -C$(KERNELDIR)/ M=$(PWD) clean