summaryrefslogtreecommitdiff
path: root/recipes-kernel/rsi-91x/files/rsi-91x-sta-ap.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/rsi-91x/files/rsi-91x-sta-ap.patch')
-rw-r--r--recipes-kernel/rsi-91x/files/rsi-91x-sta-ap.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes-kernel/rsi-91x/files/rsi-91x-sta-ap.patch b/recipes-kernel/rsi-91x/files/rsi-91x-sta-ap.patch
new file mode 100644
index 0000000..73c3e1b
--- /dev/null
+++ b/recipes-kernel/rsi-91x/files/rsi-91x-sta-ap.patch
@@ -0,0 +1,40 @@
+diff --git a/rsi/Makefile b/rsi/Makefile
+index 64f7742..951b7a1 100644
+--- a/rsi/Makefile
++++ b/rsi/Makefile
+@@ -57,7 +57,7 @@ KERNELDIR=/lib/modules/$(KERNELRELEASE)/build
+ #CONFIG_RSI_P2P=y
+
+ # Uncomment below line for using Concurrent mode
+-#CONFIG_STA_PLUS_AP=y
++CONFIG_STA_PLUS_AP=y
+
+ # Uncomment below line for platforms with no SDIO multiblock support
+ #CONFIG_RSI_NO_SDIO_MULTIBLOCK=y
+@@ -190,16 +190,21 @@ ifeq ($(OFFLOAD_SCAN_TO_DEVICE), y)
+ EXTRA_CFLAGS += -DOFFLOAD_SCAN_TO_DEVICE
+ endif
+
+-obj-m := rsi_sdio.o rsi_usb.o rsi_91x.o
++obj-m := rsi_sdio.o rsi_usb_sta_ap.o rsi_91x_sta_ap.o
+ rsi_sdio-objs := $(COMMON_SDIO_OBJS)
+-rsi_usb-objs := $(COMMON_USB_OBJS)
+-rsi_91x-objs := $(RSI_91X_OBJS)
++rsi_usb_sta_ap-objs := $(COMMON_USB_OBJS)
++rsi_91x_sta_ap-objs := $(RSI_91X_OBJS)
+
+ all:
++ @echo env is:
++ env
+ @echo -e "\033[32mCompiling RSI drivers...\033[0m"
+ make -C$(KERNELDIR)/ M=$(PWD) modules
+- @echo -e "application compilation"
+- make CC="$(CC)" ROOT_DIR=$(ROOT_DIR) -C $(PWD)/apps
++ # @echo -e "application compilation"
++ # make CC="$(CC)" ROOT_DIR=$(ROOT_DIR) -C $(PWD)/apps
++
++modules_install:
++ $(MAKE) -C $(KERNELDIR) M=$(PWD) modules_install
+
+ clean:
+ make -C$(KERNELDIR)/ M=$(PWD) clean