summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot_2016.09.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot_2016.09.01.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot_2016.09.01.bb9
1 files changed, 4 insertions, 5 deletions
diff --git a/recipes-bsp/u-boot/u-boot_2016.09.01.bb b/recipes-bsp/u-boot/u-boot_2016.09.01.bb
index 3bf223e..300bcab 100644
--- a/recipes-bsp/u-boot/u-boot_2016.09.01.bb
+++ b/recipes-bsp/u-boot/u-boot_2016.09.01.bb
@@ -3,13 +3,13 @@ require u-boot.inc
DEPENDS += "dtc-native"
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-2016.09.01:"
-FCONFIG_PATCH = "file://configfactory.patch"
-CONFIG_PATCH = "file://config.patch"
+CONFIG_PATCH = "${@oe.utils.conditional('BB_USE_SD', '1', 'file://config-sd.patch', 'file://config-n.patch', d)}"
+MTCDT_PATCH = "${@oe.utils.conditional('BB_USE_SD', '1', 'file://mtcdt-sd.patch', 'file://mtcdt-n.patch', d)}"
# file://mtpwd.path
SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \
file://kconfig_common.patch \
- ${FCONFIG_PATCH} \
+ ${CONFIG_PATCH} \
file://i2c.patch \
file://printeepromcrc.patch \
file://tftpput.patch \
@@ -20,7 +20,7 @@ SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \
# file://mtcdt.patch
SRC_URI_append_mtcdt = " \
- file://mtcdtsd.patch \
+ ${MTCDT_PATCH} \
file://mtcdt_flush_console_autoboot.patch"
SRC_URI_append_mtcap = " \
@@ -44,4 +44,3 @@ SRC_URI[sha256sum] = "95728e89dd476d17428f94080752ab48884be477b6a678941582aeef61
S = "${WORKDIR}/${PN}-${PV}"
-