summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/linux-at91_4.9.87.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-at91_4.9.87.bb b/recipes-kernel/linux/linux-at91_4.9.87.bb
index 380031e..e433d22 100644
--- a/recipes-kernel/linux/linux-at91_4.9.87.bb
+++ b/recipes-kernel/linux/linux-at91_4.9.87.bb
@@ -99,6 +99,11 @@ do_deploy_append() {
fi
}
+# Kernel PR is used for MLINUX_KERNEL_EXTRA_VERSION; share it here:
+do_shared_workdir_append() {
+ echo ${PR} > ${STAGING_KERNEL_BUILDDIR}/mlinux_pr
+}
+
kernel_do_configure_append() {
rm -f ${B}/.scmversion ${S}/.scmversion
cd ${S}; git status; cd -