summaryrefslogtreecommitdiff
path: root/recipes-kernel/rs9113
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-05-19 17:47:25 -0500
committerJohn Klug <john.klug@multitech.com>2017-06-09 09:09:19 -0500
commitca0f0763c3c6f03c7c93158588845bc6e6d63e8d (patch)
tree10f432c6a552b03d872a3ede56cf37380a0fcf8c /recipes-kernel/rs9113
parent821318c726feca8d6d226e061fc787b88f3bc7e1 (diff)
downloadmeta-multitech-atmel-ca0f0763c3c6f03c7c93158588845bc6e6d63e8d.tar.gz
meta-multitech-atmel-ca0f0763c3c6f03c7c93158588845bc6e6d63e8d.tar.bz2
meta-multitech-atmel-ca0f0763c3c6f03c7c93158588845bc6e6d63e8d.zip
Newer Yocto arm-mlinux-linux-gnueabi* compiler suite no longer have a staging directory
Diffstat (limited to 'recipes-kernel/rs9113')
-rw-r--r--recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb b/recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb
index 234d6c9..7d93952 100644
--- a/recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb
+++ b/recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb
@@ -38,8 +38,13 @@ do_configure() {
}
do_compile () {
- unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
- oe_runmake
+ unset CFLAGS LDFLAGS CXXFLAGS CPPFLAGS
+ # For Newer Yocto/Bitbake, CC does not
+ # include the staging directory
+ # by default
+ CC="${CC} --sysroot=${STAGING_DIR_HOST}"
+ LD="${LD} --sysroot=${STAGING_DIR_HOST}"
+ oe_runmake CC="${CC}" LD="${LD}"
}
do_patch () {