summaryrefslogtreecommitdiff
path: root/recipes-kernel/rs9113
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2019-05-16 16:40:58 -0500
committerJohn Klug <john.klug@multitech.com>2019-05-16 16:40:58 -0500
commit9589b6b8184291a801a286b652d742f13b6e0ff8 (patch)
tree15bcfc74500c6d347592b88b359165695f373e96 /recipes-kernel/rs9113
parente7f34f673edf3790cd26bda6afe2e6cd2d73b984 (diff)
downloadmeta-multitech-atmel-9589b6b8184291a801a286b652d742f13b6e0ff8.tar.gz
meta-multitech-atmel-9589b6b8184291a801a286b652d742f13b6e0ff8.tar.bz2
meta-multitech-atmel-9589b6b8184291a801a286b652d742f13b6e0ff8.zip
Allow for antenna gain in wf command
Diffstat (limited to 'recipes-kernel/rs9113')
-rwxr-xr-xrecipes-kernel/rs9113/files/rf/wf13
-rw-r--r--recipes-kernel/rs9113/rs9113rf.inc2
-rw-r--r--recipes-kernel/rs9113/rs9113rf_1.2.bb (renamed from recipes-kernel/rs9113/rs9113rf_1.1.bb)0
3 files changed, 13 insertions, 2 deletions
diff --git a/recipes-kernel/rs9113/files/rf/wf b/recipes-kernel/rs9113/files/rf/wf
index f16bec0..832ec51 100755
--- a/recipes-kernel/rs9113/files/rf/wf
+++ b/recipes-kernel/rs9113/files/rf/wf
@@ -7,6 +7,15 @@ echo ' mcs0, mcs1, mcs2, mcs3, mcs4, mcs5, mcs6,'
echo ' and mcs7'
echo '3rd parameter values:'
echo '0 is 20MHz, 2 is upper 20 of 40, 4 is lower 20 of 40, 6 is 40MHz, 8 is 20KHz for 11J'
+echo '4th and 5th parameters: antenna gain values in db of 2.4GHZ and 5GHZ respectively'
+gain2=0
+gain5=0
+if [[ -n $4 ]] ; then
+ gain2=$4
+fi
+if [[ -n $5 ]] ; then
+ gain5=$5
+fi
chan=8
if [[ -n $1 ]] ; then
chan=$1
@@ -29,4 +38,6 @@ echo "Using channel WiFi $chan BT $btchan"
set -x
echo chan $chan
/opt/rs9113/onebox_util rpine0 ant_sel 2
-/opt/rs9113/transmit rpine0 127 $rate 1536 1 $chan 0 $flag 0 0 0 255
+/opt/rs9113/onebox_util rpine0 set_ext_ant_gain $gain2 $gain5
+/opt/rs9113/transmit rpine0 18 $rate 1536 1 $chan 0 $flag 0 0 0 255
+
diff --git a/recipes-kernel/rs9113/rs9113rf.inc b/recipes-kernel/rs9113/rs9113rf.inc
index 9fcea2b..ce8b7fc 100644
--- a/recipes-kernel/rs9113/rs9113rf.inc
+++ b/recipes-kernel/rs9113/rs9113rf.inc
@@ -2,7 +2,7 @@ DESCRIPTION = "Immunity testing for rs9113"
SECTION = "base"
PRIORITY = "optional"
LICENSE = "GPLv2+"
-PR = "r4"
+PR = "r1"
inherit allarch
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
SRC_URI = " \
diff --git a/recipes-kernel/rs9113/rs9113rf_1.1.bb b/recipes-kernel/rs9113/rs9113rf_1.2.bb
index 43ec216..43ec216 100644
--- a/recipes-kernel/rs9113/rs9113rf_1.1.bb
+++ b/recipes-kernel/rs9113/rs9113rf_1.2.bb