summaryrefslogtreecommitdiff
path: root/recipes-kernel/rs9113
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2022-01-19 18:14:33 -0600
committerJohn Klug <john.klug@multitech.com>2022-01-19 18:14:33 -0600
commit4577feee9ca7752b783e2e1ffadf4a238f04a423 (patch)
tree20461004c92389476151d187b14ae7cb0089b618 /recipes-kernel/rs9113
parent367710f415fe64bd4ca98153d0e8ffe04370f748 (diff)
downloadmeta-multitech-atmel-4577feee9ca7752b783e2e1ffadf4a238f04a423.tar.gz
meta-multitech-atmel-4577feee9ca7752b783e2e1ffadf4a238f04a423.tar.bz2
meta-multitech-atmel-4577feee9ca7752b783e2e1ffadf4a238f04a423.zip
rs9113: Use PKGR like other Dunfell recipes, move to rev 14
Diffstat (limited to 'recipes-kernel/rs9113')
-rwxr-xr-xrecipes-kernel/rs9113/files/rs9113/rs9113.init5
-rw-r--r--recipes-kernel/rs9113/rs9113-from-src_1.6.5.bb3
-rw-r--r--recipes-kernel/rs9113/rs9113_1.6.5.bb3
3 files changed, 7 insertions, 4 deletions
diff --git a/recipes-kernel/rs9113/files/rs9113/rs9113.init b/recipes-kernel/rs9113/files/rs9113/rs9113.init
index 6adeb5a..d5b31ec 100755
--- a/recipes-kernel/rs9113/files/rs9113/rs9113.init
+++ b/recipes-kernel/rs9113/files/rs9113/rs9113.init
@@ -45,15 +45,16 @@ function logpipe {
}
function rs9113_reset {
- for i in {1..5} ; do
+ for i in {1..10} ; do
if [[ -f $RS9113_RESET ]] ; then
break
fi
+ usleep 10000
done
# Reset the RS9113 chip is ready, and
# wait for it to settle.
- for i in {1..5} ; do
+ for i in {1..10} ; do
if [[ -f $RS9113_RESET ]] ; then
echo 0 >$RS9113_RESET
usleep $SLEEPTIME
diff --git a/recipes-kernel/rs9113/rs9113-from-src_1.6.5.bb b/recipes-kernel/rs9113/rs9113-from-src_1.6.5.bb
index 8dac47e..95ff29d 100644
--- a/recipes-kernel/rs9113/rs9113-from-src_1.6.5.bb
+++ b/recipes-kernel/rs9113/rs9113-from-src_1.6.5.bb
@@ -2,7 +2,8 @@ DESCRIPTION = "USB Driver for Redpine RS9113"
LICENSE = "Proprietary"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
PROVIDES = "rs9113-from-src"
-PR = "r12${KERNEL_MODULE_PACKAGE_SUFFIX}"
+PR = "r14"
+PKGR = "${PR}${KERNEL_MODULE_PACKAGE_SUFFIX}${EXTENDPRAUTO}"
INHIBIT_PACKAGE_STRIP = "1"
BB_STRICT_CHECKSUM = "0"
inherit module
diff --git a/recipes-kernel/rs9113/rs9113_1.6.5.bb b/recipes-kernel/rs9113/rs9113_1.6.5.bb
index 46578c9..ba6aa52 100644
--- a/recipes-kernel/rs9113/rs9113_1.6.5.bb
+++ b/recipes-kernel/rs9113/rs9113_1.6.5.bb
@@ -17,7 +17,8 @@ COMPATIBLE_MACHINE = "(mtcdt|mtrv1)"
# To update this, manually copy ipk from Jenkin's job to
# git://git@${MTS_INTERNAL_GIT}/mlinux/ipk.git;protocol=ssh;branch=${PV}
#
-PR = "r10${KERNEL_MODULE_PACKAGE_SUFFIX}"
+PR = "r14"
+PKGR = "${PR}${KERNEL_MODULE_PACKAGE_SUFFIX}${EXTENDPRAUTO}"
SRC_URI = " \
file://rs9113/rs9113.init \
file://rs9113/rs9113.default \