summaryrefslogtreecommitdiff
path: root/recipes-kernel/rs9113
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2021-10-26 09:51:38 -0500
committerAndrii Pientsov <andrii.pientsov@globallogic.com>2021-11-18 10:55:06 +0200
commit0c630ce6825b353bda5f3505d35afb904816e838 (patch)
tree6577b2333810d82d093e888f04362e55137ffb07 /recipes-kernel/rs9113
parent948c5945a4b324a5a33c395727df844fff25555f (diff)
downloadmeta-multitech-atmel-0c630ce6825b353bda5f3505d35afb904816e838.tar.gz
meta-multitech-atmel-0c630ce6825b353bda5f3505d35afb904816e838.tar.bz2
meta-multitech-atmel-0c630ce6825b353bda5f3505d35afb904816e838.zip
Turn off debug in the RS9113 driver due to too many warnings
Diffstat (limited to 'recipes-kernel/rs9113')
-rw-r--r--recipes-kernel/rs9113/rs9113-from-src/debug-rs9113.patch14
-rw-r--r--recipes-kernel/rs9113/rs9113-from-src_1.6.5.bb4
2 files changed, 17 insertions, 1 deletions
diff --git a/recipes-kernel/rs9113/rs9113-from-src/debug-rs9113.patch b/recipes-kernel/rs9113/rs9113-from-src/debug-rs9113.patch
new file mode 100644
index 0000000..4101116
--- /dev/null
+++ b/recipes-kernel/rs9113/rs9113-from-src/debug-rs9113.patch
@@ -0,0 +1,14 @@
+* Turn off debug to prevent performance issues
+=======================================================
+diff --git a/source/host/config/make.config b/source/host/config/make.config
+index fd5133b..fc4507d 100644
+--- a/source/host/config/make.config
++++ b/source/host/config/make.config
+@@ -48,7 +48,6 @@ ifeq ($(CONFIG_CHW_20_40), y)
+ endif
+
+
+-EXTRA_CFLAGS += -DONEBOX_DEBUG_ENABLE
+ EXTRA_CFLAGS += -DPROGRAMMING_BBP_TA
+ EXTRA_CFLAGS += -DPROGRAMMING_SCAN_TA
+ EXTRA_CFLAGS += -DRSI_SDIO_MULTI_BLOCK_SUPPORT
diff --git a/recipes-kernel/rs9113/rs9113-from-src_1.6.5.bb b/recipes-kernel/rs9113/rs9113-from-src_1.6.5.bb
index efd6549..a1af590 100644
--- a/recipes-kernel/rs9113/rs9113-from-src_1.6.5.bb
+++ b/recipes-kernel/rs9113/rs9113-from-src_1.6.5.bb
@@ -18,6 +18,8 @@ SRCREV_FORMAT = "machine"
SRC_URI = " \
git://git@${MTS_INTERNAL_GIT}/mlinux/meta-rs9113.git;protocol=ssh;branch=${PV};destsuffix=meta/ \
git://git@${MTS_INTERNAL_GIT}/mlinux/Redpine.git;protocol=ssh;branch=${PV} \
+ file://debug-rs9113.patch \
+ file://onebox-backlog-counter.patch \
"
SRCXX_URI = " \
git://git@${MTS_INTERNAL_GIT}/mlinux/Redpine.git;protocol=ssh;branch=${PV};name=machine \
@@ -59,7 +61,7 @@ do_compile () {
do_patch () {
cd ${WORKDIR}/git
- for f in ${M}/patches/* ; do
+ for f in ${M}/patches/* ../*.patch ; do
# Cannot use [[ $f =~ \.patch$ ]] here because the $ after patch breaks the recipe.
if echo ${f} | grep '\.patch$' >/dev/null 2>&1 ; then
echo found patch ${f}