summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux/linux-at91_4.9.87.bb
diff options
context:
space:
mode:
authorAndrii Pientsov <andrii.pientsov@globallogic.com>2021-01-13 14:07:25 +0200
committerAndrii Pientsov <andrii.pientsov@globallogic.com>2021-01-13 14:07:25 +0200
commiteff5e93a3a0b893eef7918dc217b2b703c754684 (patch)
treefdaf3483550e571ee6dadbdd534f078f784feec1 /recipes-kernel/linux/linux-at91_4.9.87.bb
parent452bce692c348270794e06b770834dc835da75cb (diff)
downloadmeta-multitech-atmel-eff5e93a3a0b893eef7918dc217b2b703c754684.tar.gz
meta-multitech-atmel-eff5e93a3a0b893eef7918dc217b2b703c754684.tar.bz2
meta-multitech-atmel-eff5e93a3a0b893eef7918dc217b2b703c754684.zip
Create a temporary device tree for MTRE based on MTRV1
Diffstat (limited to 'recipes-kernel/linux/linux-at91_4.9.87.bb')
-rw-r--r--recipes-kernel/linux/linux-at91_4.9.87.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-at91_4.9.87.bb b/recipes-kernel/linux/linux-at91_4.9.87.bb
index 24f1812..b8d6502 100644
--- a/recipes-kernel/linux/linux-at91_4.9.87.bb
+++ b/recipes-kernel/linux/linux-at91_4.9.87.bb
@@ -71,6 +71,11 @@ SRC_URI_append_mtr = "\
file://fix-atmel-mci-reg-overloading.patch \
file://wl12xx_enable_disable.patch \
"
+#TODO FIX DEVICE TREE for MTRE
+SRC_URI_append_mtre = "\
+ ${COMMON_PATCHES} \
+ file://linux-4.9-mtre-device-tree.patch \
+ "
KERNEL_MODULE_AUTOLOAD_mtcap_append += "i2c-dev"
KERNEL_MODULE_AUTOLOAD_mtcdt_append += "i2c-dev"
@@ -78,6 +83,7 @@ DTB_APPEND_mtcdt = "mtcdt"
DTB_APPEND_mtrv1 = "mtrv1"
DTB_APPEND_mtcap = "mtcap"
DTB_APPEND_mtr = "mtr"
+DTB_APPEND_mtre = "mtre"
python __anonymous () {
if d.getVar('UBOOT_FIT_IMAGE', True) == 'xyes':
@@ -116,7 +122,7 @@ kernel_do_configure_append() {
KERNEL_MODULE_PACKAGE_SUFFIX=""
-COMPATIBLE_MACHINE = "(mtcdt|mtrv1|mtr|mtcap|mths)"
+COMPATIBLE_MACHINE = "(mtcdt|mtrv1|mtr|mtcap|mths|mtre)"
pkg_preinst_kernel-image-uimage() {
set -x