summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux/linux-at91_4.9.87.bb
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2019-01-04 15:13:02 -0600
committerJohn Klug <john.klug@multitech.com>2019-01-04 15:13:02 -0600
commitcb905d8eb251a58ab3f613c61dbbc3ef9efe8628 (patch)
tree91ab756098620e6c00903eef6feb5da0063de514 /recipes-kernel/linux/linux-at91_4.9.87.bb
parent372ccaa4781d87dc48ffb5cd28be978d2c86aa62 (diff)
downloadmeta-multitech-atmel-cb905d8eb251a58ab3f613c61dbbc3ef9efe8628.tar.gz
meta-multitech-atmel-cb905d8eb251a58ab3f613c61dbbc3ef9efe8628.tar.bz2
meta-multitech-atmel-cb905d8eb251a58ab3f613c61dbbc3ef9efe8628.zip
Simplify package updates with OPKG
Diffstat (limited to 'recipes-kernel/linux/linux-at91_4.9.87.bb')
-rw-r--r--recipes-kernel/linux/linux-at91_4.9.87.bb8
1 files changed, 2 insertions, 6 deletions
diff --git a/recipes-kernel/linux/linux-at91_4.9.87.bb b/recipes-kernel/linux/linux-at91_4.9.87.bb
index 60685f0..8b55f61 100644
--- a/recipes-kernel/linux/linux-at91_4.9.87.bb
+++ b/recipes-kernel/linux/linux-at91_4.9.87.bb
@@ -99,11 +99,7 @@ pkg_prerm_kernel-image-uimage() {
PACKAGES =+ "kernel-image-uimage-inst kernel-dt-bindings-dev"
# Not sure how to get the name below generated automatically
-#KERNELVERSION = "4.9.87-linux4sam-5.8-dirty"
-KERNELVERSION = "${PV}"
-#KERNELVERSION2 = "4.9.87-linux4sam_5.8-dirty"
-KERNELVERSION2 = "${PV}"
-RDEPENDS_kernel-image-uimage-inst += "kernel-image-uimage-${KERNELVERSION}"
+RDEPENDS_kernel-image-uimage-inst += "kernel-image-uimage-${PV}"
ALLOW_EMPTY_kernel-image-uimage-inst = "1"
pkg_postinst_kernel-image-uimage-inst() {
@@ -113,7 +109,7 @@ pkg_postinst_kernel-image-uimage-inst() {
set -x
kernel_mtd="/dev/$(cat /proc/mtd | grep '\"uImage\"' | cut -d : -f 1)"
flash_erase ${kernel_mtd} 0 0
- if nandwrite -p ${kernel_mtd} /boot/uImage-${KERNELVERSION2} ; then
+ if nandwrite -p ${kernel_mtd} /boot/uImage-${PV} ; then
echo 'Kernel image update is successful'
fi
set +x