summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMike Nicholson <mike.nicholson@multitech.com>2020-08-28 17:41:43 -0500
committerMike Nicholson <mike.nicholson@multitech.com>2020-08-28 17:41:43 -0500
commit0c107b08548dbef0f94e1db1a9b0fb16b6c96bfc (patch)
tree2c8b5c628d20995cc84b6084abc7547248780166 /recipes-bsp
parent9d6d495b791691a6ec7715eb951f296ae3c1ce7d (diff)
downloadmeta-multitech-atmel-0c107b08548dbef0f94e1db1a9b0fb16b6c96bfc.tar.gz
meta-multitech-atmel-0c107b08548dbef0f94e1db1a9b0fb16b6c96bfc.tar.bz2
meta-multitech-atmel-0c107b08548dbef0f94e1db1a9b0fb16b6c96bfc.zip
Move to mt-dt-overlay with MTCAP support
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/multitech/mt-dt-overlay_1.0.1.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/recipes-bsp/multitech/mt-dt-overlay_1.0.1.bb b/recipes-bsp/multitech/mt-dt-overlay_1.0.1.bb
new file mode 100644
index 0000000..2714705
--- /dev/null
+++ b/recipes-bsp/multitech/mt-dt-overlay_1.0.1.bb
@@ -0,0 +1,53 @@
+DESCRIPTION = "Compile MT board device tree overlays"
+LICENSE = "(GPLv2+)"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+# By using an overlay, we should be able to support multiple pinouts
+# using the same image. The overlays go into /lib/dtoverlays.
+# There names are: [hw-version]-driver.dtbo
+# e.g. /lib/dtoverlays/MTRV1-0.0-pps.dtbo
+# The idea is that mts-io will search for the overlays, and install the
+# appropriate device tree overlay for the current hw-version.
+
+dt_dir = "/lib/dtoverlays"
+
+PR = "r1"
+
+SRC_URI = "git://git.multitech.net/mt-dt-overlay.git;protocol=git"
+
+SRCREV = "${PV}"
+
+DEPENDS = "virtual/kernel u-boot-mkimage-native"
+
+S = "${WORKDIR}/git"
+
+do_compile[depends] += "virtual/kernel:do_deploy virtual/kernel:do_shared_workdir"
+do_compile[nostamp] = "1"
+
+do_compile () {
+ echo MACHINE is ${MACHINE}
+ oe_runmake DTC=/usr/bin/dtc KERNEL_DIR=${STAGING_KERNEL_DIR} KERNEL_BUILD_DIR=${KERNEL_PATH} ${MACHINE}_dtbos
+}
+
+FILES_${PN} = "${dt_dir}"
+
+addtask install after do_compile
+
+do_install () {
+ # Copy files to /lib/dt-overlay/main (mtac cards will be in mtac)
+ if [ -e ${AT91BOOTSTRAP_MACHINE} ]; then
+ install -d ${D}/${dt_dir}
+ (
+ cd ${MACHINE}
+ for f in *.dtbo ; do
+ if [[ -h $f ]] ; then
+ cp -df ${f} ${D}/${dt_dir}
+ else
+ install ${f} ${D}/${dt_dir}
+ fi
+ done
+ )
+ fi;
+}
+