summaryrefslogtreecommitdiff
path: root/recipes-bsp/wl12xx-firmware/wl12xx-firmware_r6.bb
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2019-02-28 10:56:37 -0600
committerJohn Klug <john.klug@multitech.com>2019-02-28 10:56:37 -0600
commitf5a2e833004731e3f9d9b74bed79a7d9e870b812 (patch)
tree4721451003b317e476f531c73f2d9b6ec5cc92fa /recipes-bsp/wl12xx-firmware/wl12xx-firmware_r6.bb
parent1983e5064b2e6bdb270a4c5f261591a7c686771b (diff)
downloadmeta-multitech-atmel-f5a2e833004731e3f9d9b74bed79a7d9e870b812.tar.gz
meta-multitech-atmel-f5a2e833004731e3f9d9b74bed79a7d9e870b812.tar.bz2
meta-multitech-atmel-f5a2e833004731e3f9d9b74bed79a7d9e870b812.zip
Use latest firmware
Diffstat (limited to 'recipes-bsp/wl12xx-firmware/wl12xx-firmware_r6.bb')
-rw-r--r--recipes-bsp/wl12xx-firmware/wl12xx-firmware_r6.bb17
1 files changed, 10 insertions, 7 deletions
diff --git a/recipes-bsp/wl12xx-firmware/wl12xx-firmware_r6.bb b/recipes-bsp/wl12xx-firmware/wl12xx-firmware_r6.bb
index 75423c0..ed7fe36 100644
--- a/recipes-bsp/wl12xx-firmware/wl12xx-firmware_r6.bb
+++ b/recipes-bsp/wl12xx-firmware/wl12xx-firmware_r6.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "TI wl1271 firmware"
HOMEPAGE = "http://processors.wiki.ti.com/index.php/ARM_Processor_Open_Source_Wireless_Connectivity"
LICENSE = "Proprietary"
LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=1c9961176d6529283e0d0c983be41b45"
-PR="r6"
+PR="r9"
# bluetooth firmware from TI-ECS on github.com:
# https://github.com/TI-ECS/bt-firmware.git
@@ -10,10 +10,10 @@ PR="r6"
# Last file log message: "Updated to service pack 2.14"
# file: am335x/TIInit_7.6.15.bts
# md5sum: a46c46104c7fab23bb9ebfae1633a3af
-# wifi firmware from TI-OpenLink on github.com
-# https://github.com/TI-OpenLink/firmwares.git
-# revision 977880610b1ad9048f4b7804ba5b8fa454e0b76a
-# Last file log message: "Update the wl127x and wl128x firmwares to *.3.10.0.133 for single-role and *.5.7.0.42 for multi-role."
+# wifi firmware from Wkennington on github.com
+# https://github.com/wkennington/linux-firmware/tree/master/ti-connectivity
+# revision 6d3bc8886517d171068fd1263176b8b5c51df204
+# Last file log message: "Fix permissions on ti-connectivity firmware from 05e9fe5 Signed-off-by: Kyle McMartin <kyle@kernel.org>"
# file: ti-connectivity/wl127x-fw-5-sr.bin
# file: ti-connectivity/wl127x-fw-5-mr.bin
# file: ti-connectivity/wl127x-fw-5-plt.bin
@@ -23,6 +23,7 @@ SRC_URI = "file://wl127x-fw-5-mr.bin \
file://wl127x-fw-5-sr.bin \
file://TIInit_7.6.15.bts \
file://wl1271-nvs.bin \
+ file://calibrate-wifi \
file://LICENSE "
# nothing to compile
@@ -34,6 +35,7 @@ do_compile() {
do_install() {
install -d ${D}/lib/firmware
+ install -d ${D}/sbin
install -d ${D}/lib/firmware/ti-connectivity
# wifi firmware
install ${WORKDIR}/wl127x-fw-*-*.bin ${D}/lib/firmware/ti-connectivity
@@ -41,9 +43,10 @@ do_install() {
# use local copy since the one in hw/firmware dir is *wrong*
install ${WORKDIR}/wl1271-nvs.bin ${D}/lib/firmware/ti-connectivity/wl1271-nvs.bin.factory
# link to nvs file with mac address set
- ln -sf wl1271-nvs.bin.factory ${D}/lib/firmware/ti-connectivity/wl1271-nvs.bin
+ ln -sf /var/oem/mts/wl1271-nvs.bin ${D}/lib/firmware/ti-connectivity/wl127x-nvs.bin
+ install ${WORKDIR}/calibrate-wifi ${D}/sbin
# bluetooth firmware
install ${WORKDIR}/TIInit_7.6.15.bts ${D}/lib/firmware/ti-connectivity/TIInit_7.6.15.bts
}
-FILES_${PN} = "/lib/firmware"
+FILES_${PN} = "/lib/firmware /sbin"