summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-04-11 09:56:56 -0500
committerJohn Klug <john.klug@multitech.com>2017-04-24 11:43:22 -0500
commit15d63924bce5d059519b1ef2a1da7f9d357bb32f (patch)
treec6dc2c884ebc9fd2d0638deff449399e4a463a53 /recipes-bsp/u-boot
parent29e17716525867068ad3925c572dcd454ac15a2d (diff)
downloadmeta-multitech-atmel-15d63924bce5d059519b1ef2a1da7f9d357bb32f.tar.gz
meta-multitech-atmel-15d63924bce5d059519b1ef2a1da7f9d357bb32f.tar.bz2
meta-multitech-atmel-15d63924bce5d059519b1ef2a1da7f9d357bb32f.zip
Add header files to u-boot developer package.
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot.inc4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot.inc b/recipes-bsp/u-boot/u-boot.inc
index 38a8a79..869b142 100644
--- a/recipes-bsp/u-boot/u-boot.inc
+++ b/recipes-bsp/u-boot/u-boot.inc
@@ -29,6 +29,8 @@ SPL_BINARY ?= ""
SPL_IMAGE ?= "${SPL_BINARY}-${MACHINE}-${PV}-${PR}"
SPL_SYMLINK ?= "${SPL_BINARY}-${MACHINE}"
+FILES_${PN}-dev += "${includedir}/u-boot/* ${includedir}/u-boot/configs/* ${includedir}/u-boot/asm/*"
+
do_compile () {
if [ "${@base_contains('DISTRO_FEATURES', 'ld-is-gold', 'ld-is-gold', '', d)}" = "ld-is-gold" ] ; then
sed -i 's/$(CROSS_COMPILE)ld$/$(CROSS_COMPILE)ld.bfd/g' config.mk
@@ -63,6 +65,8 @@ do_install () {
install ${S}/${SPL_BINARY} ${D}/boot/${SPL_IMAGE}
ln -sf ${SPL_IMAGE} ${D}/boot/${SPL_BINARY}
fi
+ mkdir -p ${D}/usr/include/u-boot || true
+ (cd ${S}/include;find . | cpio -pdum ${D}/usr/include/u-boot)
}
FILES_${PN} = "/boot ${sysconfdir}"