summaryrefslogtreecommitdiff
path: root/recipes-bsp/at91bootstrap
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-05-23 18:23:27 -0500
committerJohn Klug <john.klug@multitech.com>2017-06-09 09:09:19 -0500
commitefd44696f886fbe10946118db729c0ce63a38f02 (patch)
tree1975c056f984365d496d7ccc5e661960454b88cf /recipes-bsp/at91bootstrap
parent03aab7ba023e69dc174b728302a6942f7b3b4603 (diff)
downloadmeta-multitech-atmel-efd44696f886fbe10946118db729c0ce63a38f02.tar.gz
meta-multitech-atmel-efd44696f886fbe10946118db729c0ce63a38f02.tar.bz2
meta-multitech-atmel-efd44696f886fbe10946118db729c0ce63a38f02.zip
Set the orig file to match the old at91bootstrap build.
Diffstat (limited to 'recipes-bsp/at91bootstrap')
-rw-r--r--recipes-bsp/at91bootstrap/at91bootstrap_3.5.3.bb.orig31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-bsp/at91bootstrap/at91bootstrap_3.5.3.bb.orig b/recipes-bsp/at91bootstrap/at91bootstrap_3.5.3.bb.orig
new file mode 100644
index 0000000..c6ae7a7
--- /dev/null
+++ b/recipes-bsp/at91bootstrap/at91bootstrap_3.5.3.bb.orig
@@ -0,0 +1,31 @@
+require at91bootstrap_3.5.inc
+
+PR = "r2"
+
+LICENSE = "custom-freely-distributable"
+LIC_FILES_CHKSUM = "file://main.c;beginline=6;endline=26;md5=6fca71334c9e8b7d033296123c91437f"
+
+SRCREV = "v${PV}"
+SRC_URI = "git://github.com/linux4sam/at91bootstrap \
+ file://at91bootstrap-3.5.2-add-install.patch \
+ file://at91bootstrap-3.5.2-onetime-slow-clock-switch.patch \
+ file://at91sam9x5_4bit_pmecc_header.bin \
+ file://at91bootstrap-3.5.3-remove-std-includes.patch \
+ "
+
+S = "${WORKDIR}/git"
+
+SRC_URI_append_mtcdt = " file://at91bootstrap-3.5.3-mtcdt.patch "
+SRC_URI_append_mtcap = " file://at91bootstrap-3.5.3-mtcdt.patch "
+
+# generate a bootstrap file padded with the header needed for 4-bit PMECC
+# The padded file can be flashed via u-boot without any need to set the PMECC header using SAM-BA
+do_pad_4bit_pmecc() {
+ cp -f ${WORKDIR}/at91sam9x5_4bit_pmecc_header.bin ${DEPLOY_DIR_IMAGE}/at91bootstrap_pmecc_padded.bin
+ cat ${DEPLOY_DIR_IMAGE}/at91bootstrap.bin >> ${DEPLOY_DIR_IMAGE}/at91bootstrap_pmecc_padded.bin
+}
+
+do_install_append() {
+ do_pad_4bit_pmecc
+}
+