summaryrefslogtreecommitdiff
path: root/recipes-bsp/at91bootstrap
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2019-05-23 13:06:50 -0500
committerJohn Klug <john.klug@multitech.com>2019-05-23 13:06:50 -0500
commit932269f9bf70f6c3d8c6d2edbfcea0e3c3a4bdc2 (patch)
tree2817ccdd0998fdc0ee394b41e5e753e50c8c0db7 /recipes-bsp/at91bootstrap
parenta0421aea85f050b70e984b11377a9ab4fbceb878 (diff)
downloadmeta-multitech-atmel-932269f9bf70f6c3d8c6d2edbfcea0e3c3a4bdc2.tar.gz
meta-multitech-atmel-932269f9bf70f6c3d8c6d2edbfcea0e3c3a4bdc2.tar.bz2
meta-multitech-atmel-932269f9bf70f6c3d8c6d2edbfcea0e3c3a4bdc2.zip
GNSS reset fix to suppress GPS serial port to protect XR12V1414 from bad PID/VID
Diffstat (limited to 'recipes-bsp/at91bootstrap')
-rw-r--r--recipes-bsp/at91bootstrap/at91bootstrap-3.8.12/at91bootstrap-3.8-mtcdt.patch18
-rw-r--r--recipes-bsp/at91bootstrap/at91bootstrap_3.8.12.bb2
2 files changed, 13 insertions, 7 deletions
diff --git a/recipes-bsp/at91bootstrap/at91bootstrap-3.8.12/at91bootstrap-3.8-mtcdt.patch b/recipes-bsp/at91bootstrap/at91bootstrap-3.8.12/at91bootstrap-3.8-mtcdt.patch
index f299d30..8710ee5 100644
--- a/recipes-bsp/at91bootstrap/at91bootstrap-3.8.12/at91bootstrap-3.8-mtcdt.patch
+++ b/recipes-bsp/at91bootstrap/at91bootstrap-3.8.12/at91bootstrap-3.8-mtcdt.patch
@@ -1,7 +1,7 @@
diff -aNru orig/board/at91sam9x5ek/at91sam9x5ek.c new/board/at91sam9x5ek/at91sam9x5ek.c
--- orig/board/at91sam9x5ek/at91sam9x5ek.c 2019-04-16 14:20:15.036823256 -0500
+++ new/board/at91sam9x5ek/at91sam9x5ek.c 2019-04-16 14:26:10.648812728 -0500
-@@ -44,6 +44,31 @@
+@@ -44,6 +44,37 @@
#include "at91sam9x5ek.h"
#include "board_hw_info.h"
@@ -12,12 +12,18 @@ diff -aNru orig/board/at91sam9x5ek/at91sam9x5ek.c new/board/at91sam9x5ek/at91sam
+ const struct pio_desc mt_gpio_pins[] = {
+ /* Misc. pins -- Pins PD15-PD18 belong to PERIPH
+ * B A20-A25 until bootstrap shuts them down.
-+ * This code prevents these pins from being used
-+ * during boot, since we do not
-+ * need these pins to boot the system and we
-+ * do not want resets to toggle needlessly.
++ * This code prevents these pins from being used
++ * during boot, since we do not
++ * need these pins to boot the system and we
++ * do not want resets to toggle needlessly.
++ * GNSS-RESET is held low because the EXAR
++ * rarely will display the wrong VID/PID on the
++ * USB bus, which prevents the vizzini driver
++ * from loading. Once the VID/PID is bad, a
++ * reboot will preserve the bad VID/PID, so
++ * a power cycle is then required.
+ */
-+ {"GNSS-RESET",AT91C_PIN_PD(15), 1, PIO_PULLUP, PIO_OUTPUT},
++ {"GNSS-RESET",AT91C_PIN_PD(15), 0, PIO_PULLUP, PIO_OUTPUT},
+ {"SECURE-RESET",AT91C_PIN_PD(16), 1, PIO_PULLUP, PIO_OUTPUT},
+ {"MTQ-RESET",AT91C_PIN_PD(17), 1, PIO_PULLUP, PIO_OUTPUT},
+ {"USBHUB-RESET",AT91C_PIN_PD(18), 1, PIO_PULLUP, PIO_OUTPUT},
diff --git a/recipes-bsp/at91bootstrap/at91bootstrap_3.8.12.bb b/recipes-bsp/at91bootstrap/at91bootstrap_3.8.12.bb
index 99ba701..dcbb649 100644
--- a/recipes-bsp/at91bootstrap/at91bootstrap_3.8.12.bb
+++ b/recipes-bsp/at91bootstrap/at91bootstrap_3.8.12.bb
@@ -1,5 +1,5 @@
require at91bootstrap.inc
-PR = "m1"
+PR = "m2"
LIC_FILES_CHKSUM = "file://main.c;endline=27;md5=a2a70db58191379e2550cbed95449fbd"