summaryrefslogtreecommitdiff
path: root/recipes-bsp/at91bootstrap
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-05-24 09:42:38 -0500
committerJohn Klug <john.klug@multitech.com>2017-06-09 09:09:19 -0500
commit486bef6fa33f0a97dda230f210ebdc5c5f6d7f83 (patch)
tree17eac6836796835fb7c3c306a9e92fca7d812df4 /recipes-bsp/at91bootstrap
parente8c071bef1635a9f82e90e40b50350dc65b7f64d (diff)
downloadmeta-multitech-atmel-486bef6fa33f0a97dda230f210ebdc5c5f6d7f83.tar.gz
meta-multitech-atmel-486bef6fa33f0a97dda230f210ebdc5c5f6d7f83.tar.bz2
meta-multitech-atmel-486bef6fa33f0a97dda230f210ebdc5c5f6d7f83.zip
at91bootstrap with MTR RTC patch
Diffstat (limited to 'recipes-bsp/at91bootstrap')
-rw-r--r--recipes-bsp/at91bootstrap/at91bootstrap_3.5.3.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-bsp/at91bootstrap/at91bootstrap_3.5.3.bb b/recipes-bsp/at91bootstrap/at91bootstrap_3.5.3.bb
new file mode 100644
index 0000000..2e5f086
--- /dev/null
+++ b/recipes-bsp/at91bootstrap/at91bootstrap_3.5.3.bb
@@ -0,0 +1,30 @@
+require at91bootstrap_3.5.inc
+
+PR = "r3"
+
+LICENSE = "custom-freely-distributable"
+LIC_FILES_CHKSUM = "file://main.c;beginline=6;endline=26;md5=6fca71334c9e8b7d033296123c91437f"
+
+SRCREV = "v${PV}"
+SRC_URI = "git://github.com/linux4sam/at91bootstrap \
+ file://at91bootstrap-3.5.2-add-install.patch \
+ file://at91bootstrap-3.5.2-onetime-slow-clock-switch.patch \
+ file://at91sam9x5_4bit_pmecc_header.bin \
+ file://at91bootstrap-3.5.3-disable-rtc-interrupts.patch"
+
+S = "${WORKDIR}/git"
+
+SRC_URI_append_mtcdt = " file://at91bootstrap-3.5.3-mtcdt.patch "
+SRC_URI_append_mtcap = " file://at91bootstrap-3.5.3-mtcdt.patch "
+
+# generate a bootstrap file padded with the header needed for 4-bit PMECC
+# The padded file can be flashed via u-boot without any need to set the PMECC header using SAM-BA
+do_pad_4bit_pmecc() {
+ cp -f ${WORKDIR}/at91sam9x5_4bit_pmecc_header.bin ${DEPLOY_DIR_IMAGE}/at91bootstrap_pmecc_padded.bin
+ cat ${DEPLOY_DIR_IMAGE}/at91bootstrap.bin >> ${DEPLOY_DIR_IMAGE}/at91bootstrap_pmecc_padded.bin
+}
+
+do_install_append() {
+ do_pad_4bit_pmecc
+}
+