summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-05-12 18:26:28 -0500
committerJohn Klug <john.klug@multitech.com>2017-06-09 09:09:19 -0500
commite2f2dce006439e3c7a35737b15ed7da03ba0bc2a (patch)
tree9f84c5fb98d6fea84e4c9878880298248e08a28a
parent06f304cec0ee3260ccd28bcc47d591eb1fca257d (diff)
downloadmeta-multitech-atmel-e2f2dce006439e3c7a35737b15ed7da03ba0bc2a.tar.gz
meta-multitech-atmel-e2f2dce006439e3c7a35737b15ed7da03ba0bc2a.tar.bz2
meta-multitech-atmel-e2f2dce006439e3c7a35737b15ed7da03ba0bc2a.zip
Merging morty with master (Daisy).
-rw-r--r--conf/machine/mtcdt.conf6
-rw-r--r--recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/.at91bootstrap-3.5.2-onetime-slow-clock-switch.patch.swpbin0 -> 12288 bytes
-rw-r--r--recipes-bsp/at91bootstrap/at91bootstrap_3.5.3.bb30
-rw-r--r--recipes-bsp/u-boot/u-boot.inc3
-rw-r--r--recipes-bsp/u-boot/u-boot.inc.orig89
-rw-r--r--recipes-bsp/u-boot/u-boot_2012.10.bb42
-rw-r--r--recipes-bsp/u-boot/u-boot_2016.03.bb3
-rw-r--r--recipes-kernel/linux/linux-3.12.70/mtcdt/defconfig4
8 files changed, 101 insertions, 76 deletions
diff --git a/conf/machine/mtcdt.conf b/conf/machine/mtcdt.conf
index 58339dd..0fef766 100644
--- a/conf/machine/mtcdt.conf
+++ b/conf/machine/mtcdt.conf
@@ -14,7 +14,10 @@ PREFERRED_VERSION_kernel-module-vizzini ?= "1.1"
DEFAULTTUNE = "arm926ejs"
TUNE_CCARGS = " -march=armv5te -marm -mthumb-interwork -mtune=arm926ej-s"
TUNE_FEATURES = "arm armv5 thumb dsp arm926ejs"
+<<<<<<< HEAD
ARMPKGSFX_THUMB="t"
+=======
+>>>>>>> Initial commit of Yocto 2.1 changes
# used by sysvinit_2
SERIAL_CONSOLES = "115200;ttyS0"
@@ -31,7 +34,8 @@ KERNEL_IMAGETYPE = "uImage"
# remove kernel-image from rootfs by overriding kernel-base DEPS
RDEPENDS_kernel-base = ""
-EXTRA_IMAGEDEPENDS += "at91bootstrap u-boot"
+#EXTRA_IMAGEDEPENDS += "at91bootstrap u-boot"
+EXTRA_IMAGEDEPENDS += "u-boot"
IMAGE_FSTYPES =+ "jffs2 tar.gz"
EXTRA_IMAGECMD_jffs2 = "--little-endian --eraseblock=0x20000 --pagesize=0x800 -n"
diff --git a/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/.at91bootstrap-3.5.2-onetime-slow-clock-switch.patch.swp b/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/.at91bootstrap-3.5.2-onetime-slow-clock-switch.patch.swp
new file mode 100644
index 0000000..f31477d
--- /dev/null
+++ b/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/.at91bootstrap-3.5.2-onetime-slow-clock-switch.patch.swp
Binary files differ
diff --git a/recipes-bsp/at91bootstrap/at91bootstrap_3.5.3.bb b/recipes-bsp/at91bootstrap/at91bootstrap_3.5.3.bb
deleted file mode 100644
index 2e5f086..0000000
--- a/recipes-bsp/at91bootstrap/at91bootstrap_3.5.3.bb
+++ /dev/null
@@ -1,30 +0,0 @@
-require at91bootstrap_3.5.inc
-
-PR = "r3"
-
-LICENSE = "custom-freely-distributable"
-LIC_FILES_CHKSUM = "file://main.c;beginline=6;endline=26;md5=6fca71334c9e8b7d033296123c91437f"
-
-SRCREV = "v${PV}"
-SRC_URI = "git://github.com/linux4sam/at91bootstrap \
- file://at91bootstrap-3.5.2-add-install.patch \
- file://at91bootstrap-3.5.2-onetime-slow-clock-switch.patch \
- file://at91sam9x5_4bit_pmecc_header.bin \
- file://at91bootstrap-3.5.3-disable-rtc-interrupts.patch"
-
-S = "${WORKDIR}/git"
-
-SRC_URI_append_mtcdt = " file://at91bootstrap-3.5.3-mtcdt.patch "
-SRC_URI_append_mtcap = " file://at91bootstrap-3.5.3-mtcdt.patch "
-
-# generate a bootstrap file padded with the header needed for 4-bit PMECC
-# The padded file can be flashed via u-boot without any need to set the PMECC header using SAM-BA
-do_pad_4bit_pmecc() {
- cp -f ${WORKDIR}/at91sam9x5_4bit_pmecc_header.bin ${DEPLOY_DIR_IMAGE}/at91bootstrap_pmecc_padded.bin
- cat ${DEPLOY_DIR_IMAGE}/at91bootstrap.bin >> ${DEPLOY_DIR_IMAGE}/at91bootstrap_pmecc_padded.bin
-}
-
-do_install_append() {
- do_pad_4bit_pmecc
-}
-
diff --git a/recipes-bsp/u-boot/u-boot.inc b/recipes-bsp/u-boot/u-boot.inc
index 6db11f8..d004d85 100644
--- a/recipes-bsp/u-boot/u-boot.inc
+++ b/recipes-bsp/u-boot/u-boot.inc
@@ -64,9 +64,6 @@ UBOOT_ENV ?= ""
UBOOT_ENV_BINARY ?= "${UBOOT_ENV}.${UBOOT_ENV_SUFFIX}"
UBOOT_ENV_IMAGE ?= "${UBOOT_ENV}-${MACHINE}-${PV}-${PR}.${UBOOT_ENV_SUFFIX}"
UBOOT_ENV_SYMLINK ?= "${UBOOT_ENV}-${MACHINE}.${UBOOT_ENV_SUFFIX}"
-
-FILES_${PN}-dev += "${includedir}/u-boot/* ${includedir}/u-boot/configs/* ${includedir}/u-boot/asm/*"
-
FILES_${PN}-dev += "${includedir}/u-boot/* ${includedir}/u-boot/configs/* ${includedir}/u-boot/asm/*"
do_compile () {
diff --git a/recipes-bsp/u-boot/u-boot.inc.orig b/recipes-bsp/u-boot/u-boot.inc.orig
new file mode 100644
index 0000000..38a8a79
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot.inc.orig
@@ -0,0 +1,89 @@
+DESCRIPTION = "U-Boot - the Universal Boot Loader"
+HOMEPAGE = "http://www.denx.de/wiki/U-Boot/WebHome"
+SECTION = "bootloaders"
+PROVIDES = "virtual/bootloader"
+
+inherit uboot-config deploy
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"'
+
+# Allow setting an additional version string that will be picked up by the
+# u-boot build system and appended to the u-boot version. If the .scmversion
+# file already exists it will not be overwritten.
+UBOOT_LOCALVERSION ?= ""
+
+# Some versions of u-boot use .bin and others use .img. By default use .bin
+# but enable individual recipes to change this value.
+UBOOT_SUFFIX ?= "bin"
+UBOOT_IMAGE ?= "u-boot-${MACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
+UBOOT_BINARY ?= "u-boot.${UBOOT_SUFFIX}"
+UBOOT_SYMLINK ?= "u-boot-${MACHINE}.${UBOOT_SUFFIX}"
+UBOOT_MAKE_TARGET ?= "all"
+
+# Some versions of u-boot build an SPL (Second Program Loader) image that
+# should be packaged along with the u-boot binary as well as placed in the
+# deploy directory. For those versions they can set the following variables
+# to allow packaging the SPL.
+SPL_BINARY ?= ""
+SPL_IMAGE ?= "${SPL_BINARY}-${MACHINE}-${PV}-${PR}"
+SPL_SYMLINK ?= "${SPL_BINARY}-${MACHINE}"
+
+do_compile () {
+ if [ "${@base_contains('DISTRO_FEATURES', 'ld-is-gold', 'ld-is-gold', '', d)}" = "ld-is-gold" ] ; then
+ sed -i 's/$(CROSS_COMPILE)ld$/$(CROSS_COMPILE)ld.bfd/g' config.mk
+ fi
+
+ unset LDFLAGS
+ unset CFLAGS
+ unset CPPFLAGS
+
+ if [ ! -e ${B}/.scmversion -a ! -e ${S}/.scmversion ]
+ then
+ echo ${UBOOT_LOCALVERSION} > ${B}/.scmversion
+ echo ${UBOOT_LOCALVERSION} > ${S}/.scmversion
+ fi
+
+ oe_runmake ${UBOOT_MACHINE}
+ oe_runmake ${UBOOT_MAKE_TARGET}
+}
+
+do_install () {
+ install -d ${D}/boot
+ install ${S}/${UBOOT_BINARY} ${D}/boot/${UBOOT_IMAGE}
+ ln -sf ${UBOOT_IMAGE} ${D}/boot/${UBOOT_BINARY}
+
+ if [ -e ${WORKDIR}/fw_env.config ] ; then
+ install -d ${D}${sysconfdir}
+ install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
+ fi
+
+ if [ "x${SPL_BINARY}" != "x" ]
+ then
+ install ${S}/${SPL_BINARY} ${D}/boot/${SPL_IMAGE}
+ ln -sf ${SPL_IMAGE} ${D}/boot/${SPL_BINARY}
+ fi
+}
+
+FILES_${PN} = "/boot ${sysconfdir}"
+FILESPATH =. "${FILE_DIRNAME}/u-boot-git/${MACHINE}:"
+
+do_deploy () {
+ install -d ${DEPLOYDIR}
+ install ${S}/${UBOOT_BINARY} ${DEPLOYDIR}/${UBOOT_IMAGE}
+
+ cd ${DEPLOYDIR}
+ rm -f ${UBOOT_BINARY} ${UBOOT_SYMLINK}
+ ln -sf ${UBOOT_IMAGE} ${UBOOT_SYMLINK}
+ ln -sf ${UBOOT_IMAGE} ${UBOOT_BINARY}
+
+ if [ "x${SPL_BINARY}" != "x" ]
+ then
+ install ${S}/${SPL_BINARY} ${DEPLOYDIR}/${SPL_IMAGE}
+ rm -f ${DEPLOYDIR}/${SPL_BINARY} ${DEPLOYDIR}/${SPL_SYMLINK}
+ ln -sf ${SPL_IMAGE} ${DEPLOYDIR}/${SPL_BINARY}
+ ln -sf ${SPL_IMAGE} ${DEPLOYDIR}/${SPL_SYMLINK}
+ fi
+}
+
+addtask deploy before do_build after do_compile
diff --git a/recipes-bsp/u-boot/u-boot_2012.10.bb b/recipes-bsp/u-boot/u-boot_2012.10.bb
deleted file mode 100644
index 51cd565..0000000
--- a/recipes-bsp/u-boot/u-boot_2012.10.bb
+++ /dev/null
@@ -1,42 +0,0 @@
-PR = "r7"
-require u-boot.inc
-
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
-
-DEFAULT_PREFERENCE = "-1"
-
-# U-Boot 2012.10 for AT91
-# tag: linux4sam_4.0
-SRCREV="8978bdafbad84c0c9878c9ff331930ca6edf9a76"
-
-SRC_URI = "git://github.com/linux4sam/u-boot-at91.git;branch=u-boot-2012.10-at91 \
- file://u-boot-2012.10-sam9x5-eth-mii-fix.patch \
- file://u-boot-env-crc-dbg.patch \
- "
-
-# add patch to speed up boot if ethernet autonegotiation fails
-SRC_URI += "file://u-boot-2010.06-macb-autoneg-timeout.patch"
-# add password protection patch
-SRC_URI += "file://u-boot-2012.10-pwd.patch"
-
-SRC_URI_append_mtcdt = " file://u-boot-2012.10-mtcdt.patch"
-SRC_URI_append_mtcap = " file://u-boot-2012.10-mtcdt.patch"
-
-TARGET_LDFLAGS = ""
-
-S = "${WORKDIR}/git"
-
-inherit base
-
-do_configure_prepend() {
- mv -f tools/setlocalversion tools/setlocalversion.old
- echo -e "#!/bin/sh\necho '-${MACHINE}-${PR}'" > tools/setlocalversion
- chmod a+rx tools/setlocalversion
-}
-
-do_compile () {
- oe_runmake ${UBOOT_MACHINE}
- oe_runmake all
-}
-
diff --git a/recipes-bsp/u-boot/u-boot_2016.03.bb b/recipes-bsp/u-boot/u-boot_2016.03.bb
index 1f58b50..77fce05 100644
--- a/recipes-bsp/u-boot/u-boot_2016.03.bb
+++ b/recipes-bsp/u-boot/u-boot_2016.03.bb
@@ -8,8 +8,11 @@ DEPENDS += "dtc-native"
SRCREV = "df61a74e6845ec9bdcdd48d2aff5e9c2c6debeaa"
PV = "v2016.03+git${SRCPV}"
+<<<<<<< HEAD
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-2016.03:"
SRC_URI += "file://mtcdt.patch"
SRC_URI += "file://spl.patch"
SRC_URI += "file://i2c.patch"
+=======
+>>>>>>> Initial commit of Yocto 2.1 changes
diff --git a/recipes-kernel/linux/linux-3.12.70/mtcdt/defconfig b/recipes-kernel/linux/linux-3.12.70/mtcdt/defconfig
index 9f5265e..82dc224 100644
--- a/recipes-kernel/linux/linux-3.12.70/mtcdt/defconfig
+++ b/recipes-kernel/linux/linux-3.12.70/mtcdt/defconfig
@@ -963,7 +963,11 @@ CONFIG_MTD_CFI_I2=y
# Self-contained MTD device drivers
#
# CONFIG_MTD_DATAFLASH is not set
+<<<<<<< HEAD
CONFIG_MTD_M25P80=m
+=======
+# CONFIG_MTD_M25P80 is not set
+>>>>>>> Initial commit of Yocto 2.1 changes
# CONFIG_MTD_SST25L is not set
# CONFIG_MTD_SLRAM is not set
# CONFIG_MTD_PHRAM is not set