summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Dorokhin <mykyta.dorokhin@globallogic.com>2021-01-18 12:31:33 +0200
committerMykyta Dorokhin <mykyta.dorokhin@globallogic.com>2021-01-18 12:31:33 +0200
commitccb7db27ddd86bbe1d1a9231d66fb2181917268f (patch)
tree4f91f934b0a38de95ac5403848fbf3efd857a9b4
parent6a8b0d682079edffe75dd5736ec1d9bc152fbed5 (diff)
downloadmeta-multitech-atmel-ccb7db27ddd86bbe1d1a9231d66fb2181917268f.tar.gz
meta-multitech-atmel-ccb7db27ddd86bbe1d1a9231d66fb2181917268f.tar.bz2
meta-multitech-atmel-ccb7db27ddd86bbe1d1a9231d66fb2181917268f.zip
linux 5.4: add modules autoload instructions
-rw-r--r--recipes-kernel/linux/linux-at91_5.4.81.bb124
1 files changed, 121 insertions, 3 deletions
diff --git a/recipes-kernel/linux/linux-at91_5.4.81.bb b/recipes-kernel/linux/linux-at91_5.4.81.bb
index 4ce96ec..9b3a2e9 100644
--- a/recipes-kernel/linux/linux-at91_5.4.81.bb
+++ b/recipes-kernel/linux/linux-at91_5.4.81.bb
@@ -127,12 +127,130 @@ do_deploy_append() {
fi
}
-KERNEL_MODULE_AUTOLOAD += "atmel_usba_udc g_serial"
-
DTB_APPEND_mtcdt = "mtcdt"
DTB_APPEND_mtrv1 = "mtrv1"
DTB_APPEND_mtcap = "mtcap"
DTB_APPEND_mtr = "mtr"
+COMPATIBLE_MACHINE = "(mtcdt|mtrv1|mtr|mtcap|mths)"
+
+NET_LOAD_ALL_MACHINES += " \
+ 8021q \
+ bnep \
+ br_netfilter \
+ dns_resolver \
+ garp \
+ ip6_gre \
+ ip6table_filter \
+ ip6table_mangle \
+ ip6table_nat \
+ ip6table_raw \
+ ip6t_ah \
+ ip6t_eui64 \
+ ip6t_frag \
+ ip6t_hbh \
+ ip6t_ipv6header \
+ ip6t_MASQUERADE \
+ ip6t_mh \
+ ip6t_NPT \
+ ip6t_REJECT \
+ ip6t_rpfilter \
+ ip6t_rt \
+ ip6t_SYNPROXY \
+ ip6_vti \
+ ipip \
+ iptable_mangle \
+ iptable_nat \
+ iptable_netfilter \
+ iptable_raw \
+ ip_tables \
+ ipt_ah \
+ ip_vs \
+ l2tp_ppp \
+ mac80211 \
+ mrp \
+ nf_conntrack_ipv4 \
+ nf_conntrack_ipv6 \
+ nf_conntrack_netbios_ns \
+ nf_conntrack_netlink \
+ nf_log_ipv4 \
+ nf_log_ipv6 \
+ nf_nat_ftp \
+ nf_nat_h323 \
+ nf_nat_pptp \
+ nf_nat_sip \
+ nf_nat_snmp_basic \
+ nfnetlink_cttimeout \
+ nf_tables_inet \
+ nf_tables_netdev \
+ nft_exthdr \
+ nft_meta \
+ p8022 \
+ psnap \
+ rfcomm \
+ rfkill-gpio \
+ rfkill-regulator \
+ sit \
+ tun \
+ xfrm6_mode_tunnel \
+ xt_CLASSIFY \
+ xt_connmark \
+ xt_conntrack \
+ xt_CT \
+ xt_ecn \
+ xt_esp \
+ xt_hashlimit \
+ xt_hl \
+ xt_HL \
+ xt_iprange \
+ xt_l2tp \
+ xt_LED \
+ xt_limit \
+ xt_LOG \
+ xt_mac \
+ xt_mark \
+ xt_multiport \
+ xt_nat \
+ xt_NETMAP \
+ xt_NFLOG \
+ xt_NFQUEUE \
+ xt_policy \
+ xt_recent \
+ xt_REDIRECT \
+ xt_set \
+ xt_state \
+ xt_tcpudp \
+ xt_TEE \
+ xt_time \
+ xt_TPROXY \
+ ledtrig-netdev \
+"
+
+DRIVER_LOAD_ALL_MACHINES = " \
+ atmel_usba_udc \
+ ledtrig-default-on \
+ ledtrig-heartbeat \
+ ledtrig-timer \
+"
-COMPATIBLE_MACHINE = "(mtcdt|mtrv1|mtr|mtcap|mths)" \ No newline at end of file
+KERNEL_MODULE_AUTOLOAD_mtcdt += " \
+ g_serial \
+ softdog \
+"
+
+KERNEL_MODULE_AUTOLOAD_mtcdt += " \
+ ${NET_LOAD_ALL_MACHINES} \
+ ${DRIVER_LOAD_ALL_MACHINES} \
+"
+KERNEL_MODULE_AUTOLOAD_mtrv1 += " \
+ ${NET_LOAD_ALL_MACHINES} \
+ ${DRIVER_LOAD_ALL_MACHINES} \
+"
+KERNEL_MODULE_AUTOLOAD_mtr += " \
+ ${NET_LOAD_ALL_MACHINES} \
+ ${DRIVER_LOAD_ALL_MACHINES} \
+"
+KERNEL_MODULE_AUTOLOAD_mtcap += " \
+ ${NET_LOAD_ALL_MACHINES} \
+ ${DRIVER_LOAD_ALL_MACHINES} \
+"