summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Dorokhin <mykyta.dorokhin@globallogic.com>2021-02-06 18:21:04 +0200
committerMykyta Dorokhin <mykyta.dorokhin@globallogic.com>2021-02-06 18:21:04 +0200
commit3d427056864ead89d0fd025eec5df4fdee61d21b (patch)
tree8f49d38aa02f648e26fbf436fa4650e9c0390c85
parent7c0599b8bcfac7f63b59cc607b9bf8e967a608a0 (diff)
downloadmeta-multitech-atmel-3d427056864ead89d0fd025eec5df4fdee61d21b.tar.gz
meta-multitech-atmel-3d427056864ead89d0fd025eec5df4fdee61d21b.tar.bz2
meta-multitech-atmel-3d427056864ead89d0fd025eec5df4fdee61d21b.zip
linux-5.4: minor kernel recipe optimization
-rw-r--r--recipes-kernel/linux/linux-at91_5.4.81.bb13
1 files changed, 4 insertions, 9 deletions
diff --git a/recipes-kernel/linux/linux-at91_5.4.81.bb b/recipes-kernel/linux/linux-at91_5.4.81.bb
index acb0272..557026b 100644
--- a/recipes-kernel/linux/linux-at91_5.4.81.bb
+++ b/recipes-kernel/linux/linux-at91_5.4.81.bb
@@ -48,15 +48,19 @@ COMMON_PATCHES = " \
"
SRC_URI_append_mtcdt = "\
+ file://mts-dts/mtcdt.dts \
${COMMON_PATCHES} \
"
SRC_URI_append_mtrv1 = "\
+ file://mts-dts/mtrv1.dts \
${COMMON_PATCHES} \
"
SRC_URI_append_mtcap = "\
+ file://mts-dts/mtcap.dts \
${COMMON_PATCHES} \
"
SRC_URI_append_mtr = "\
+ file://mts-dts/mtr.dts \
${COMMON_PATCHES} \
file://linux-5.4-fix-atmel-mci-reg-overloading.patch \
file://linux-5.4-wl12xx_enable_disable.patch \
@@ -67,15 +71,6 @@ python __anonymous () {
d.appendVar('DEPENDS', ' u-boot-mkimage-native dtc-native')
}
-copy_mts_dts_files () {
- # Install MTS device tree files
- cp -f ${THISDIR}/linux-at91-5.4.81/mts-dts/${MACHINE}.dts ${S}/arch/${ARCH}/boot/dts/
-}
-
-python do_unpack_append () {
- bb.build.exec_func('copy_mts_dts_files', d)
-}
-
# Files needed to build external kernel modules.
do_shared_workdir_append() {
install -d -m 755 ${STAGING_KERNEL_BUILDDIR}/include/config