summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorandrii.davydenko <andrii.davydenko@globallogic.com>2022-08-19 17:07:03 +0300
committerJohn Klug <john.klug@multitech.com>2022-11-16 18:07:23 -0600
commit37ed870fa6925f3bff33ab893e9c6977babeb17c (patch)
treed677db04cf44cf49df55a0779e8b0d683a1ac723
parent5f18187f4cd84d20fac8051a720f4746bede4bbb (diff)
downloadmeta-multitech-atmel-37ed870fa6925f3bff33ab893e9c6977babeb17c.tar.gz
meta-multitech-atmel-37ed870fa6925f3bff33ab893e9c6977babeb17c.tar.bz2
meta-multitech-atmel-37ed870fa6925f3bff33ab893e9c6977babeb17c.zip
[MTX-4566][GP-1689] Manufacturing: Atmel based devices - process improvement
Add SDMFG variable instead of BB_USE_SD
-rw-r--r--conf/machine/mtcdt.conf2
-rw-r--r--recipes-bsp/at91bootstrap/at91bootstrap.inc4
-rw-r--r--recipes-bsp/u-boot/u-boot.inc7
-rw-r--r--recipes-bsp/u-boot/u-boot_2016.09.01.bb4
4 files changed, 11 insertions, 6 deletions
diff --git a/conf/machine/mtcdt.conf b/conf/machine/mtcdt.conf
index 4738601..097d27d 100644
--- a/conf/machine/mtcdt.conf
+++ b/conf/machine/mtcdt.conf
@@ -44,3 +44,5 @@ PREFERRED_VERSION_rs9113 = '1.6.5'
PRINC ?= "0"
PACKAGECONFIG_append_pn-boost = " python"
+
+SDMFG ??= ""
diff --git a/recipes-bsp/at91bootstrap/at91bootstrap.inc b/recipes-bsp/at91bootstrap/at91bootstrap.inc
index f2f29bd..6dfc9ef 100644
--- a/recipes-bsp/at91bootstrap/at91bootstrap.inc
+++ b/recipes-bsp/at91bootstrap/at91bootstrap.inc
@@ -18,7 +18,7 @@ inherit cml1 deploy
# TODO: python2: use python3
inherit python3-dir python3native
-DEFCONFIG = "${@oe.utils.conditional('BB_USE_SD', '1', 'file://defconfig-sd', 'file://defconfig-n', d)}"
+DEFCONFIG = "${@oe.utils.conditional('SDMFG', '', 'file://defconfig-n', 'file://defconfig-sd', d)}"
SRC_URI_append = " \
${DEFCONFIG} \
@@ -92,7 +92,7 @@ do_configure() {
if [ ${MACHINE} = "mtcdt" ] ; then
bbnote "Found mtcdt"
- if [ -n "${BB_USE_SD}" -a "${BB_USE_SD}" = "1" ]; then
+ if [ -n "${SDMFG}" ]; then
bbnote "Building for SD card"
cp ${WORKDIR}/defconfig-sd ${WORKDIR}/defconfig
else
diff --git a/recipes-bsp/u-boot/u-boot.inc b/recipes-bsp/u-boot/u-boot.inc
index e4e534a..cba40c9 100644
--- a/recipes-bsp/u-boot/u-boot.inc
+++ b/recipes-bsp/u-boot/u-boot.inc
@@ -6,6 +6,9 @@ PROVIDES = "virtual/bootloader"
# New U-Boot with suppressed version.
PR="m5"
+# Add a '-sd' suffix to the PR for SDMFG builds
+PR .= "${@oe.utils.conditional("SDMFG", "", "", "-sd", d)}"
+
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
@@ -85,8 +88,8 @@ do_patch_append () {
except TypeError:
bb.fatal("PR is missing from recipe")
f.write(PR + os.linesep)
- SDCARD = d.getVar("BB_USE_SD",True)
- if (SDCARD == 1):
+ SDCARD = d.getVar("SDMFG",True)
+ if (SDCARD != ""):
try:
S = d.getVar("S",True)
except TypeError:
diff --git a/recipes-bsp/u-boot/u-boot_2016.09.01.bb b/recipes-bsp/u-boot/u-boot_2016.09.01.bb
index 300bcab..2d7ba27 100644
--- a/recipes-bsp/u-boot/u-boot_2016.09.01.bb
+++ b/recipes-bsp/u-boot/u-boot_2016.09.01.bb
@@ -3,8 +3,8 @@ require u-boot.inc
DEPENDS += "dtc-native"
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-2016.09.01:"
-CONFIG_PATCH = "${@oe.utils.conditional('BB_USE_SD', '1', 'file://config-sd.patch', 'file://config-n.patch', d)}"
-MTCDT_PATCH = "${@oe.utils.conditional('BB_USE_SD', '1', 'file://mtcdt-sd.patch', 'file://mtcdt-n.patch', d)}"
+CONFIG_PATCH = "${@oe.utils.conditional('SDMFG', '', 'file://config-n.patch', 'file://config-sd.patch', d)}"
+MTCDT_PATCH = "${@oe.utils.conditional('SDMFG', '', 'file://mtcdt-n.patch', 'file://mtcdt-sd.patch', d)}"
# file://mtpwd.path
SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \