summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVyacheslav Pedash <vyacheslav.pedash@globallogic.com>2023-08-18 17:48:20 +0300
committerVyacheslav Pedash <vyacheslav.pedash@globallogic.com>2023-08-18 17:48:20 +0300
commit20def296509899676b8d812032fc0e70ec06541e (patch)
tree9d1485fe34b48bb0179a6341437a43bc42a4ea72
parentf85d2259ea400e6313e86915f81079736394d563 (diff)
downloadmeta-multitech-atmel-20def296509899676b8d812032fc0e70ec06541e.tar.gz
meta-multitech-atmel-20def296509899676b8d812032fc0e70ec06541e.tar.bz2
meta-multitech-atmel-20def296509899676b8d812032fc0e70ec06541e.zip
MTX-5053 Update RS911x driver to v. 2.6.1
New driver has a fix for WPA2-PSK connections with wpa-supplicant v 2.10 and above.
-rw-r--r--recipes-kernel/rsi-91x/files/0001_concurrent_compilation_fix.patch26
-rw-r--r--recipes-kernel/rsi-91x/files/fix-rsi-handle-card-ready.patch (renamed from recipes-kernel/rsi-91x/files/0002-fix-rsi_handle_card_ready-card-ready.patch)25
-rw-r--r--recipes-kernel/rsi-91x/files/rsi-91x-config.patch16
-rw-r--r--recipes-kernel/rsi-91x/files/rsi-91x-sta-ap.patch16
-rw-r--r--recipes-kernel/rsi-91x/files/rsi-bt91x-config.patch16
-rw-r--r--recipes-kernel/rsi-91x/rsi-91x-fw_2.6.1.bb (renamed from recipes-kernel/rsi-91x/rsi-91x-fw_2.5.1.bb)6
-rw-r--r--recipes-kernel/rsi-91x/rsi-91x-sta-ap_2.6.1.bb (renamed from recipes-kernel/rsi-91x/rsi-91x-sta-ap_2.5.1.bb)9
-rw-r--r--recipes-kernel/rsi-91x/rsi-91x-utils_2.6.1.bb (renamed from recipes-kernel/rsi-91x/rsi-91x-utils_2.5.1.bb)6
-rw-r--r--recipes-kernel/rsi-91x/rsi-91x_2.6.1.bb (renamed from recipes-kernel/rsi-91x/rsi-91x_2.5.1.bb)13
-rw-r--r--recipes-kernel/rsi-91x/rsi-bt91x_2.6.1.bb (renamed from recipes-kernel/rsi-91x/rsi-bt91x_2.5.1.bb)9
10 files changed, 54 insertions, 88 deletions
diff --git a/recipes-kernel/rsi-91x/files/0001_concurrent_compilation_fix.patch b/recipes-kernel/rsi-91x/files/0001_concurrent_compilation_fix.patch
deleted file mode 100644
index 5615c78..0000000
--- a/recipes-kernel/rsi-91x/files/0001_concurrent_compilation_fix.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-rs9116 rsi-91x linux driver fails to compile in Station + AP mode
-
-Silicon labs patch from case 00297277
-
-https://community.silabs.com/5008Y000024DTst
-==================================================
-diff --git a/rsi_91x_per.c b/rsi_91x_per.c
-index 031f3fc..d57b8fa 100644
---- a/rsi_91x_per.c
-+++ b/rsi_91x_per.c
-@@ -145,7 +145,6 @@ int rsi_send_rx_stats_cmd(struct rsi_hw *adapter, struct nlmsghdr *nlh)
- int status = 0;
- #endif
-
-- if (common->driver_mode == E2E_MODE) {
- #ifndef CONFIG_STA_PLUS_AP
- struct ieee80211_vif *vif = adapter->vifs[0];
- bool assoc = vif && vif->bss_conf.assoc;
-@@ -154,6 +153,7 @@ int rsi_send_rx_stats_cmd(struct rsi_hw *adapter, struct nlmsghdr *nlh)
- bool assoc = sta_vif && sta_vif->bss_conf.assoc;
- #endif
-
-+ if (common->driver_mode == E2E_MODE) {
- if (!assoc && adapter->ps_state == PS_ENABLED)
- rsi_disable_ps(adapter);
- goto SEND_STATS_FRAME;
diff --git a/recipes-kernel/rsi-91x/files/0002-fix-rsi_handle_card_ready-card-ready.patch b/recipes-kernel/rsi-91x/files/fix-rsi-handle-card-ready.patch
index aeed2c9..aed069a 100644
--- a/recipes-kernel/rsi-91x/files/0002-fix-rsi_handle_card_ready-card-ready.patch
+++ b/recipes-kernel/rsi-91x/files/fix-rsi-handle-card-ready.patch
@@ -1,18 +1,8 @@
-From 822df5990784ba914a1622e81b2b9ea4e079d5ea Mon Sep 17 00:00:00 2001
-From: Serhii Voloshynov <serhii.voloshynov@globallogic.com>
-Date: Thu, 29 Dec 2022 09:36:07 +0200
-Subject: [PATCH] fix 'rsi_handle_card_ready: card ready indication in invalid
- state 0.' issue
-
----
-rsi_91x_hal.c | 5 +++--
- 1 file changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/rsi_91x_hal.c b/rsi_91x_hal.c
-index c3d5823..e3eeec6 100644
---- a/rsi_91x_hal.c
-+++ b/rsi_91x_hal.c
-@@ -1703,6 +1703,9 @@ int rsi_hal_device_init(struct rsi_hw *adapter)
+diff --git a/rsi/rsi_91x_hal.c b/rsi/rsi_91x_hal.c
+index b9166f6..a94b871 100644
+--- a/rsi/rsi_91x_hal.c
++++ b/rsi/rsi_91x_hal.c
+@@ -1794,6 +1794,9 @@ int rsi_hal_device_init(struct rsi_hw *adapter)
rsi_dbg(ERR_ZONE, "%s: oper_mode = %d, coex_mode = %d\n", __func__, common->oper_mode, common->coex_mode);
@@ -22,7 +12,7 @@ index c3d5823..e3eeec6 100644
switch (adapter->device_model) {
case RSI_DEV_9113:
case RSI_DEV_9116:
-@@ -1714,8 +1717,6 @@ int rsi_hal_device_init(struct rsi_hw *adapter)
+@@ -1805,8 +1808,6 @@ int rsi_hal_device_init(struct rsi_hw *adapter)
default:
return -EINVAL;
}
@@ -31,6 +21,3 @@ index c3d5823..e3eeec6 100644
#if defined(CONFIG_RSI_BT_ALONE) || defined(CONFIG_RSI_COEX_MODE)
adapter->priv->bt_fsm_state = BT_DEVICE_NOT_READY;
---
-2.25.1
-
diff --git a/recipes-kernel/rsi-91x/files/rsi-91x-config.patch b/recipes-kernel/rsi-91x/files/rsi-91x-config.patch
index c711698..448c7b2 100644
--- a/recipes-kernel/rsi-91x/files/rsi-91x-config.patch
+++ b/recipes-kernel/rsi-91x/files/rsi-91x-config.patch
@@ -1,8 +1,8 @@
diff --git a/rsi/Makefile b/rsi/Makefile
-index 64f7742..e74d971 100644
+index 0c610f8..a7ec0cc 100644
--- a/rsi/Makefile
+++ b/rsi/Makefile
-@@ -45,7 +45,7 @@ KERNELDIR=/lib/modules/$(KERNELRELEASE)/build
+@@ -17,7 +17,7 @@ KERNELDIR=/lib/modules/$(KERNELRELEASE)/build
#CONFIG_RSI_BT_ALONE=y
# Uncomment below line for Wi-Fi BT coex mode
@@ -11,7 +11,7 @@ index 64f7742..e74d971 100644
# Uncomment below line for WLAN + Zigbee coex mode
#CONFIG_RSI_ZIGB=y
-@@ -196,10 +196,15 @@ rsi_usb-objs := $(COMMON_USB_OBJS)
+@@ -168,13 +168,18 @@ rsi_usb-objs := $(COMMON_USB_OBJS)
rsi_91x-objs := $(RSI_91X_OBJS)
all:
@@ -19,13 +19,15 @@ index 64f7742..e74d971 100644
+ env
@echo -e "\033[32mCompiling RSI drivers...\033[0m"
make -C$(KERNELDIR)/ M=$(PWD) modules
-- @echo -e "application compilation"
+ chmod 777 start_rs9116.sh
+ chmod 777 osd_common_insert.sh
- make CC="$(CC)" ROOT_DIR=$(ROOT_DIR) -C $(PWD)/apps
-+ # @echo -e "application compilation"
+ # make CC="$(CC)" ROOT_DIR=$(ROOT_DIR) -C $(PWD)/apps
-+
+ @echo -e "\033[32mCompilation done SUCCESSFULLY\033[0m"
+
+modules_install:
+ $(MAKE) -C $(KERNELDIR) M=$(PWD) modules_install
-
++
clean:
make -C$(KERNELDIR)/ M=$(PWD) clean
+ @find . -name 'receive' | xargs rm -rf
diff --git a/recipes-kernel/rsi-91x/files/rsi-91x-sta-ap.patch b/recipes-kernel/rsi-91x/files/rsi-91x-sta-ap.patch
index 73c3e1b..d542ae2 100644
--- a/recipes-kernel/rsi-91x/files/rsi-91x-sta-ap.patch
+++ b/recipes-kernel/rsi-91x/files/rsi-91x-sta-ap.patch
@@ -1,8 +1,8 @@
diff --git a/rsi/Makefile b/rsi/Makefile
-index 64f7742..951b7a1 100644
+index 0c610f8..ad0caaa 100644
--- a/rsi/Makefile
+++ b/rsi/Makefile
-@@ -57,7 +57,7 @@ KERNELDIR=/lib/modules/$(KERNELRELEASE)/build
+@@ -29,7 +29,7 @@ KERNELDIR=/lib/modules/$(KERNELRELEASE)/build
#CONFIG_RSI_P2P=y
# Uncomment below line for using Concurrent mode
@@ -11,7 +11,7 @@ index 64f7742..951b7a1 100644
# Uncomment below line for platforms with no SDIO multiblock support
#CONFIG_RSI_NO_SDIO_MULTIBLOCK=y
-@@ -190,16 +190,21 @@ ifeq ($(OFFLOAD_SCAN_TO_DEVICE), y)
+@@ -162,19 +162,24 @@ ifeq ($(OFFLOAD_SCAN_TO_DEVICE), y)
EXTRA_CFLAGS += -DOFFLOAD_SCAN_TO_DEVICE
endif
@@ -28,13 +28,15 @@ index 64f7742..951b7a1 100644
+ env
@echo -e "\033[32mCompiling RSI drivers...\033[0m"
make -C$(KERNELDIR)/ M=$(PWD) modules
-- @echo -e "application compilation"
+ chmod 777 start_rs9116.sh
+ chmod 777 osd_common_insert.sh
- make CC="$(CC)" ROOT_DIR=$(ROOT_DIR) -C $(PWD)/apps
-+ # @echo -e "application compilation"
+ # make CC="$(CC)" ROOT_DIR=$(ROOT_DIR) -C $(PWD)/apps
-+
+ @echo -e "\033[32mCompilation done SUCCESSFULLY\033[0m"
+
+modules_install:
+ $(MAKE) -C $(KERNELDIR) M=$(PWD) modules_install
-
++
clean:
make -C$(KERNELDIR)/ M=$(PWD) clean
+ @find . -name 'receive' | xargs rm -rf
diff --git a/recipes-kernel/rsi-91x/files/rsi-bt91x-config.patch b/recipes-kernel/rsi-91x/files/rsi-bt91x-config.patch
index 3bda909..3f74f50 100644
--- a/recipes-kernel/rsi-91x/files/rsi-bt91x-config.patch
+++ b/recipes-kernel/rsi-91x/files/rsi-bt91x-config.patch
@@ -1,8 +1,8 @@
diff --git a/rsi/Makefile b/rsi/Makefile
-index 64f7742..bc088b8 100644
+index 0c610f8..7af43f7 100644
--- a/rsi/Makefile
+++ b/rsi/Makefile
-@@ -42,7 +42,7 @@ KERNELDIR=/lib/modules/$(KERNELRELEASE)/build
+@@ -14,7 +14,7 @@ KERNELDIR=/lib/modules/$(KERNELRELEASE)/build
#CONFIG_SDIO_INTR_POLL=y
# Uncomment below line for BT alone (Classic/LE/Dual) mode
@@ -11,7 +11,7 @@ index 64f7742..bc088b8 100644
# Uncomment below line for Wi-Fi BT coex mode
#CONFIG_RSI_COEX_MODE=y
-@@ -190,16 +190,21 @@ ifeq ($(OFFLOAD_SCAN_TO_DEVICE), y)
+@@ -162,19 +162,24 @@ ifeq ($(OFFLOAD_SCAN_TO_DEVICE), y)
EXTRA_CFLAGS += -DOFFLOAD_SCAN_TO_DEVICE
endif
@@ -29,13 +29,15 @@ index 64f7742..bc088b8 100644
+ env
@echo -e "\033[32mCompiling RSI drivers...\033[0m"
make -C$(KERNELDIR)/ M=$(PWD) modules
-- @echo -e "application compilation"
+ chmod 777 start_rs9116.sh
+ chmod 777 osd_common_insert.sh
- make CC="$(CC)" ROOT_DIR=$(ROOT_DIR) -C $(PWD)/apps
-+ # @echo -e "application compilation"
+ # make CC="$(CC)" ROOT_DIR=$(ROOT_DIR) -C $(PWD)/apps
-+
+ @echo -e "\033[32mCompilation done SUCCESSFULLY\033[0m"
+
+modules_install:
+ $(MAKE) -C $(KERNELDIR) M=$(PWD) modules_install
-
++
clean:
make -C$(KERNELDIR)/ M=$(PWD) clean
+ @find . -name 'receive' | xargs rm -rf
diff --git a/recipes-kernel/rsi-91x/rsi-91x-fw_2.5.1.bb b/recipes-kernel/rsi-91x/rsi-91x-fw_2.6.1.bb
index 19dca25..099600b 100644
--- a/recipes-kernel/rsi-91x/rsi-91x-fw_2.5.1.bb
+++ b/recipes-kernel/rsi-91x/rsi-91x-fw_2.6.1.bb
@@ -1,6 +1,6 @@
-LIC_FILES_CHKSUM = "file://${WORKDIR}/git/rsi/Makefile;beginline=1;endline=29;md5=5eb8ffe925477437d8fcd5e2859c96a1"
-LICENSE = "BSD-3-Clause"
-PR = "r3"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+PR = "r4"
inherit allarch
inherit update-rc.d
diff --git a/recipes-kernel/rsi-91x/rsi-91x-sta-ap_2.5.1.bb b/recipes-kernel/rsi-91x/rsi-91x-sta-ap_2.6.1.bb
index 56c2de6..d2db9a3 100644
--- a/recipes-kernel/rsi-91x/rsi-91x-sta-ap_2.5.1.bb
+++ b/recipes-kernel/rsi-91x/rsi-91x-sta-ap_2.6.1.bb
@@ -1,6 +1,6 @@
-LICENSE = "GPLv2+|BSD"
+LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-PR = "r1"
+PR = "r2"
PKGR = "${PR}${KERNEL_MODULE_PACKAGE_SUFFIX}${EXTENDPRAUTO}"
RPROVIDES_kernel-module-${PN} = "${PN}"
inherit module
@@ -8,9 +8,8 @@ inherit module
SRCREV = "v${PV}"
SRC_URI = "git://github.com/SiliconLabs/RS911X-nLink-OSD.git;protocol=https \
file://rsi-91x-sta-ap.patch;striplevel=2 \
- file://0001_concurrent_compilation_fix.patch \
- file://0002-fix-rsi_handle_card_ready-card-ready.patch \
- "
+ file://fix-rsi-handle-card-ready.patch;striplevel=2 \
+ "
S = "${WORKDIR}/git/rsi"
EXTRA_OEMAKE = " KERNELDIR=${STAGING_KERNEL_DIR} \
diff --git a/recipes-kernel/rsi-91x/rsi-91x-utils_2.5.1.bb b/recipes-kernel/rsi-91x/rsi-91x-utils_2.6.1.bb
index 49cb4d2..9f5d7ff 100644
--- a/recipes-kernel/rsi-91x/rsi-91x-utils_2.5.1.bb
+++ b/recipes-kernel/rsi-91x/rsi-91x-utils_2.6.1.bb
@@ -1,6 +1,6 @@
-LIC_FILES_CHKSUM = "file://${WORKDIR}/git/rsi/apps/onebox_util.c;beginline=5;endline=17;md5=de9e3b7d092ee142ef090acc79db39c1"
-LICENSE = "CLOSED"
-PR = "r2"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+PR = "r3"
RDEPENDS_${PN} += "bash"
diff --git a/recipes-kernel/rsi-91x/rsi-91x_2.5.1.bb b/recipes-kernel/rsi-91x/rsi-91x_2.6.1.bb
index 24e79a1..09c674f 100644
--- a/recipes-kernel/rsi-91x/rsi-91x_2.5.1.bb
+++ b/recipes-kernel/rsi-91x/rsi-91x_2.6.1.bb
@@ -1,17 +1,18 @@
-LICENSE = "GPLv2+|BSD"
+LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-PR = "r2"
+PR = "r3"
PKGR = "${PR}${KERNEL_MODULE_PACKAGE_SUFFIX}${EXTENDPRAUTO}"
RPROVIDES_kernel-module-rsi-91x = "rsi-91x"
inherit module
SRCREV = "v${PV}"
+
SRC_URI = "git://github.com/SiliconLabs/RS911X-nLink-OSD.git;protocol=https \
file://rsi-91x-config.patch;striplevel=2 \
- file://0001_concurrent_compilation_fix.patch \
- file://0002-fix-rsi_handle_card_ready-card-ready.patch \
- "
-S = "${WORKDIR}/git/rsi"
+ file://fix-rsi-handle-card-ready.patch;striplevel=2 \
+ "
+
+S = "${WORKDIR}/git/rsi/"
EXTRA_OEMAKE = " KERNELDIR=${STAGING_KERNEL_DIR} \
CROSS_COMPILE=${TARGET_PREFIX} \
diff --git a/recipes-kernel/rsi-91x/rsi-bt91x_2.5.1.bb b/recipes-kernel/rsi-91x/rsi-bt91x_2.6.1.bb
index d2cdaa9..f720b0a 100644
--- a/recipes-kernel/rsi-91x/rsi-bt91x_2.5.1.bb
+++ b/recipes-kernel/rsi-91x/rsi-bt91x_2.6.1.bb
@@ -1,6 +1,6 @@
-LICENSE = "GPLv2+|BSD"
+LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-PR = "r2"
+PR = "r3"
PKGR = "${PR}${KERNEL_MODULE_PACKAGE_SUFFIX}${EXTENDPRAUTO}"
RPROVIDES_kernel-module-rsi-bt91x = "rsi-bt91x"
inherit module
@@ -8,9 +8,8 @@ inherit module
SRCREV = "v${PV}"
SRC_URI = "git://github.com/SiliconLabs/RS911X-nLink-OSD.git;protocol=https \
file://rsi-bt91x-config.patch;striplevel=2 \
- file://0001_concurrent_compilation_fix.patch \
- file://0002-fix-rsi_handle_card_ready-card-ready.patch \
- "
+ file://fix-rsi-handle-card-ready.patch;striplevel=2 \
+ "
S = "${WORKDIR}/git/rsi"
EXTRA_OEMAKE = " KERNELDIR=${STAGING_KERNEL_DIR} \