summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerhii Voloshynov <serhii.voloshynov@globallogic.com>2020-06-23 14:35:15 +0300
committerSerhii Voloshynov <serhii.voloshynov@globallogic.com>2020-06-23 15:22:24 +0300
commit10460289cbbc1f2bc83284d2aa0d3369da8bd53e (patch)
tree7183a666d18e926b41d797e8c7e27c4cf5a6883e
parent8e3bb757f96e45118d0ff00d5a8c9c35d79226aa (diff)
downloadmeta-multitech-atmel-10460289cbbc1f2bc83284d2aa0d3369da8bd53e.tar.gz
meta-multitech-atmel-10460289cbbc1f2bc83284d2aa0d3369da8bd53e.tar.bz2
meta-multitech-atmel-10460289cbbc1f2bc83284d2aa0d3369da8bd53e.zip
add user data partition
-rw-r--r--contrib/uboot-setenv-mtcdt.minicom5
-rw-r--r--contrib/uboot-setenv-mtcdt.ttl7
-rw-r--r--contrib/uboot-setenv-mtr.minicom5
-rw-r--r--contrib/uboot-setenv-mtrv1.minicom5
-rw-r--r--recipes-kernel/linux/linux-at91-4.9.87/mtcap/linux-4.9-mtcap-device-tree.patch8
-rw-r--r--recipes-kernel/linux/linux-at91-4.9.87/mtcdt/linux-4.9-mtcdt-device-tree.patch10
-rw-r--r--recipes-kernel/linux/linux-at91-4.9.87/mtr/linux-4.9-mtr-device-tree.patch8
-rw-r--r--recipes-kernel/linux/linux-at91-4.9.87/mtrv1/linux-4.9-mtrv1-device-tree.patch8
8 files changed, 39 insertions, 17 deletions
diff --git a/contrib/uboot-setenv-mtcdt.minicom b/contrib/uboot-setenv-mtcdt.minicom
index c7685b7..5ab6c6c 100644
--- a/contrib/uboot-setenv-mtcdt.minicom
+++ b/contrib/uboot-setenv-mtcdt.minicom
@@ -12,7 +12,7 @@ send setenv stdout serial
send setenv stderr serial
send setenv ethact macb0
send setenv mtdids nand0=nand0
-send setenv mtdparts mtdparts=nand0:256k(bootstrap),512k(u-boot),640k(u-boot-env1),640k(u-boot-env2),6M(kernel),8M(config),8M(oem),-(rootfs)
+send setenv mtdparts mtdparts=nand0:256k(bootstrap),512k(u-boot),640k(u-boot-env1),640k(u-boot-env2),6M(kernel),8M(config),8M(oem),128M(rootfs),-(user)
send setenv bootstrap_file oe_bootstrap_pmecc_padded.bin
send setenv uboot_file oe_u-boot.bin
send setenv uboot_env1_file oe_uboot_env1.bin
@@ -44,6 +44,7 @@ send setenv erase_kernel \'nand erase.part kernel\'
send setenv erase_config \'nand erase.part config\'
send setenv erase_oem \'nand erase.part oem\'
send setenv erase_rootfs \'nand erase.part rootfs\'
+send setenv erase_user_data \'nand erase.part user\'
send setenv tftp_bootstrap \'tftpb ${tftpaddr} ${bootstrap_file} && run erase_bootstrap && nand write.jffs2 ${fileaddr} bootstrap ${filesize}\'
send setenv tftp_uboot \'tftpb ${tftpaddr} ${uboot_file} && run erase_uboot && nand write.jffs2 ${fileaddr} u-boot ${filesize}\'
send setenv tftp_uboot_env1 \'tftpb ${tftpaddr} ${uboot_env1_file} && run erase_uboot_env1 && nand write.jffs2 ${fileaddr} u-boot-env1 ${filesize}\'
@@ -51,7 +52,7 @@ send setenv tftp_uboot_env2 \'tftpb ${tftpaddr} ${uboot_env2_file} && run
send setenv tftp_kernel \'tftpb ${tftpaddr} ${kernel_file} && run erase_kernel && nand write.jffs2 ${fileaddr} kernel ${filesize}\'
send setenv tftp_config \'tftpb ${tftpaddr} ${config_file} && run erase_config && nand write.jffs2 ${fileaddr} config ${filesize}\'
send setenv tftp_oem \'tftpb ${tftpaddr} ${oem_file} && run erase_oem && nand write.jffs2 ${fileaddr} oem ${filesize}\'
-send setenv tftp_rootfs \'tftpb ${tftpaddr} ${rootfs_file} && run erase_rootfs && nand write.jffs2 ${fileaddr} rootfs ${filesize}\'
+send setenv tftp_rootfs \'tftpb ${tftpaddr} ${rootfs_file} && run erase_rootfs && run erase_user_data && nand write.jffs2 ${fileaddr} rootfs ${filesize}\'
send setenv krb \'run tftp_kernel && run tftp_rootfs && boot\'
send setenv rb \'run tftp_rootfs && boot\'
print saving...
diff --git a/contrib/uboot-setenv-mtcdt.ttl b/contrib/uboot-setenv-mtcdt.ttl
index d67f635..2b5dc54 100644
--- a/contrib/uboot-setenv-mtcdt.ttl
+++ b/contrib/uboot-setenv-mtcdt.ttl
@@ -14,6 +14,7 @@ EKERN = 'nand erase.part kernel'
ECONF = 'nand erase.part config'
EOEM = 'nand erase.part oem'
EROOT = 'nand erase.part rootfs'
+EUSER = 'nand erase.part user'
TBOOT = 'tftpb ${tftpaddr} ${bootstrap_file} && run erase_bootstrap && nand write.jffs2 ${fileaddr} bootstrap ${filesize}'
TUBOOT = 'tftpb ${tftpaddr} ${uboot_file} && run erase_uboot && nand write.jffs2 ${fileaddr} u-boot ${filesize}'
TUBOOTE1 = 'tftpb ${tftpaddr} ${uboot_env1_file} && run erase_uboot_env1 && nand write.jffs2 ${fileaddr} u-boot-env1 ${filesize}'
@@ -21,7 +22,7 @@ TUBOOTE2 = 'tftpb ${tftpaddr} ${uboot_env2_file} && run erase_uboot_env2 && nand
TKERN = 'tftpb ${tftpaddr} ${kernel_file} && run erase_kernel && nand write.jffs2 ${fileaddr} kernel ${filesize}'
TCONF = 'tftpb ${tftpaddr} ${config_file} && run erase_config && nand write.jffs2 ${fileaddr} config ${filesize}'
TOEM = 'tftpb ${tftpaddr} ${oem_file} && run erase_oem && nand write.jffs2 ${fileaddr} oem ${filesize}'
-TROOT = 'tftpb ${tftpaddr} ${rootfs_file} && run erase_rootfs && nand write.jffs2 ${fileaddr} rootfs ${filesize}'
+TROOT = 'tftpb ${tftpaddr} ${rootfs_file} && run erase_rootfs && run erase_user_data && nand write.jffs2 ${fileaddr} rootfs ${filesize}'
KRB = 'run tftp_kernel && run tftp_rootfs && boot'
RB = 'run tftp_rootfs && boot'
@@ -51,7 +52,7 @@ sendln 'setenv ethact macb0'
wait P
sendln 'setenv mtdids nand0=nand0'
wait P
-sendln 'setenv mtdparts mtdparts=nand0:256k(bootstrap),512k(u-boot),640k(u-boot-env1),640k(u-boot-env2),6M(kernel),8M(config),8M(oem),-(rootfs)'
+sendln 'setenv mtdparts mtdparts=nand0:256k(bootstrap),512k(u-boot),640k(u-boot-env1),640k(u-boot-env2),6M(kernel),8M(config),8M(oem),128M(rootfs),-(user)'
wait P
sendln 'setenv bootstrap_file oe_bootstrap_pmecc_padded.bin'
wait P
@@ -117,6 +118,8 @@ sendln 'setenv erase_oem ' 39 EOEM 39
wait P
sendln 'setenv erase_rootfs ' 39 EROOT 39
wait P
+sendln 'setenv erase_user_data ' 39 EUSER 39
+wait P
sendln 'setenv tftp_bootstrap ' 39 TBOOT 39
wait P
sendln 'setenv tftp_uboot ' 39 TUBOOT 39
diff --git a/contrib/uboot-setenv-mtr.minicom b/contrib/uboot-setenv-mtr.minicom
index bc53396..340e4f0 100644
--- a/contrib/uboot-setenv-mtr.minicom
+++ b/contrib/uboot-setenv-mtr.minicom
@@ -12,7 +12,7 @@ send setenv stderr serial
send setenv ethact macb0
send setenv ethaddr 00:08:00:87:00:02
send setenv mtdids nand0=nand0
-send setenv mtdparts mtdparts=nand0:256k(bootstrap),512k(u-boot),640k(u-boot-env1),640k(u-boot-env2),6M(kernel),8M(config),8M(oem),-(rootfs)
+send setenv mtdparts mtdparts=nand0:256k(bootstrap),512k(u-boot),640k(u-boot-env1),640k(u-boot-env2),6M(kernel),8M(config),8M(oem),128M(rootfs),-(user)
send setenv bootstrap_file oe_bootstrap_pmecc_padded.bin
send setenv uboot_file oe_u-boot.bin
send setenv uboot_env1_file oe_uboot_env1.bin
@@ -44,6 +44,7 @@ send setenv erase_kernel \'nand erase.part kernel\'
send setenv erase_config \'nand erase.part config\'
send setenv erase_oem \'nand erase.part oem\'
send setenv erase_rootfs \'nand erase.part rootfs\'
+send setenv erase_user_data \'nand erase.part user\'
send setenv tftp_bootstrap \'tftpboot ${loadaddr} ${bootstrap_file} && run erase_bootstrap && nand write.jffs2 ${fileaddr} bootstrap ${filesize}\'
send setenv tftp_uboot \'tftpboot ${loadaddr} ${uboot_file} && run erase_uboot && nand write.jffs2 ${fileaddr} u-boot ${filesize}\'
send setenv tftp_uboot_env1 \'tftpboot ${loadaddr} ${uboot_env1_file} && run erase_uboot_env1 && nand write.jffs2 ${fileaddr} u-boot-env1 ${filesize}\'
@@ -51,7 +52,7 @@ send setenv tftp_uboot_env2 \'tftpboot ${loadaddr} ${uboot_env2_file} && r
send setenv tftp_kernel \'tftpboot ${loadaddr} ${kernel_file} && run erase_kernel && nand write.jffs2 ${fileaddr} kernel ${filesize}\'
send setenv tftp_config \'tftpboot ${loadaddr} ${config_file} && run erase_config && nand write.jffs2 ${fileaddr} config ${filesize}\'
send setenv tftp_oem \'tftpboot ${loadaddr} ${oem_file} && run erase_oem && nand write.jffs2 ${fileaddr} oem ${filesize}\'
-send setenv tftp_rootfs \'tftpboot ${loadaddr} ${rootfs_file} && run erase_rootfs && nand write.jffs2 ${fileaddr} rootfs ${filesize}\'
+send setenv tftp_rootfs \'tftpboot ${loadaddr} ${rootfs_file} && run erase_rootfs && run erase_user_data && nand write.jffs2 ${fileaddr} rootfs ${filesize}\'
send setenv krb \'run tftp_kernel && run tftp_rootfs && boot\'
send setenv rb \'run tftp_rootfs && boot\'
print saving...
diff --git a/contrib/uboot-setenv-mtrv1.minicom b/contrib/uboot-setenv-mtrv1.minicom
index bc53396..340e4f0 100644
--- a/contrib/uboot-setenv-mtrv1.minicom
+++ b/contrib/uboot-setenv-mtrv1.minicom
@@ -12,7 +12,7 @@ send setenv stderr serial
send setenv ethact macb0
send setenv ethaddr 00:08:00:87:00:02
send setenv mtdids nand0=nand0
-send setenv mtdparts mtdparts=nand0:256k(bootstrap),512k(u-boot),640k(u-boot-env1),640k(u-boot-env2),6M(kernel),8M(config),8M(oem),-(rootfs)
+send setenv mtdparts mtdparts=nand0:256k(bootstrap),512k(u-boot),640k(u-boot-env1),640k(u-boot-env2),6M(kernel),8M(config),8M(oem),128M(rootfs),-(user)
send setenv bootstrap_file oe_bootstrap_pmecc_padded.bin
send setenv uboot_file oe_u-boot.bin
send setenv uboot_env1_file oe_uboot_env1.bin
@@ -44,6 +44,7 @@ send setenv erase_kernel \'nand erase.part kernel\'
send setenv erase_config \'nand erase.part config\'
send setenv erase_oem \'nand erase.part oem\'
send setenv erase_rootfs \'nand erase.part rootfs\'
+send setenv erase_user_data \'nand erase.part user\'
send setenv tftp_bootstrap \'tftpboot ${loadaddr} ${bootstrap_file} && run erase_bootstrap && nand write.jffs2 ${fileaddr} bootstrap ${filesize}\'
send setenv tftp_uboot \'tftpboot ${loadaddr} ${uboot_file} && run erase_uboot && nand write.jffs2 ${fileaddr} u-boot ${filesize}\'
send setenv tftp_uboot_env1 \'tftpboot ${loadaddr} ${uboot_env1_file} && run erase_uboot_env1 && nand write.jffs2 ${fileaddr} u-boot-env1 ${filesize}\'
@@ -51,7 +52,7 @@ send setenv tftp_uboot_env2 \'tftpboot ${loadaddr} ${uboot_env2_file} && r
send setenv tftp_kernel \'tftpboot ${loadaddr} ${kernel_file} && run erase_kernel && nand write.jffs2 ${fileaddr} kernel ${filesize}\'
send setenv tftp_config \'tftpboot ${loadaddr} ${config_file} && run erase_config && nand write.jffs2 ${fileaddr} config ${filesize}\'
send setenv tftp_oem \'tftpboot ${loadaddr} ${oem_file} && run erase_oem && nand write.jffs2 ${fileaddr} oem ${filesize}\'
-send setenv tftp_rootfs \'tftpboot ${loadaddr} ${rootfs_file} && run erase_rootfs && nand write.jffs2 ${fileaddr} rootfs ${filesize}\'
+send setenv tftp_rootfs \'tftpboot ${loadaddr} ${rootfs_file} && run erase_rootfs && run erase_user_data && nand write.jffs2 ${fileaddr} rootfs ${filesize}\'
send setenv krb \'run tftp_kernel && run tftp_rootfs && boot\'
send setenv rb \'run tftp_rootfs && boot\'
print saving...
diff --git a/recipes-kernel/linux/linux-at91-4.9.87/mtcap/linux-4.9-mtcap-device-tree.patch b/recipes-kernel/linux/linux-at91-4.9.87/mtcap/linux-4.9-mtcap-device-tree.patch
index 2735184..9cc9091 100644
--- a/recipes-kernel/linux/linux-at91-4.9.87/mtcap/linux-4.9-mtcap-device-tree.patch
+++ b/recipes-kernel/linux/linux-at91-4.9.87/mtcap/linux-4.9-mtcap-device-tree.patch
@@ -258,7 +258,7 @@ diff -Naru linux-4.9.87.orig/arch/arm/boot/dts/Makefile linux-4.9.87/arch/arm/bo
diff -Naru linux-4.9.87.orig/arch/arm/boot/dts/mtcap.dts linux-4.9.87/arch/arm/boot/dts/mtcap.dts
--- linux-4.9.87.orig/arch/arm/boot/dts/mtcap.dts 1969-12-31 18:00:00.000000000 -0600
+++ linux-4.9.87/arch/arm/boot/dts/mtcap.dts 2019-01-31 18:11:18.651648726 -0600
-@@ -0,0 +1,266 @@
+@@ -0,0 +1,270 @@
+/*
+ * DTS file for Multi-Tech Systems MTCAP Hardware
+ *
@@ -471,7 +471,11 @@ diff -Naru linux-4.9.87.orig/arch/arm/boot/dts/mtcap.dts linux-4.9.87/arch/arm/b
+ };
+ rootfs@1800000 {
+ label = "Rootfs";
-+ reg = <0x1800000 0xe800000>;
++ reg = <0x1800000 0x8000000>;
++ };
++ user@9800000 {
++ label = "User data";
++ reg = <0x9800000 0x6800000>;
+ };
+ };
+
diff --git a/recipes-kernel/linux/linux-at91-4.9.87/mtcdt/linux-4.9-mtcdt-device-tree.patch b/recipes-kernel/linux/linux-at91-4.9.87/mtcdt/linux-4.9-mtcdt-device-tree.patch
index ddc5123..87696c6 100644
--- a/recipes-kernel/linux/linux-at91-4.9.87/mtcdt/linux-4.9-mtcdt-device-tree.patch
+++ b/recipes-kernel/linux/linux-at91-4.9.87/mtcdt/linux-4.9-mtcdt-device-tree.patch
@@ -3,7 +3,7 @@ Index: linux-at91-4.9/arch/arm/boot/dts/mtcdt.dts
diff -aNru linux-at91-4.9.orig/arch/arm/boot/dts/mtcdt.dts linux-at91-4.9/arch/arm/boot/dts/mtcdt.dts
--- linux-at91-4.9.orig/arch/arm/boot/dts/mtcdt.dts 1969-12-31 18:00:00.000000000 -0600
+++ linux-at91-4.9/arch/arm/boot/dts/mtcdt.dts 2019-04-24 17:01:26.112074133 -0500
-@@ -0,0 +1,287 @@
+@@ -0,0 +1,291 @@
+/*
+ * DTS file for Multi-Tech Systems MTCDT Hardware
+ */
@@ -209,8 +209,12 @@ diff -aNru linux-at91-4.9.orig/arch/arm/boot/dts/mtcdt.dts linux-at91-4.9/arch/a
+ };
+ rootfs@1800000 {
+ label = "Rootfs";
-+ reg = <0x1800000 0xe800000>;
-+ };
++ reg = <0x1800000 0x8000000>;
++ };
++ user@9800000 {
++ label = "User data";
++ reg = <0x9800000 0x6800000>;
++ };
+ };
+ };
+
diff --git a/recipes-kernel/linux/linux-at91-4.9.87/mtr/linux-4.9-mtr-device-tree.patch b/recipes-kernel/linux/linux-at91-4.9.87/mtr/linux-4.9-mtr-device-tree.patch
index a846bc5..659931d 100644
--- a/recipes-kernel/linux/linux-at91-4.9.87/mtr/linux-4.9-mtr-device-tree.patch
+++ b/recipes-kernel/linux/linux-at91-4.9.87/mtr/linux-4.9-mtr-device-tree.patch
@@ -1,7 +1,7 @@
diff -Naru linux-4.9.87.orig/arch/arm/boot/dts/mtr.dts linux-4.9.87/arch/arm/boot/dts/mtr.dts
--- linux-4.9.87.orig/arch/arm/boot/dts/mtr.dts 1969-12-31 18:00:00.000000000 -0600
+++ linux-4.9.87/arch/arm/boot/dts/mtr.dts 2019-01-03 15:17:51.799576663 -0600
-@@ -0,0 +1,283 @@
+@@ -0,0 +1,287 @@
+/*
+ * DTS file for Multi-Tech Systems mtr Hardware
+ *
@@ -215,7 +215,11 @@ diff -Naru linux-4.9.87.orig/arch/arm/boot/dts/mtr.dts linux-4.9.87/arch/arm/boo
+ };
+ rootfs@1800000 {
+ label = "Rootfs";
-+ reg = <0x1800000 0xe800000>;
++ reg = <0x1800000 0x8000000>;
++ };
++ user@9800000 {
++ label = "User data";
++ reg = <0x9800000 0x6800000>;
+ };
+ };
+
diff --git a/recipes-kernel/linux/linux-at91-4.9.87/mtrv1/linux-4.9-mtrv1-device-tree.patch b/recipes-kernel/linux/linux-at91-4.9.87/mtrv1/linux-4.9-mtrv1-device-tree.patch
index e8088c7..e1f67f1 100644
--- a/recipes-kernel/linux/linux-at91-4.9.87/mtrv1/linux-4.9-mtrv1-device-tree.patch
+++ b/recipes-kernel/linux/linux-at91-4.9.87/mtrv1/linux-4.9-mtrv1-device-tree.patch
@@ -1,7 +1,7 @@
diff -Naru linux-4.9.87.orig/arch/arm/boot/dts/mtrv1.dts linux-4.9.87/arch/arm/boot/dts/mtrv1.dts
--- linux-4.9.87.orig/arch/arm/boot/dts/mtrv1.dts 1969-12-31 18:00:00.000000000 -0600
+++ linux-4.9.87/arch/arm/boot/dts/mtrv1.dts 2019-05-07 19:03:19.378605555 -0500
-@@ -0,0 +1,274 @@
+@@ -0,0 +1,278 @@
+/*
+ * DTS file for Multi-Tech Systems MTRv1 Hardware
+ *
@@ -205,7 +205,11 @@ diff -Naru linux-4.9.87.orig/arch/arm/boot/dts/mtrv1.dts linux-4.9.87/arch/arm/b
+ };
+ rootfs@1800000 {
+ label = "Rootfs";
-+ reg = <0x1800000 0xe800000>;
++ reg = <0x1800000 0x8000000>;
++ };
++ user@9800000 {
++ label = "User data";
++ reg = <0x9800000 0x6800000>;
+ };
+ };
+