summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2023-02-02 13:55:05 -0600
committerJohn Klug <john.klug@multitech.com>2023-02-02 13:58:14 -0600
commit052bac8c0d3e3e46d24e83af61bb2fb92380bd27 (patch)
tree5ac1cb5b43e52df36aed7c8ee26c00ab6e9d5d7c
parent1b68688574a37a7a4f41fb5688ae9e9fe87b5fa6 (diff)
downloadmeta-multitech-atmel-052bac8c0d3e3e46d24e83af61bb2fb92380bd27.tar.gz
meta-multitech-atmel-052bac8c0d3e3e46d24e83af61bb2fb92380bd27.tar.bz2
meta-multitech-atmel-052bac8c0d3e3e46d24e83af61bb2fb92380bd27.zip
Fix up U-Boot password regression
-rw-r--r--recipes-bsp/u-boot/u-boot.inc2
-rw-r--r--recipes-bsp/u-boot/u-boot_2016.09.01.bb4
2 files changed, 4 insertions, 2 deletions
diff --git a/recipes-bsp/u-boot/u-boot.inc b/recipes-bsp/u-boot/u-boot.inc
index cba40c9..1368427 100644
--- a/recipes-bsp/u-boot/u-boot.inc
+++ b/recipes-bsp/u-boot/u-boot.inc
@@ -4,7 +4,7 @@ SECTION = "bootloaders"
PROVIDES = "virtual/bootloader"
# New U-Boot with suppressed version.
-PR="m5"
+PR="m6"
# Add a '-sd' suffix to the PR for SDMFG builds
PR .= "${@oe.utils.conditional("SDMFG", "", "", "-sd", d)}"
diff --git a/recipes-bsp/u-boot/u-boot_2016.09.01.bb b/recipes-bsp/u-boot/u-boot_2016.09.01.bb
index 5af4d92..b394a76 100644
--- a/recipes-bsp/u-boot/u-boot_2016.09.01.bb
+++ b/recipes-bsp/u-boot/u-boot_2016.09.01.bb
@@ -6,7 +6,8 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-2016.09.01:"
CONFIG_PATCH = "${@oe.utils.conditional('SDMFG', '', 'file://config-n.patch', 'file://config-sd.patch', d)}"
MTCDT_PATCH = "${@oe.utils.conditional('SDMFG', '', 'file://mtcdt-n.patch', 'file://mtcdt-sd.patch', d)}"
-# file://mtpwd.path
+PASSWD_PATCH = "${@oe.utils.conditional('SDMFG', '', 'file://mtpwd.patch', '', d)}"
+
SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \
file://kconfig_common.patch \
${CONFIG_PATCH} \
@@ -16,6 +17,7 @@ SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \
file://hide_uboot_version.patch \
file://fix_2_6.patch \
file://fix_net.patch \
+ ${PASSWD_PATCH} \
"
SRC_URI_append_mtcdt = " \