summaryrefslogtreecommitdiff
path: root/recipes-support/qfirehose/qfirehose_1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/qfirehose/qfirehose_1.2.bb')
-rw-r--r--recipes-support/qfirehose/qfirehose_1.2.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-support/qfirehose/qfirehose_1.2.bb b/recipes-support/qfirehose/qfirehose_1.2.bb
new file mode 100644
index 0000000..994b1bf
--- /dev/null
+++ b/recipes-support/qfirehose/qfirehose_1.2.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Quectel modem flashing tool"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
+
+PR = "r0"
+
+SRC_URI = "http://www.multitech.net/downloads/${PN}-${PACKAGE_ARCH}-${PV}-${PR}.tar.gz;name=${PACKAGE_ARCH}"
+SRC_URI[arm926ejste.md5sum] = ""
+SRC_URI[arm926ejste.sha256sum] = ""
+SRC_URI[armv7vet2hf-neon.md5sum] = "62b1d837fa64cb6c7efc1a42db763715"
+SRC_URI[armv7vet2hf-neon.sha256sum] = "e6762a83ea166a628dabd9765565fcd2a55fd7823014b339525b310c00d98cb6"
+
+do_install() {
+ install -d ${D}${sbindir}
+ echo "do_install: directory is $(pwd)"
+ install -m 0755 ${WORKDIR}/${PN}-${PACKAGE_ARCH}-${PV}-${PR}/${sbindir}/* ${D}${sbindir}
+}
+
+FILES_${PN} = "${sbindir}"