summaryrefslogtreecommitdiff
path: root/recipes-support/multitech/jsparser_0.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/multitech/jsparser_0.4.bb')
-rw-r--r--recipes-support/multitech/jsparser_0.4.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-support/multitech/jsparser_0.4.bb b/recipes-support/multitech/jsparser_0.4.bb
new file mode 100644
index 0000000..cd419c6
--- /dev/null
+++ b/recipes-support/multitech/jsparser_0.4.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "MultiTech Command Line JSON Parser"
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=94d55d512a9ba36caa9b7df079bae19f"
+DEPENDS = "jsoncpp libmts"
+RDEPENDS_${PN} += "bash jsoncpp"
+
+PR = "r0"
+SRCREV="${PV}"
+
+SRC_URI = "git://git.multitech.net/jsparser;branch=master \
+ file://jspp \
+"
+
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ oe_runmake install DESTDIR=${D}
+ install -d ${D}/usr/bin
+ install -m 755 ${WORKDIR}/jspp ${D}/usr/bin/jspp
+}
+
+