summaryrefslogtreecommitdiff
path: root/recipes-support/multitech/jsparser/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/multitech/jsparser/Makefile')
-rw-r--r--recipes-support/multitech/jsparser/Makefile69
1 files changed, 0 insertions, 69 deletions
diff --git a/recipes-support/multitech/jsparser/Makefile b/recipes-support/multitech/jsparser/Makefile
deleted file mode 100644
index 8fe64f6..0000000
--- a/recipes-support/multitech/jsparser/Makefile
+++ /dev/null
@@ -1,69 +0,0 @@
-
-includedir ?= /usr/include
-libdir ?= /usr/lib
-
-LIBS := -lmts -ljsoncpp -lrt
-
-OBJS += \
-Version.o \
-main.o
-
-CPP_DEPS += \
-Version.d \
-main.d
-
-all: postbuild
-
-prebuild:
- @echo PRE-BUILD
- @echo 'Removing previous version components started'
- -$(RM) Version.o
- -$(RM) Version.d
- -$(RM) Version.cpp
- @echo 'Removing previous version components complete'
- @echo ' '
-
-postbuild: mainbuild
- @echo POST-BUILD
- @echo ' '
-
-mainbuild: prebuild
- @echo MAIN-BUILD
- @$(MAKE) --no-print-directory target
-
-target: $(OBJS)
- @echo 'Building target: $@'
- $(CXX) $(CFLAGS) $(LDFLAGS) -o jsparser $(OBJS) $(LIBS)
- @echo 'Finished building target: $@'
- @echo ' '
-
-Version.o: Version.cpp
- @echo 'Building file: $<'
- $(CXX) $(CFLAGS) -Iinclude -Wall -c -std=c++0x -fmessage-length=0 -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o "$@" "$<"
- @echo 'Finished building: $<'
- @echo ' '
-
-Version.cpp:
- @echo 'Creating file: Version.cpp'
- /bin/echo -e "//Pre-Build Auto-Generated Source\n#include \"Version.h\"\n\nconst std::string Version::version(\"$(shell git describe)\");" > Version.cpp
- @echo 'Finished creating: Version.cpp'
- @echo ' '
-
-main.o: main.cpp
- @echo 'Building file: $<'
- $(CXX) $(CFLAGS) -I=$(includedir)/jsoncpp -Wall -c -std=c++0x -fmessage-length=0 -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o "$@" "$<"
- @echo 'Finished building: $<'
- @echo ' '
-
-install:
- install -d $(DESTDIR)/usr/bin
- install -m 0755 jsparser $(DESTDIR)/usr/bin
-
-clean:
- -$(RM) $(OBJS) $(CPP_DEPS) jsparser
- -@echo ' '
-
-.PHONY: all clean dependents install target
-.SECONDARY:
-
-