summaryrefslogtreecommitdiff
path: root/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/node-red/node-red_0.15.3.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/recipes-devtools/node-red/node-red_0.15.3.bb b/recipes-devtools/node-red/node-red_0.15.3.bb
index 940b5bd..bacf9fd 100644
--- a/recipes-devtools/node-red/node-red_0.15.3.bb
+++ b/recipes-devtools/node-red/node-red_0.15.3.bb
@@ -44,5 +44,16 @@ do_install() {
install -d ${D}/opt/node-red
cp -r ./node_modules/node-red/* ${D}/opt/node-red/
}
+pkg_preinst_${PN}() {
+ if grep 'Application Execution Platform with mLinux' /etc/issue ; then
+ ((aep=1))
+ fi
+ ls /etc/init.d >/tmp/init.txt
+
+ if ((aep == 1)) ; then
+ logger -t opkg -s -p user.error 'Application Execution Platform detected in /etc/issue -- this node-red package is for mLinux not AEP'
+ exit 1
+ fi
+}
FILES_${PN} += "/opt/node-red"