summaryrefslogtreecommitdiff
path: root/recipes-devtools
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-11-28 16:41:12 -0600
committerJohn Klug <john.klug@multitech.com>2017-12-06 11:27:06 -0600
commitf580058ee7f877c3d9d56a33d540247b62f14394 (patch)
tree033faba0608fdae470e6cc9d510ea965eee6c147 /recipes-devtools
parent07ba917a4433d44a559ed8db0bd7ee4fb85a2ad0 (diff)
downloadmeta-mlinux-f580058ee7f877c3d9d56a33d540247b62f14394.tar.gz
meta-mlinux-f580058ee7f877c3d9d56a33d540247b62f14394.tar.bz2
meta-mlinux-f580058ee7f877c3d9d56a33d540247b62f14394.zip
Bail out on install if AEP in /etc/issue
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/node-red/node-red_0.15.3.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/recipes-devtools/node-red/node-red_0.15.3.bb b/recipes-devtools/node-red/node-red_0.15.3.bb
index 940b5bd..bacf9fd 100644
--- a/recipes-devtools/node-red/node-red_0.15.3.bb
+++ b/recipes-devtools/node-red/node-red_0.15.3.bb
@@ -44,5 +44,16 @@ do_install() {
install -d ${D}/opt/node-red
cp -r ./node_modules/node-red/* ${D}/opt/node-red/
}
+pkg_preinst_${PN}() {
+ if grep 'Application Execution Platform with mLinux' /etc/issue ; then
+ ((aep=1))
+ fi
+ ls /etc/init.d >/tmp/init.txt
+
+ if ((aep == 1)) ; then
+ logger -t opkg -s -p user.error 'Application Execution Platform detected in /etc/issue -- this node-red package is for mLinux not AEP'
+ exit 1
+ fi
+}
FILES_${PN} += "/opt/node-red"