summaryrefslogtreecommitdiff
path: root/recipes-devtools/nodejs/nodejs_0.8.28.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/nodejs/nodejs_0.8.28.bb')
-rw-r--r--recipes-devtools/nodejs/nodejs_0.8.28.bb58
1 files changed, 0 insertions, 58 deletions
diff --git a/recipes-devtools/nodejs/nodejs_0.8.28.bb b/recipes-devtools/nodejs/nodejs_0.8.28.bb
deleted file mode 100644
index 6c9de2f..0000000
--- a/recipes-devtools/nodejs/nodejs_0.8.28.bb
+++ /dev/null
@@ -1,58 +0,0 @@
-DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript"
-HOMEPAGE = "http://nodejs.org"
-LICENSE = "MIT & BSD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=95a589a3257ab7dfe37d8a8379e3c72d"
-
-DEPENDS = "openssl"
-PROVIDES = "virtual/node"
-RPROVIDES_${PN} = "node"
-
-# use newer npm version that supports caret (^) versions
-# https://github.com/npm/npm/issues/4849
-SRCREV_npm = "v1.4.23"
-
-SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz \
- file://0001-gcc-has-a-builtin-define-to-denote-hard-abi-when-in-.patch \
- git://github.com/npm/npm.git;destsuffix=npm;name=npm \
-"
-SRC_URI[md5sum] = "2516e11b2cb231b122c0bf37a78ed4b0"
-SRC_URI[sha256sum] = "50e9a4282a741c923bd41c3ebb76698edbd7b1324024fe70cedc1e34b782d44f"
-
-S = "${WORKDIR}/node-v${PV}"
-
-# v8 errors out if you have set CCACHE
-CCACHE = ""
-
-ARCHFLAGS_arm = "${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '--with-arm-float-abi=hard', '--with-arm-float-abi=softfp', d)}"
-ARCHFLAGS ?= ""
-
-# Node is way too cool to use proper autotools, so we install two wrappers to forcefully inject proper arch cflags to workaround gypi
-do_configure () {
- export LD="${CXX}"
-
- ./configure --prefix=${prefix} --without-snapshot ${ARCHFLAGS}
-}
-
-do_compile () {
- export LD="${CXX}"
- make BUILDTYPE=Release
-}
-
-do_install () {
- # backup original bundled npm
- if [ ! -d deps/npm.orig ]; then
- mv deps/npm deps/npm.orig
- else
- rm -rf deps/npm
- fi
- # install updated npm from git repo
- cp -r ${WORKDIR}/npm deps/npm
-
- oe_runmake install DESTDIR=${D}
-}
-
-RDEPENDS_${PN} = "curl python-shell python-datetime python-subprocess python-crypt python-textutils python-netclient "
-RDEPENDS_${PN}_class-native = ""
-
-FILES_${PN} += "${libdir}/node/wafadmin ${libdir}/node_modules ${libdir}/dtrace"
-BBCLASSEXTEND = "native"