summaryrefslogtreecommitdiff
path: root/recipes-core/useradd
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/useradd')
-rw-r--r--recipes-core/useradd/useradd.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/recipes-core/useradd/useradd.bb b/recipes-core/useradd/useradd.bb
index 0afa3b1..458facf 100644
--- a/recipes-core/useradd/useradd.bb
+++ b/recipes-core/useradd/useradd.bb
@@ -45,3 +45,13 @@ FILES_${PN} = "/home/mtadm/.ssh"
# debugsources.list: No such file or directory:
INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
+pkg_postinst_${PN} () {
+ profile=/home/mtadm/.profile
+ if ! grep 'sbin' ${profile} ; then
+ Sub='${PA'
+ Sub=${Sub}'TH}:/sbin:/usr/sbin'
+ echo 'PATH='${Sub} >>/home/mtadm/.profile
+ echo 'export PATH' >>/home/mtadm/.profile
+ fi
+}
+