summaryrefslogtreecommitdiff
path: root/recipes-core/mlinux/mlinux-feed-extras-task.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/mlinux/mlinux-feed-extras-task.bb')
-rw-r--r--recipes-core/mlinux/mlinux-feed-extras-task.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-core/mlinux/mlinux-feed-extras-task.bb b/recipes-core/mlinux/mlinux-feed-extras-task.bb
new file mode 100644
index 0000000..03455c6
--- /dev/null
+++ b/recipes-core/mlinux/mlinux-feed-extras-task.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Extra packages to build for mLinux feed"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
+
+PR = "r0"
+
+inherit packagegroup
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+FS_PACKAGES="sshfs-fuse fuse-exfat exfat-utils"
+NET_PACKAGES="netcat ipsec-tools openvpn iftop dnsmasq strongswan stunnel tunctl"
+UTIL_PACKAGES="logrotate fatrace stressapptest gawk rsyslog zip gnupg"
+DEV_PACKAGES="node-red mono gdb git vim"
+
+DEPENDS_${PN} = "\
+ linux-firmware \
+ ${FS_PACKAGES} \
+ ${NET_PACKAGES} \
+ ${UTIL_PACKAGES} \
+ ${DEV_PACKAGES} \
+ "
+