summaryrefslogtreecommitdiff
path: root/recipes-connectivity/strongswan/strongswan_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/strongswan/strongswan_%.bbappend')
-rw-r--r--recipes-connectivity/strongswan/strongswan_%.bbappend18
1 files changed, 17 insertions, 1 deletions
diff --git a/recipes-connectivity/strongswan/strongswan_%.bbappend b/recipes-connectivity/strongswan/strongswan_%.bbappend
index c68b45e..3286caa 100644
--- a/recipes-connectivity/strongswan/strongswan_%.bbappend
+++ b/recipes-connectivity/strongswan/strongswan_%.bbappend
@@ -1,3 +1,19 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:${THISDIR}/files:"
+
+PR.=".mts2"
PACKAGECONFIG_remove = "sqlite3"
+
+PACKAGECONFIG_append = "stroke"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/ ${D}${sysconfdir}/ipsec.d/
+ ln -sf /var/run/ipsec/ipsec.conf ${D}${sysconfdir}/ipsec.conf
+ ln -sf /var/run/ipsec/ipsec.secrets ${D}${sysconfdir}/ipsec.secrets
+ rm -rf ${D}${sysconfdir}/ipsec.d/cacerts
+ ln -sf /var/run/ipsec/cacerts ${D}${sysconfdir}/ipsec.d/cacerts
+ rm -rf ${D}${sysconfdir}/ipsec.d/certs
+ ln -sf /var/run/ipsec/certs ${D}${sysconfdir}/ipsec.d/certs
+ rm -rf ${D}${sysconfdir}/ipsec.d/private
+ ln -sf /var/run/ipsec/private ${D}${sysconfdir}/ipsec.d/private
+}