summaryrefslogtreecommitdiff
path: root/recipes-connectivity/lora/lora-network-server_2.5.35.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/lora/lora-network-server_2.5.35.bb')
-rw-r--r--recipes-connectivity/lora/lora-network-server_2.5.35.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/recipes-connectivity/lora/lora-network-server_2.5.35.bb b/recipes-connectivity/lora/lora-network-server_2.5.35.bb
new file mode 100644
index 0000000..7b1bca8
--- /dev/null
+++ b/recipes-connectivity/lora/lora-network-server_2.5.35.bb
@@ -0,0 +1,48 @@
+DESCRIPTION = "MultiTech LoRa Network Server"
+PRIORITY = "optional"
+SECTION = "console/utils"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2b9a30a3082ddccd2c695a4dbeeab80d"
+DEPENDS = "jsoncpp libmts mosquitto sqlite3 curl gnutls"
+RDEPENDS_${PN} += "lora-packet-forwarder logrotate bash lora-logging jsoncpp"
+PR = "r0"
+CONFFILES_${PN} += "${sysconfdir}/default/lora-network-server ${sysconfdir}/init.d/lora-network-server"
+
+SRC_URI = "http://multitech.net/downloads/lora-network-server_${PV}.tar.gz \
+ file://lora-network-server.init \
+ file://lora-network-server.default \
+ "
+
+SRC_URI[md5sum] = "94044e85f244776fc3e79afece3f8205"
+SRC_URI[sha256sum] = "d905d80f8375c81389a939ec78770c27cc979554bc2618f1ad162c94b3d8d3ce"
+
+# binaries are already stripped, so suppress warning
+INSANE_SKIP_${PN} = "already-stripped"
+
+S = "${WORKDIR}"
+
+LORA_DIR = "/opt/lora"
+
+do_compile() {
+}
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "lora-network-server"
+INITSCRIPT_PARAMS = "defaults 80 30"
+
+do_install() {
+ install -d ${D}${LORA_DIR}
+ install -m 0755 lora-network-server-arm926ejste-mlinux-6 ${D}${LORA_DIR}/lora-network-server
+ install -m 0755 lora-v21-keygen-arm926ejste-mlinux-6 ${D}${LORA_DIR}/lora-v21-keygen
+ install -m 0644 config/lora-network-server.conf.sample ${D}${LORA_DIR}/lora-network-server.conf.sample
+ install -m 0644 config/lora-network-server.conf.full ${D}${LORA_DIR}/lora-network-server.conf.full
+
+ install -d ${D}${sysconfdir}/default
+ install -m 0644 ${WORKDIR}/lora-network-server.default ${D}${sysconfdir}/default/lora-network-server
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/lora-network-server.init ${D}${sysconfdir}/init.d/lora-network-server
+}
+
+FILES_${PN} += "${LORA_DIR}"
+FILES_${PN}-dbg += "${LORA_DIR}/.debug"