summaryrefslogtreecommitdiff
path: root/recipes-connectivity/lora/lora-gateway-sx1303_2.0.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/lora/lora-gateway-sx1303_2.0.6.bb')
-rw-r--r--recipes-connectivity/lora/lora-gateway-sx1303_2.0.6.bb78
1 files changed, 78 insertions, 0 deletions
diff --git a/recipes-connectivity/lora/lora-gateway-sx1303_2.0.6.bb b/recipes-connectivity/lora/lora-gateway-sx1303_2.0.6.bb
new file mode 100644
index 0000000..fb2d708
--- /dev/null
+++ b/recipes-connectivity/lora/lora-gateway-sx1303_2.0.6.bb
@@ -0,0 +1,78 @@
+DESCRIPTION = "LoRa Packet Forwarder"
+HOMEPAGE = "https://github.com/Lora-net/sx1302_hal"
+PRIORITY = "optional"
+SECTION = "console/utils"
+# Semtech license is a modified BSD-style license
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=d2119120bd616e725f4580070bd9ee19"
+DEPENDS = "logrotate"
+RDEPENDS_${PN} += "bash"
+PR = "r0"
+
+# SRCREV = "100104ee350a0e469b348ac383486d311caaf5e5"
+SRCREV = "V${PV}"
+
+SRC_URI = "git://github.com/MultiTechSystems/sx1302_hal.git;protocol=git;branch=master \
+ file://global_conf.json.MTAC_003_0_0.EU868 \
+ file://global_conf.json.MTAC_003_0_0.US915 \
+ file://global_conf.json.MTCAP3.EU868 \
+ file://global_conf.json.MTCAP3.US915 \
+"
+
+
+S = "${WORKDIR}/git"
+B = "${S}"
+
+LORA_DIR = "/opt/lora"
+
+
+CFLAGS += " -I${S}/packet_forwarder/inc -I${S}/libloragw/inc -I${S}/libtools/inc -I${S}/inc -I. -std=gnu11"
+
+do_compile() {
+ oe_runmake packet_forwarder LDFLAGS=${LDFLAGS}
+ oe_runmake util_boot LDFLAGS=${LDFLAGS}
+ oe_runmake util_chip_id FLAGS=${LDFLAGS}
+ oe_runmake util_net_downlink LDFLAGS=${LDFLAGS}
+ # oe_runmake util_spectral_scan LDFLAGS=${LDFLAGS}
+}
+
+do_install() {
+ install -d ${D}${LORA_DIR}
+ install -d ${D}${LORA_DIR}/forwarder-utils-sx1303
+ install -d ${D}${LORA_DIR}/gateway-utils-sx1303
+ install -m 755 packet_forwarder/lora_pkt_fwd ${D}${LORA_DIR}/lora_pkt_fwd_sx1303
+ install -m 755 libloragw/test_loragw* ${D}${LORA_DIR}/gateway-utils-sx1303/
+ install -m 755 util_boot/boot ${D}${LORA_DIR}/forwarder-utils-sx1303/util_boot
+ install -m 755 util_chip_id/chip_id ${D}${LORA_DIR}/forwarder-utils-sx1303/util_chip_id
+ install -m 755 util_net_downlink/net_downlink ${D}${LORA_DIR}/forwarder-utils-sx1303/util_net_downlink
+ # install -m 755 util_spectral_scan/util_spectral_scan ${D}${LORA_DIR}/forwarder-utils-sx1303/
+}
+
+do_install_append_mtcdt() {
+ install -m 644 ${WORKDIR}/global_conf.json.MTAC_003_0_0.EU868 ${D}${LORA_DIR}/global_conf.json.MTAC_003_0_0.EU868
+ install -m 644 ${WORKDIR}/global_conf.json.MTAC_003_0_0.US915 ${D}${LORA_DIR}/global_conf.json.MTAC_003_0_0.US915
+}
+
+do_install_append_mtcap() {
+ install -m 644 ${WORKDIR}/global_conf.json.MTCAP3.EU868 ${D}${LORA_DIR}/global_conf.json.MTCAP3.EU868
+ install -m 644 ${WORKDIR}/global_conf.json.MTCAP3.US915 ${D}${LORA_DIR}/global_conf.json.MTCAP3.US915
+}
+
+do_install_append_mtcdt3() {
+ install -m 644 ${WORKDIR}/global_conf.json.MTAC_003_0_0.EU868 ${D}${LORA_DIR}/global_conf.json.MTAC_003_0_0.EU868
+ install -m 644 ${WORKDIR}/global_conf.json.MTAC_003_0_0.US915 ${D}${LORA_DIR}/global_conf.json.MTAC_003_0_0.US915
+}
+
+do_install_append_mtcdt3hs() {
+ install -m 644 ${WORKDIR}/global_conf.json.MTAC_003_0_0.EU868 ${D}${LORA_DIR}/global_conf.json.MTAC_003_0_0.EU868
+ install -m 644 ${WORKDIR}/global_conf.json.MTAC_003_0_0.US915 ${D}${LORA_DIR}/global_conf.json.MTAC_003_0_0.US915
+}
+
+
+FILES_${PN} += "${LORA_DIR}"
+
+# disable this on purpose for dev purposes
+do_rm_work() {
+ echo "skipping"
+
+}