summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--conf/distro/mlinux.conf4
-rw-r--r--recipes-connectivity/lora/lora-logging.bb2
-rw-r--r--recipes-connectivity/lora/lora-logging/lora-logging.logrotate.conf3
-rwxr-xr-xrecipes-connectivity/lora/lora-network-server/lora-network-server.init2
-rwxr-xr-xrecipes-connectivity/lora/lora-packet-forwarder/lora-packet-forwarder.init2
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder_4.0.1.bb2
-rw-r--r--recipes-core/images/mlinux-factory-image.bb2
-rw-r--r--recipes-core/images/mlinux-rs9113-base-image.bb2
8 files changed, 11 insertions, 8 deletions
diff --git a/conf/distro/mlinux.conf b/conf/distro/mlinux.conf
index 38288aa..33238b9 100644
--- a/conf/distro/mlinux.conf
+++ b/conf/distro/mlinux.conf
@@ -1,7 +1,7 @@
DISTRO = "mlinux"
DISTRO_NAME = "mLinux"
-DISTRO_BASE_VERSION = "4.0"
-DISTRO_VERSION = "${DISTRO_BASE_VERSION}.5"
+DISTRO_BASE_VERSION = "4.1"
+DISTRO_VERSION = "${DISTRO_BASE_VERSION}.0"
DISTRO_CODENAME = ""
SDK_VENDOR = "-mlinux"
SDK_VERSION := "${@'${DISTRO_VERSION}'.replace('snapshot-${DATE}','snapshot')}"
diff --git a/recipes-connectivity/lora/lora-logging.bb b/recipes-connectivity/lora/lora-logging.bb
index 67b4099..201c0cc 100644
--- a/recipes-connectivity/lora/lora-logging.bb
+++ b/recipes-connectivity/lora/lora-logging.bb
@@ -4,7 +4,7 @@ SECTION = "console/utils"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
DEPENDS = ""
-PR = "r1"
+PR = "r2"
RDEPENDS_${PN} += "logrotate bash"
SRC_URI = "file://lora-logging.logrotate.conf \
diff --git a/recipes-connectivity/lora/lora-logging/lora-logging.logrotate.conf b/recipes-connectivity/lora/lora-logging/lora-logging.logrotate.conf
index 01a1cc0..f425c00 100644
--- a/recipes-connectivity/lora/lora-logging/lora-logging.logrotate.conf
+++ b/recipes-connectivity/lora/lora-logging/lora-logging.logrotate.conf
@@ -4,4 +4,7 @@
compress
copytruncate
missingok
+ postrotate
+ killall -SIGHUP lora-network-server
+ endscript
}
diff --git a/recipes-connectivity/lora/lora-network-server/lora-network-server.init b/recipes-connectivity/lora/lora-network-server/lora-network-server.init
index 2009fd8..a55be0b 100755
--- a/recipes-connectivity/lora/lora-network-server/lora-network-server.init
+++ b/recipes-connectivity/lora/lora-network-server/lora-network-server.init
@@ -125,7 +125,7 @@ do_start() {
# start packet forwarder
/usr/sbin/start-stop-daemon --chdir $run_dir/1 --background --start --make-pidfile \
- --pidfile $pkt_fwd_pidfile --startas /bin/bash -- -c "exec $pkt_fwd &>$pkt_fwd_log"
+ --pidfile $pkt_fwd_pidfile --startas /bin/bash -- -c "exec $pkt_fwd "
renice -n -20 -p $(pgrep lora-network-se)
renice -n -20 -p $(pgrep $(basename $pkt_fwd))
diff --git a/recipes-connectivity/lora/lora-packet-forwarder/lora-packet-forwarder.init b/recipes-connectivity/lora/lora-packet-forwarder/lora-packet-forwarder.init
index 4780da6..99463f6 100755
--- a/recipes-connectivity/lora/lora-packet-forwarder/lora-packet-forwarder.init
+++ b/recipes-connectivity/lora/lora-packet-forwarder/lora-packet-forwarder.init
@@ -195,7 +195,7 @@ do_start() {
echo -n "Starting $NAME: "
/usr/sbin/start-stop-daemon --chdir $run_dir/1 --background --start --make-pidfile \
- --pidfile $pkt_fwd_pidfile --startas /bin/bash -- -c "exec $pkt_fwd $pkt_fwd_options &>$pkt_fwd_log"
+ --pidfile $pkt_fwd_pidfile --startas /bin/bash -- -c "exec $pkt_fwd $pkt_fwd_options"
renice -n -20 -p $(pgrep $(basename $pkt_fwd))
diff --git a/recipes-connectivity/lora/lora-packet-forwarder_4.0.1.bb b/recipes-connectivity/lora/lora-packet-forwarder_4.0.1.bb
index c7644a9..e3f59ef 100644
--- a/recipes-connectivity/lora/lora-packet-forwarder_4.0.1.bb
+++ b/recipes-connectivity/lora/lora-packet-forwarder_4.0.1.bb
@@ -7,7 +7,7 @@ LICENSE = "Proprietary"
LIC_FILES_CHKSUM = "file://LICENSE;md5=22af7693d7b76ef0fc76161c4be76c45"
DEPENDS = "lora-gateway logrotate lora-logging"
RDEPENDS_${PN} += "bash"
-PR = "r13"
+PR = "r15"
SRCREV = "v${PV}"
diff --git a/recipes-core/images/mlinux-factory-image.bb b/recipes-core/images/mlinux-factory-image.bb
index 55fbc37..b9930d5 100644
--- a/recipes-core/images/mlinux-factory-image.bb
+++ b/recipes-core/images/mlinux-factory-image.bb
@@ -26,7 +26,7 @@ IMAGE_INSTALL += "autossh"
IMAGE_INSTALL += "monit"
# LoRa support (MTAC-LORA accessory card)
-IMAGE_INSTALL += "lora-gateway-utils lora-network-server lora-query lora-packet-forwarder-usb lora-gateway-geolocation-utils lora-packet-forwarder-geolocation"
+IMAGE_INSTALL += "lora-gateway-utils lora-network-server lora-query lora-packet-forwarder-usb lora-gateway-geolocation-utils lora-packet-forwarder-geolocation mtac-xdot-util"
# MQTT server
#IMAGE_INSTALL += "mosquitto"
diff --git a/recipes-core/images/mlinux-rs9113-base-image.bb b/recipes-core/images/mlinux-rs9113-base-image.bb
index 8aab186..7890e04 100644
--- a/recipes-core/images/mlinux-rs9113-base-image.bb
+++ b/recipes-core/images/mlinux-rs9113-base-image.bb
@@ -2,4 +2,4 @@ require mlinux-base-image.bb
DESCRIPTION = "mLinux base image with rs9113 drivers"
# Extra stuff to install
-IMAGE_INSTALL += " rs9113 "
+IMAGE_INSTALL += "kernel-module-rs9113 rs9113-noarch rs9113-util"