summaryrefslogtreecommitdiff
path: root/recipes-support
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2021-02-24 17:38:22 -0600
committerJohn Klug <john.klug@multitech.com>2021-02-24 17:38:22 -0600
commita316abe09424166f1fd2e1152bcb592fe9088b6f (patch)
treefe5b8cbbfaf2f0d0f92dd303b0278585533d31f4 /recipes-support
parentdd543ccfc392d9751974f400f8f4598a85c1bc9e (diff)
downloadmeta-mlinux-a316abe09424166f1fd2e1152bcb592fe9088b6f.tar.gz
meta-mlinux-a316abe09424166f1fd2e1152bcb592fe9088b6f.tar.bz2
meta-mlinux-a316abe09424166f1fd2e1152bcb592fe9088b6f.zip
Update uxfp for dunfell release
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/uxfp/uxfp-from-source/0001-Fixed-unrecognized-command-line-option.patch26
-rw-r--r--recipes-support/uxfp/uxfp-from-source/0002-uxfp-add-param-syslog.patch33
-rw-r--r--recipes-support/uxfp/uxfp-from-source_1.0.2.1.bb27
3 files changed, 86 insertions, 0 deletions
diff --git a/recipes-support/uxfp/uxfp-from-source/0001-Fixed-unrecognized-command-line-option.patch b/recipes-support/uxfp/uxfp-from-source/0001-Fixed-unrecognized-command-line-option.patch
new file mode 100644
index 0000000..86faf07
--- /dev/null
+++ b/recipes-support/uxfp/uxfp-from-source/0001-Fixed-unrecognized-command-line-option.patch
@@ -0,0 +1,26 @@
+From 5f8fef39aa5c3fd5894f7dbaa579d50f6e78c08a Mon Sep 17 00:00:00 2001
+From: "mykola.salomatin" <mykola.salomatin@globallogic.com>
+Date: Thu, 18 Feb 2021 21:57:25 +0200
+Subject: [PATCH] Fixed unrecognized command line option
+ '-Wno-deprecated-declaration'
+
+---
+ telit_os_abstraction_layer/linux/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/telit_os_abstraction_layer/linux/Makefile b/telit_os_abstraction_layer/linux/Makefile
+index 6c54e71..5d847c8 100644
+--- a/telit_os_abstraction_layer/linux/Makefile
++++ b/telit_os_abstraction_layer/linux/Makefile
+@@ -32,7 +32,7 @@ ifeq ($(LIBUDEV), enable)
+ endif
+
+
+-CFLAGS := -g -Wno-deprecated-declaration -Wall -Werror -fPIC $(INCLUDES) $(LIBUSB_CFLAG) $(LIBUDEV_CFLAG) -DVER_MAJOR=$(MAJOR) -DVER_MINOR=$(MINOR) -DVER_ALPHA=$(ALPHA) -DVER_CUSTOM=$(CUSTOM)
++CFLAGS := -g -Wno-deprecated-declarations -Wall -Werror -fPIC $(INCLUDES) $(LIBUSB_CFLAG) $(LIBUDEV_CFLAG) -DVER_MAJOR=$(MAJOR) -DVER_MINOR=$(MINOR) -DVER_ALPHA=$(ALPHA) -DVER_CUSTOM=$(CUSTOM)
+ LDFLAGS := $(LIBUDEV_LDFLAG) $(LIBUSB_LDFLAG)
+
+
+--
+2.7.4
+
diff --git a/recipes-support/uxfp/uxfp-from-source/0002-uxfp-add-param-syslog.patch b/recipes-support/uxfp/uxfp-from-source/0002-uxfp-add-param-syslog.patch
new file mode 100644
index 0000000..8dedc1b
--- /dev/null
+++ b/recipes-support/uxfp/uxfp-from-source/0002-uxfp-add-param-syslog.patch
@@ -0,0 +1,33 @@
+
+The patch allows to redirect all log messages from stdout to syslog.
+
+diff -ruN git/uxfp/main.c git/uxfp/main.c
+--- git/uxfp/main.c 2020-07-28 19:06:02.236397898 +0300
++++ git/uxfp/main.c 2020-07-28 17:55:38.000000000 +0300
+@@ -20,6 +20,7 @@
+ uint64_t speed;
+ bool debug;
+ bool recovery;
++ bool syslog;
+ } options = {0};
+
+ flag_t flags [] = {
+@@ -30,6 +31,7 @@
+ {"--class", "-c", VALUE_TYPE_ULONG, &options.class, OPT, "modem class"},
+ {"--debug", "-d", VALUE_TYPE_BOOLEAN, &options.debug, OPT, "enable debug logging"},
+ {"--lossrecovery", "-l", VALUE_TYPE_BOOLEAN, &options.recovery, OPT, "device in recovery mode"},
++ {"--syslog", "-n", VALUE_TYPE_BOOLEAN, &options.syslog, OPT, "all the logs redirected to syslog"},
+ {NULL, NULL, VALUE_TYPE_UNKNOWN, NULL, OPT, NULL},
+ };
+
+@@ -60,6 +62,10 @@
+ goto end;
+ }
+
++ if (options.syslog) {
++ core_log_set_native(true);
++ }
++
+ if (options.debug) {
+ core_log_set_level(LOG_LEVEL_DBG);
+ }
diff --git a/recipes-support/uxfp/uxfp-from-source_1.0.2.1.bb b/recipes-support/uxfp/uxfp-from-source_1.0.2.1.bb
new file mode 100644
index 0000000..ceb089d
--- /dev/null
+++ b/recipes-support/uxfp/uxfp-from-source_1.0.2.1.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Telit utility for upgrading CAT4 radio firmware"
+HOMEPAGE = "https://contact.telit.com/"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
+
+DEPENDS = "libusb1 udev"
+
+PR = "r2"
+SRCREV = "${PV}"
+
+SRC_URI = " \
+ git://git@${MTS_INTERNAL_GIT}/vendor-code/uxfp.git;protocol=ssh;branch=master \
+ file://0001-Fixed-unrecognized-command-line-option.patch \
+ file://0002-uxfp-add-param-syslog.patch \
+"
+
+S = "${WORKDIR}/git"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 uxfp/linux/uxfp ${D}${sbindir}
+}
+