summaryrefslogtreecommitdiff
path: root/recipes-support
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2021-07-28 16:52:28 -0500
committerJohn Klug <john.klug@multitech.com>2021-07-28 16:52:28 -0500
commit3c7d77ddb19e2da99d4dc6cde5ce6eadf49cb38d (patch)
treeefb54bf0bba11342ac3b86513a1131a86fd46d28 /recipes-support
parent71e48116fad0637b7694f4dadbb04b05a30cffbf (diff)
downloadmeta-mlinux-3c7d77ddb19e2da99d4dc6cde5ce6eadf49cb38d.tar.gz
meta-mlinux-3c7d77ddb19e2da99d4dc6cde5ce6eadf49cb38d.tar.bz2
meta-mlinux-3c7d77ddb19e2da99d4dc6cde5ce6eadf49cb38d.zip
uxfp 1.7.2
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/uxfp/uxfp-from-source/0002-uxfp-add-param-syslog.patch43
-rw-r--r--recipes-support/uxfp/uxfp-from-source_1.7.2-0.bb (renamed from recipes-support/uxfp/uxfp-from-source_1.0.2.1.bb)5
-rw-r--r--recipes-support/uxfp/uxfp_1.7.2-0.bb (renamed from recipes-support/uxfp/uxfp_1.0.2.1.bb)0
3 files changed, 24 insertions, 24 deletions
diff --git a/recipes-support/uxfp/uxfp-from-source/0002-uxfp-add-param-syslog.patch b/recipes-support/uxfp/uxfp-from-source/0002-uxfp-add-param-syslog.patch
index 8dedc1b..e562b59 100644
--- a/recipes-support/uxfp/uxfp-from-source/0002-uxfp-add-param-syslog.patch
+++ b/recipes-support/uxfp/uxfp-from-source/0002-uxfp-add-param-syslog.patch
@@ -2,32 +2,33 @@
The patch allows to redirect all log messages from stdout to syslog.
diff -ruN git/uxfp/main.c git/uxfp/main.c
---- git/uxfp/main.c 2020-07-28 19:06:02.236397898 +0300
-+++ git/uxfp/main.c 2020-07-28 17:55:38.000000000 +0300
-@@ -20,6 +20,7 @@
- uint64_t speed;
- bool debug;
- bool recovery;
-+ bool syslog;
+--- git/uxfp/main.c
++++ git/uxfp/main.c
+@@ -47,6 +47,7 @@
+ bool json;
+ bool report;
+ bool no_fastboot_driver;
++ bool syslog;
} options = {0};
flag_t flags [] = {
-@@ -30,6 +31,7 @@
- {"--class", "-c", VALUE_TYPE_ULONG, &options.class, OPT, "modem class"},
- {"--debug", "-d", VALUE_TYPE_BOOLEAN, &options.debug, OPT, "enable debug logging"},
- {"--lossrecovery", "-l", VALUE_TYPE_BOOLEAN, &options.recovery, OPT, "device in recovery mode"},
-+ {"--syslog", "-n", VALUE_TYPE_BOOLEAN, &options.syslog, OPT, "all the logs redirected to syslog"},
- {NULL, NULL, VALUE_TYPE_UNKNOWN, NULL, OPT, NULL},
+@@ -62,6 +63,7 @@
+ {"--show-diag-ports", "-w", VALUE_TYPE_BOOLEAN, &options.show_connected_diag_ports, OPT, "only show connected diagnostic ports and exit"},
+ {"--json", "-j", VALUE_TYPE_BOOLEAN, &options.json, OPT, "log in JSON format (automatically enable --report)"},
+ {"--report", NULL, VALUE_TYPE_BOOLEAN, &options.report, OPT, "final JSON report (do not enable --json automatically)"},
++ {"--syslog", "-n", VALUE_TYPE_BOOLEAN, &options.syslog, OPT, "all the logs redirected to syslog"},
+ {NULL, NULL, VALUE_TYPE_UNKNOWN, NULL, OPT, NULL},
};
-@@ -60,6 +62,10 @@
- goto end;
- }
-
-+ if (options.syslog) {
-+ core_log_set_native(true);
+@@ -139,6 +141,10 @@
+ if (options.json) {
+ options.report = true;
+ core_log_set_pprint(CORE_LOG_PPRINT_JSON);
+ }
+
- if (options.debug) {
- core_log_set_level(LOG_LEVEL_DBG);
++ if (options.syslog) {
++ core_log_set_native(true);
}
+
+ print_version_string();
+
diff --git a/recipes-support/uxfp/uxfp-from-source_1.0.2.1.bb b/recipes-support/uxfp/uxfp-from-source_1.7.2-0.bb
index ceb089d..64b9b01 100644
--- a/recipes-support/uxfp/uxfp-from-source_1.0.2.1.bb
+++ b/recipes-support/uxfp/uxfp-from-source_1.7.2-0.bb
@@ -5,12 +5,11 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2
DEPENDS = "libusb1 udev"
-PR = "r2"
+PR = "r1"
SRCREV = "${PV}"
SRC_URI = " \
- git://git@${MTS_INTERNAL_GIT}/vendor-code/uxfp.git;protocol=ssh;branch=master \
- file://0001-Fixed-unrecognized-command-line-option.patch \
+ git://git@gitlab.multitech.net/vendor-code/uxfp.git;protocol=ssh;branch=master \
file://0002-uxfp-add-param-syslog.patch \
"
diff --git a/recipes-support/uxfp/uxfp_1.0.2.1.bb b/recipes-support/uxfp/uxfp_1.7.2-0.bb
index 9096448..9096448 100644
--- a/recipes-support/uxfp/uxfp_1.0.2.1.bb
+++ b/recipes-support/uxfp/uxfp_1.7.2-0.bb