summaryrefslogtreecommitdiff
path: root/recipes-support/qfirehose/qfirehose-from-source_1.2.bb
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2021-07-29 10:43:15 -0500
committerJohn Klug <john.klug@multitech.com>2021-07-29 10:43:15 -0500
commit2b06023c2c6fbc5ceea9b022ca735cbcf4a752e8 (patch)
tree9fca751d6caae3d6116b4ee07009708072d60761 /recipes-support/qfirehose/qfirehose-from-source_1.2.bb
parent3c7d77ddb19e2da99d4dc6cde5ce6eadf49cb38d (diff)
downloadmeta-mlinux-2b06023c2c6fbc5ceea9b022ca735cbcf4a752e8.tar.gz
meta-mlinux-2b06023c2c6fbc5ceea9b022ca735cbcf4a752e8.tar.bz2
meta-mlinux-2b06023c2c6fbc5ceea9b022ca735cbcf4a752e8.zip
Add qfirehose for Quectel firmware upgrade
Diffstat (limited to 'recipes-support/qfirehose/qfirehose-from-source_1.2.bb')
-rw-r--r--recipes-support/qfirehose/qfirehose-from-source_1.2.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-support/qfirehose/qfirehose-from-source_1.2.bb b/recipes-support/qfirehose/qfirehose-from-source_1.2.bb
new file mode 100644
index 0000000..86ce0e6
--- /dev/null
+++ b/recipes-support/qfirehose/qfirehose-from-source_1.2.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Quectel utility for upgrading CAT4 radio firmware"
+HOMEPAGE = "https://www.quectel.com/"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
+
+PR = "r0"
+SRCREV = "${PV}"
+
+SRC_URI = " \
+ file://LTE%265G_QFirehose_Linux%26Android_V1.2.zip \
+"
+
+# TODO: When ZIP archieve is unpacked, the source directory is named "LTE&5G_QFirehose_Linux&Android_V1.2"
+# As bitbake does not support escaping for the "$S" variable and falls into parsing error -
+# a custom do_unpack_extra step was added.
+do_unpack_extra() {
+ mv "${WORKDIR}/LTE&5G_QFirehose_Linux&Android_V1.2/"* "${S}/"
+}
+
+addtask unpack_extra after do_unpack before do_patch
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 QFirehose ${D}${sbindir}
+}
+