summaryrefslogtreecommitdiff
path: root/recipes-support/multitech/libmts-io_1.0.30.bb
diff options
context:
space:
mode:
authorMykola Salomatin <mykola.salomatin@globallogic.com>2022-07-01 15:25:37 +0300
committerMykola Salomatin <mykola.salomatin@globallogic.com>2022-07-01 15:25:37 +0300
commita00b7d52b1af99e8ef36d2aaf65aa2154d38ffe7 (patch)
tree95c142efb6bc8e830a80df7c4ea076f87be6ae15 /recipes-support/multitech/libmts-io_1.0.30.bb
parent0f7426df0abb9c1b6f93d9d85deb6504caf3895e (diff)
downloadmeta-mlinux-a00b7d52b1af99e8ef36d2aaf65aa2154d38ffe7.tar.gz
meta-mlinux-a00b7d52b1af99e8ef36d2aaf65aa2154d38ffe7.tar.bz2
meta-mlinux-a00b7d52b1af99e8ef36d2aaf65aa2154d38ffe7.zip
[MTX-4503] mPower R.6.0.X: Remove Verizon FOTA feature from the code GP-1610
Update tags to the latest versions.
Diffstat (limited to 'recipes-support/multitech/libmts-io_1.0.30.bb')
-rw-r--r--recipes-support/multitech/libmts-io_1.0.30.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-support/multitech/libmts-io_1.0.30.bb b/recipes-support/multitech/libmts-io_1.0.30.bb
new file mode 100644
index 0000000..34115be
--- /dev/null
+++ b/recipes-support/multitech/libmts-io_1.0.30.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "MultiTech IO C++ Library"
+HOMEPAGE = "http://www.multitech.net/"
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c"
+
+DEPENDS = "libmts jsoncpp cmake-native cppunit"
+BBCLASSEXTEND = "native"
+
+PR = "r0"
+SRCREV = "${PV}"
+SRC_URI = "git://git.multitech.net/libmts-io;branch=master"
+
+S = "${WORKDIR}/git"
+
+do_compile() {
+ oe_runmake
+}
+
+# build and run tests for native recipe
+do_compile_append_virtclass-native() {
+ cd test
+ cmake .
+ oe_runmake
+ ./TestRunnerClient
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+