summaryrefslogtreecommitdiff
path: root/recipes-support/jsoncpp/jsoncpp16_1.6.0.bb
diff options
context:
space:
mode:
authorMykyta Dorokhin <mykyta.dorokhin@globallogic.com>2021-03-02 21:33:25 +0200
committerJohn Klug <john.klug@multitech.com>2021-03-03 11:06:18 -0600
commita32ad409315ebae13614a409eb4671ac4a2b1cc8 (patch)
tree05f95d8642fa5464e9c7676eb16c5aec0a530586 /recipes-support/jsoncpp/jsoncpp16_1.6.0.bb
parent355db9f7c3167713556ad34f198e5e7a96932c0d (diff)
downloadmeta-mlinux-a32ad409315ebae13614a409eb4671ac4a2b1cc8.tar.gz
meta-mlinux-a32ad409315ebae13614a409eb4671ac4a2b1cc8.tar.bz2
meta-mlinux-a32ad409315ebae13614a409eb4671ac4a2b1cc8.zip
jsoncpp: rename package to jsoncpp16 so to use jsoncpp version from yocto by default
Diffstat (limited to 'recipes-support/jsoncpp/jsoncpp16_1.6.0.bb')
-rw-r--r--recipes-support/jsoncpp/jsoncpp16_1.6.0.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-support/jsoncpp/jsoncpp16_1.6.0.bb b/recipes-support/jsoncpp/jsoncpp16_1.6.0.bb
new file mode 100644
index 0000000..8c8454d
--- /dev/null
+++ b/recipes-support/jsoncpp/jsoncpp16_1.6.0.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Json C++ Library"
+HOMEPAGE = "https://github.com/open-source-parsers/jsoncpp"
+# Public Domain
+LICENSE = "PD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c56ee55c03a55f8105b969d8270632ce"
+DEPENDS = ""
+
+#tag 1.6.0
+SRCREV="cbe7e7c9cbd39d864588c5cf2436690634562d3f"
+
+SRC_URI = " git://github.com/open-source-parsers/jsoncpp.git;protocol=git \
+ file://Makefile \
+ "
+
+PR = "r6"
+
+S = "${WORKDIR}/git"
+
+do_compile() {
+ cp ${WORKDIR}/Makefile .
+ oe_runmake
+}
+
+do_install () {
+ install -d ${D}/usr/lib
+ install -m 0755 ${S}/libjsoncpp.so ${D}/usr/lib
+ install -d ${D}${includedir}/jsoncpp/json
+ install -m 0755 ${S}/include/json/*.h ${D}${includedir}/jsoncpp/json
+}
+
+FILES_SOLIBSDEV = ""
+FILES_${PN} += "${libdir}/*.so"
+FILES_{PN}-dev += "${libdir}/*.so"